Windows 10 indexing restarts

Hi all,
I have a laptop and the indexing will randomly restart. This has been ongoing for 5-6 months.

Windows V10.0.16299.192
Office 2016
All updates have been installed

Indexing restarts causing Outlook searches to be incomplete
Event Viewer ID 29- The store is being re-pushed to the indexer for the following reason: Index reset (or catalog signature change), re-push entire store.

Event ID 30- Starting reconciliation for the store for the following reason: ScopeID does not match with what we have saved locally.

Event ID 31- The store  has detected a catalog rebuild.

This user lives inside of Outlook and probably searches 50+ times a day. He has 5 PST files attached to Outlook plus his Archive.pst and OST. He also has a gmail account using IMAP.

About 2 months ago I installed a new SSD and reinstalled Windows from scratch using Fall Creators Update. Things worked well for about 6 weeks, but the problem returned. Other than Windows updates, there have only been two updates since then.
Video drivers about 3 weeks ago and  ITunes 5 weeks ago.

Anyone have any ideas?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
That is a Windows issue - Office uses the Windows Search.

Open cmd.exe with Run as Administrator and run dism.exe /online /cleanup-image /restorehealth

When done, restart and the go to Control Panel, Indexing Options. Make sure Users and Outlook are both in Locations along with anything else you want.

Then go to Advanced, and rebuild the index. Let it run overnight to completion.

Then check again.
elsteefAuthor Commented:
Thanks John. I had already tried SFC, but never DISM.
I also uninstalled the video driver update since it sort of corresponds to when the trouble started.

Re-indexing now....

elsteefAuthor Commented:
Good morning,
The problem has returned with a new twist.

I received several new errors this morning.
Event 36- Search cannot complete the indexing of your Outlook data. Error=0x8094081f.
Event 623- SearchIndexer Windows: The version store for this instance has reached maximum size of 128Mb. It is likely that a ling-running transaction is preventing cleanup of version store and causing it to build up in size.
Event 637- SearchIndexer Windows: New flush map file will be created to enable persisted lost flush detection.
Event 1019- Windows Search Service failed to process the list of included and excluded locations with the error <30, 0x80004005
Event 1005- The Windows Search Service has successfully created the new search index.

Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

JohnBusiness Consultant (Owner)Commented:
You can try 2 things here:

1. Try a different Windows User Profile and see if the issue remains in a new profile. That could take time if just test a new profile.

2. Try a non-destructive Windows 10 Repair Install and Keep Everything. This corrects the OS but does not correct a damaged user profile.

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.
elsteefAuthor Commented:
I seemed to have it figured out.

The indexing was restarting a couple of times a day. It always showed the  Microsoft Exchange Add-in was crashing right before the indexing restarted.
After trying everything else I could think of, including reloading windows, I disabled the add-in. I disabled it on my computer as well as the owners.
Its been about 12 days and everything is still working. It doesn't seem like that add-in is required for O365. I don't see any difference in functionality.
I found a couple of posts saying it was needed to access shared resources in O365, but I still have access to all mine with it disabled.

Thanks John for your suggestions. I'll give you "assisted solution" for taking time to help.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
elsteefAuthor Commented:
All of the suggested solutions had already been tried or weren't helpful. I marked John as "assisted solution" since he was the only person that responded to my post.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.