Restore missing partition table to a SD card

I was attempting to write an Open Media Vault image to a 16GB Sandisk SD card with Etcher but after I tried to boot the target system it would not detect  the card.  I tried to use GParted and it complained that there is no partition table on the dive.  Although GParted has an option to create a new partition table it doesn't persist the change to the dirive.  I tried using fdisk and dd command with various options but they both report that "there is no space on the device"  

Has anybody had this happen before?  Were you able to resolve it?
LVL 2
Garfield SamuelsProject ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
Try filling the first few thousand sectors of the drive with zeros using a tool such as the free version of Active@ Killdisk.  This will destroy any remnants of previous partition tables.  There is no need to erase the entire drive, 2% of it should be sufficient.

If Killdisk reports problems with erasing the drive then the drive has hardware issues and should be discarded.  There's no fix to flash memory.  If it's still in warranty you can ship it back for replacement.

Then, if the drive is still readable and writable -- and it sounds like there may indeed be some hardware problems with this particular card -- you can try reinitializing it.

http://www.killdisk.com/killdisk-home.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
is the card reader seen in the bios? i'm not sure, but it looks like the reader does need drivers - which it has not at boot time
0
Dr. KlahnPrincipal Software EngineerCommented:
Expert comments apposite and should be useful.  No further comment from requester; points split among responders.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.