Security Package Error in Remote Desktop

RDP-Error.PNGRDP LoginRDP Gateway SettingsHi,

In the last two weeks, I ran "Feature updates to WIndows 10 version 1709" on all Windows 10 PCs and ran Windows updates on SBS2011 servers.
Since then, I think, I started getting this error when Remote Desktop begins to try to make the connection to any computer inside SBS2011 Network.  When I keep trying RDP despite this error, RDP connection is made eventually.

Do you know how I can fix this?

Thanks.
LVL 1
sgleeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masnrockCommented:
A workaround would be to clear the cached credentials and re-enter them. Please follow the steps below:

Right click on the Remote Desktop Connection Icon (this is the RDP file you use to connect) and choose the edit option from the context menu

From the Remote Desktop Connection Dialog Box select the Advanced tab

On the Advanced tab you will see a area named “Connect from anywhere” click the Settings…button

You will see a RD Gateway Server Settings Dialog in the Logon Settings area click the “delete” link where it says “You can edit or delete these credentials”

You need to click “Yes” confirm the deletion when prompted

Click OK and then click the “Connect” button.

You will prompted to re-enter your credentials. Check the “Remember me” checkbox only if the computer login you are using is not shared with other users.

Continue to log in as normal
0
sgleeAuthor Commented:
@masnrock
I tried the above and it worked. However next time, I am back to the same error all over again. How do I fix this problem permanently?
I have many .RDP file and use them to connect to each computer that I manage remotely.
I hope I don't have to go thru this inconvenience each time I need to connect ...
0
masnrockCommented:
So i was in Microsoft forums... and the cause is related to a Windows 10 update. There is a Remote Credential Guard at the root of it all. There is no actual fix. However, if you copy 2 files (mstsc.exe and mstscax.dll) from a system with Windows 10 1607, you shouldn't get the error anymore.

https://partnersupport.microsoft.com/en-us/par_servplat/forum/par_winserv/rd-gateway-and-saved-credentials/36903a8c-8c20-42b3-bc4a-59426a167f62
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
masnrockCommented:
Answered and solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.