The system administrator has limited the computers you can log on with.

When I try to RDP on to a system I have designated in the 'Log On To' section for the user in Active Directory, I get the following message 'The system administrator has limited the computers you can log on with. Try logging on at a different computer. If the problem continues, contact your system administrator(That would be me) or technical support.'

I have tried/checked the following:
  • Made sure the allow connections only... With Network Level Authentication was unchecked.
  • Added the user in the Remote Desktop policy on the target computer.
  • Added the user as an administrator on target computer.
  • Made sure I added my Domain Controllers in the list of allowed computers to access.

I have tried a few other things as well, but honestly the above has always worked for me.

I should note that when I switch from limiting this user to only the computers I want to allow them access to, to allowing them access to All Computers, this user account then can login with and RDP session just fine.
Patrick MontgomeryNetwork AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
McKnifeCommented:
This could be a replication problem. DCs should replicate this change within 15 seconds, but sometimes, replication is struggeling. Use dcdiag on all DCs.
0
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
I've manually replicated each of the DC's to no avail.
0
 
PberSolutions ArchitectCommented:
You need to also add the computer name the user is coming from as well.  Seems odd, but is required.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KuppingerCole Reviews AlgoSec in Executive Report

Leading analyst firm, KuppingerCole reviews AlgoSec's Security Policy Management Solution, and the security challenges faced by companies today in their Executive View report.

 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
Seems like I had tried that too, but let me try that again. Are you saying to add it under Remote Desktop along with the user?
0
 
Shaun VermaakTechnical Specialist/DeveloperCommented:
Longshot but please check
account-log-on-to-setting-1-.png
0
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
Shaun that is the first thing I did. That is what's causing the issue. If I set it to all computer RDP works fine.
0
 
PberSolutions ArchitectCommented:
Did you add the computer that the user is RDPing from?
0
 
McKnifeCommented:
Pber's comment is correct, for RDP with NLA ("network level authentication") active, which is the default since some years, you have to add the machine name were you come from as well.
1
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
About to try that now.
0
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
Both my user account and machine name are added here in the Local Security policy of the machine I am trying to RDP in to.
I still have the same issue.

2018-01-23_9-57-36.jpg
0
 
McKnifeCommented:
You are doing several things that are unneded. Never add a computer account there, sorry, that is just desperate :-)
PBer talked about the "logon to" button in Shawn's screenshot - there you need to add both, source and target machine, for the account you are trying to connect with.
1
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
Ohhh got it. Yeah getting desperate for sure. Will try that.
0
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
Yep that did. Thanks!
0
 
Patrick MontgomeryNetwork AdministratorAuthor Commented:
This comment fixed my issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.