Wireless randomly handing out bad IP addresses

I recently took over support for an office that is running an old set of Cisco Aironet routers. This office has a good amount of wireless devices - at least 15-20 laptops and computers, along with Nest thermostats, carbon dioxide sensors, and more. What seems to happen is randomly a connected computer will suddenly lose it's connection. Where normally the connection will be 192.168.1.X (Their standard subnet) a computer will randomly drop and suddenly show a 192.168.0.X address, complete with 192.168.0 gateway and no internet access. After sometime the connection will re-establish.

Now I'm 99% sure this is simply the old Wi-Fi network unable to keep up with the number of wireless devices and it's dropping and re-acquiring leases. I just wanted to confirm that anyone else has seen this before. I was planning on replacing the Wi-Fi anyway, but it seems odd. In my experience, when a computer only has limited connectivity it would show something like a 169 address, or no address at all. The fact that it's suddenly coming up with a 192.168.0 address seems oddly specific.

Thanks for any input you might have.
TarkisalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Nest thermostats, carbon dioxide sensors, and more...

Try setting these devices with Static IP addresses in the non-DHCP address area of your router.

More practically, upgrade your router to a more modern N or N/AC wireless router.
1
David SankovskySenior SysAdminCommented:
I Agree with John on this one, Generally, I'd only allow simple endpoint computers to run off DHCP everything else (iOT devices, server and etc.) Would run off Static IP Addresses (Don't forget to remove those addresses from the DHCP server pool).

As to your problem, if it also happens to computers as well as the iOT devices, there are several things to check.
As soon as a computer would obtain a different IP Address, run the ipconfig /all | find "DHCP Server" command to see which server allocated the address to the computer. (this step could be completely useless however if both Ranges are dealt by the same DHCP server)
1
TarkisalAuthor Commented:
Thank you for your comments. I replaced the existing wifi network with a brand new Unifi network that seems to be working well. And yet, the problem remains. Random computers will suddenly lose their standard 192.168.1.X address and replace it with 192.168.0.X with a different gateway and DNS server. I'm not sure how they're even getting this information.

I did notice all of the Nest devices appear to be pulling the 192.168.0.X address no matter what. I'm suspecting they are the root cause of this problem.

I think I will have to go through and set each laptop and Nest to a static IP, as you suggested. Now I just have to figure out how to change the IP on the Nest equipment.
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Blue Street TechLast KnightCommented:
Hi Tarkisal,

Random computers will suddenly lose their standard 192.168.1.X address and replace it with 192.168.0.X with a different gateway and DNS server.
When the computer gets a different IP address what address is the Gateway, DHCP Server and DNS servers? And can you ping the DHCP server?

I did notice all of the Nest devices appear to be pulling the 192.168.0.X address no matter what. I'm suspecting they are the root cause of this problem.
The Nest devices are not the root cause. You can easily prove this by removing them entirely - the same issue will persist with the rest of the network. Why? because Nest devices are simple from a networking standpoint and only receive the IP config given to them...they cannot relay nor are they a DNS or DHCP server.

I think I will have to go through and set each laptop and Nest to a static IP, as you suggested.
This is not a solution...this is only a testing mechanism. This is a poor way to manage networks. Think about how large networks are managed - never by device-based static assignments excluding servers. Conversely you should manage your network through Static Assignments (MAC-based) from within your network appliances (if that is where your DHCP server resides) or if you DHCP servers reside in Windows then you'd use DHCP Reservations. Irrespectively, this is not the solution - you need to find the root cause, which I believe is another DHCP server within your network.

Now I just have to figure out how to change the IP on the Nest equipment.
This is not possible unless via Static Assignment (network appliance) or through DHCP Reservations (Windows).

Nest devices are simple IoT nework devices - they do not have capabilities for anything except receiving an IP address via DHCP or DHCP Reservations (MAC based assignment). We have 16 Nest devices in our network - I know them well and they don't cause this type of behavior whatsoever. Again, it sounds to me like you have another DHCP server within your network. When the laptop gets assigned a 192.168.0.0 address perform an ipconfig /all | find "DHCP Server" as David suggested and see what the DHCP server address is. Can you ping it? Track it down and remove it from the network.

Let me know. Thanks!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TarkisalAuthor Commented:
All,

Thank you very much for your quick and helpful responses. I apologize, I didn't see the Find DHCP server message earlier. I did a search, as suggested, and it pointed me to 192.168.0.1. Connecting to that brings me to the Arris cable modem provided by Spectrum. I now believe this cable modem needs to be configured to not provide DHCP, which SHOULD fix the problem. I am working on getting this done now, and will update this ticket when I have my results.

Thanks
0
Blue Street TechLast KnightCommented:
You are welcome!

Yes, put that in Bridge aka Transparent mode or otherwise disable its DHCP server...nothing should be connected to it except the SonicWALL. You may need to reconfigure the WAN IP Assignment from DHCP to Static IP provided that you have one.

Let me know if you have any other questions!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.