Share permissions Server 2016

Migrating to Server 2016. The server in question is both the PDC and file server, two partitions, C and D.
D partition has the default share of D$, and this is where shares will be created from the folder tree located there.

The problem is that I can create shares all day long, with custom permissions, but the default attribute on any folder created inside of D$ is Read Only. The vendor states that it is because I created the shares via Computer Management and not the Share Wizard. Used the Share Wizard, same result.

Some articles state that this is a "default attribute" and that's just the way it is. Others suggest a command line permissions adjustment, using

ATTRIB -R /D /S "<Foldername>
or
attrib -r -s c:\test

Neither solves the problem, at least not according to the GUI.  I can't believe this to be the "way it is" because a read only shared service wouldn't work very well, and this problem has been around since Server 2008. My best guess is that unlike what I am used to, the Read Only attribute means nothing, and the share permissions over ride the folder attributes.

Yes or no? I can't really roll out a new server and domain to the users as a read only kernel. Am I missing something here?

Thanks.
read only attrib
afrendAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
An "old new thing". Just disregard it, the checkbox has no meaning in this case.
0
afrendAuthor Commented:
Is it really that way? When I remove it, I get a dialog box asking me what I want to do, two options, one greyed out.
Apply it, and it goes through the motions of reassigning permissions, then returns to a read only attribute.
Thanks.
attrib.jpg
0
McKnifeCommented:
You don't have to do anything. leave it alone.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
afrendAuthor Commented:
OK. Any idea why it is that way? Just curious.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.