SQL 2016 Integration Services

Hi All

I'm trying to understand why I cannot see Integration in msdb.dbo.syscategories. The SQL instance I'm running is MS SQL 2016 Standard SP1, version details below

Microsoft SQL Server Management Studio                                    13.0.16000.28
Microsoft Analysis Services Client Tools                                            13.0.1700.441
Microsoft Data Access Components (MDAC)                                    10.0.14393.0
Microsoft MSXML                                                                                     3.0 6.0
Microsoft Internet Explorer                                                             9.11.14393.0
Microsoft .NET Framework                                                             4.0.30319.42000
Operating System                                                                             6.3.14393

In the syscategories I can see 22 items, see below

name
[Uncategorized (Local)]
[Uncategorized (Multi-Server)]
[Uncategorized]
[Uncategorized]
Data Collector
Database Engine Tuning Advisor
Database Maintenance
Full-Text
Jobs from MSX
Log Shipping
REPL-Alert Response
REPL-Checkup
REPL-Distribution
REPL-Distribution Cleanup
REPL-History Cleanup
Replication
REPL-LogReader
REPL-Merge
REPL-QueueReader
REPL-Snapshot
REPL-Subscription Cleanup
Reports

Open in new window


In the SQL Object Explorer, I can see Integration Services Catalogs and the Integrated Services is enabled as a feature whilst running MS SQL 2016 Setup (see SQL Features.pdf).

What I'm trying to do here is create a SQL Job and select Integration in the Category (see Category List). The Server OS is Windows Server 2016 Datacenter. Any help is greatly appreciated!

StevieSQL-Features.pdfCategory-List.pdf
Stevie ZakhourAsked:
Who is Participating?
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Category it's informational only and doesn't have any impact on the job.
Perhaps want you want is to configure a Job Step to run a SSIS package? If so, then in the job step you'll need to change the Type to SSIS:
SQLJob_SSIS_type.PNG
1
 
Stevie ZakhourAuthor Commented:
Thanks mate, that worked! Apologies for the delay too.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.