Terminal Users randomly disconnecting

Hi all,

We host a Windows Server 2008 R2 terminal server for six users and two of the users are reporting being randomly disconnected without any disconnection display message or reason.

In event viewer I can see the following error events which might be related:

Event ID 56 TermDD

Please can someone help me troubleshoot the above error event and help determine if this is the cause or a red herring?

regards
Adrian
Server GuyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hello ThereSystem AdministratorCommented:
I haven't met this but I can provide some info what helped others:
- Update RDP client side.
- Update NIC Drivers
- Disable IPv4 Large Send Offload, Checksum Offload, and TCP Connection Offload
- Disable TCP Chimney Offload using command: netsh int tcp set global chimney=disabled
- Disable RSS in Windows Server 2008 R2 using command: netsh int tcp set global rss=disabled


From MS Technet:
The RDS services may be conflicts to Automatic Updates service. Since some updates may require restarting the computer. At this point, the terminal services will be temporary not available.

So, if it’s possible, please try reboot the RDS server to see if it’s fixed.

For the Event ID 56 and 50 error, you can try to change the security layer from Negotiate to RDP Security Layer on Terminal server to see if the same issue still exists.

In my experience, this issue is usually related to network problems. Updating NIC drivers, checking the switches, setting the speed of NIC's to auto in the Windows client PC. Then you can try again.

Change these registry settings on the client and server
ON RDP client:
[HKCU\Software\Microsoft\Terminal Server Client]
"Keep Alive Interval"=dword:00000001
On RDP server:
[HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server]
"KeepAliveInterval"=dword:00000001
"KeepAliveEnable"=dword:00000001
Disable all SNP Features on the server (from admin cmd)
netsh int tcp set global chimney=disabled
netsh int tcp set global rss=disabled
netsh int tcp set global taskoffload=disabled
netsh int tcp set global autotuninglevel=disabled
netsh int tcp set global congestionprovider=none
netsh int tcp set global ecncapability=disabled
netsh int tcp set global timestamps=disabled
Disable IPv6 on server and client

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Server GuyAuthor Commented:
Updating the RDP security layer to RDP security appears to have resolved this issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.