Installing Test::More and Text::Template Perl modules

Hi, I need some help installing Test::More and Text::Template Perl modules. These modules are required by OpenSSH 7.6p1 and OpenSSL 1.1.0g installations.

I'm running Red Hat Enterprise Linux Server 7.4 (Maipo)‬ and Perl 5.16.3.

I checked the installed modules and those two modules are not listed and I don't think they are available from the repos on my system.

I need to make sure they are properly installed so that I can proceed to install OpensSSH 7.6p1 on my server.

Thanks,

Jorge Batres.
Jorge BatresAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FishMongerCommented:
Test::More is a core module and should already be installed.

I don't see Text::Template in the yum repos that I point to and not sure which repo would have it.  But I did find an rpm for CentOS 7 which should be compatible.

Another option would be to install it via cpanm.
FishMongerCommented:
Correction, I did find it in yum

[root@iso101 rkb]# yum list | grep Text-Template
perl-Text-Template.noarch            1.45-3.el6              epel6-x86_64

[root@iso101 rkb]# yum info perl-Text-Template
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile
Available Packages
Name        : perl-Text-Template
Arch        : noarch
Version     : 1.45
Release     : 3.el6
Size        : 61 k
Repo        : epel6-x86_64
Summary     : Expand template text with embedded Perl
License     : GPL+ or Artistic
Description : This is a library for generating form letters, building HTML pages, or
            : filling in templates generally.  A 'template' is a piece of text that
            : has little Perl programs embedded in it here and there.  When you
            : 'fill in' a template, you evaluate the little programs and replace
            : them with their values.
Jorge BatresAuthor Commented:
Hi FishMonger, I tried running that command in my server but nothing happened :(

Thanks,

Jorge Batres
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

FishMongerCommented:
Do you mean that you don't have yum or do you mean that it didn't find Text-Template?
Jorge BatresAuthor Commented:
I do have yum but when I typed that command nothing happened
FishMongerCommented:
Do you have the epel6-x86_64 repo?

Run this command to see your repos: yum repolist
Jorge BatresAuthor Commented:
I just installed perl-core but I don't think it included the modules I need. Please see below:

[root@web ~]# yum list perl
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
perl.x86_64                 4:5.16.3-292.el7                 @rhel-7-server-rpms
[root@web ~]# yum list perl-core
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Available Packages
perl-core.x86_64                5.16.3-292.el7                rhel-7-server-rpms
[root@web ~]# yum install perl-core
Loaded plugins: product-id, search-disabled-repos, subscription-manager
PLESK_17_5_3-extras                                      | 2.9 kB     00:00    
PLESK_17_NGINX                                           | 2.9 kB     00:00    
PLESK_17_PHP52                                           | 2.9 kB     00:00    
PLESK_17_PHP53                                           | 2.9 kB     00:00    
PLESK_17_PHP54                                           | 2.9 kB     00:00    
PLESK_17_PHP55                                           | 2.9 kB     00:00    
PLESK_17_PHP56                                           | 2.9 kB     00:00    
PLESK_17_PHP70                                           | 2.9 kB     00:00    
PLESK_17_PHP71                                           | 2.9 kB     00:00    
PLESK_17_PHP72                                           | 2.9 kB     00:00    
mariadb                                                  | 2.9 kB     00:00    
plesk-migrator                                           | 2.9 kB     00:00    
plesk-migrator-tp                                        | 2.9 kB     00:00    
rhel-7-server-optional-rpms                              | 2.3 kB     00:00    
rhel-7-server-rpms                                       | 2.3 kB     00:00    
rhel-7-server-supplementary-rpms                         | 2.3 kB     00:00    
(1/22): PLESK_17_PHP52/primary_db                          |  13 kB   00:00    
(2/22): PLESK_17_PHP55/primary_db                          |  13 kB   00:00    
(3/22): PLESK_17_PHP54/primary_db                          |  13 kB   00:00    
(4/22): PLESK_17_NGINX/primary_db                          | 3.2 kB   00:00    
(5/22): PLESK_17_PHP56/primary_db                          |  14 kB   00:00    
(6/22): PLESK_17_PHP70/primary_db                          |  14 kB   00:00    
(7/22): PLESK_17_PHP71/primary_db                          |  14 kB   00:00    
(8/22): PLESK_17_PHP72/primary_db                          |  13 kB   00:00    
(9/22): plesk-migrator/primary_db                          | 6.3 kB   00:00    
(10/22): plesk-migrator-tp/primary_db                      | 1.1 kB   00:00    
(11/22): mariadb/primary_db                                |  21 kB   00:00    
(12/22): rhel-7-server-optional-rpms/7Server/x86_64/group  |  19 kB   00:00    
(13/22): PLESK_17_PHP53/primary_db                         |  13 kB   00:00    
(14/22): PLESK_17_5_3-extras/primary_db                    |  26 kB   00:00    
(15/22): rhel-7-server-rpms/7Server/x86_64/group           | 598 kB   00:00    
(16/22): rhel-7-server-optional-rpms/7Server/x86_64/update | 4.6 MB   00:00    
(17/22): rhel-7-server-supplementary-rpms/7Server/x86_64/u |  68 kB   00:00    
(18/22): rhel-7-server-optional-rpms/7Server/x86_64/primar | 3.6 MB   00:00    
(19/22): rhel-7-server-supplementary-rpms/7Server/x86_64/g |  34 kB   00:00    
(20/22): rhel-7-server-supplementary-rpms/7Server/x86_64/p | 103 kB   00:00    
(21/22): rhel-7-server-rpms/7Server/x86_64/updateinfo      | 5.0 MB   00:01    
(22/22): rhel-7-server-rpms/7Server/x86_64/primary         |  37 MB   00:04    
rhel-7-server-optional-rpms                                         21155/21155
rhel-7-server-rpms                                                  31329/31329
rhel-7-server-supplementary-rpms                                        351/351
Resolving Dependencies
--> Running transaction check
---> Package perl-core.x86_64 0:5.16.3-292.el7 will be installed
--> Processing Dependency: perl-autodie for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Version-Requirements for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Time-Piece for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Text-Soundex for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Test-Simple for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Term-UI for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Pod-Parser for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Pod-LaTeX for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Pod-Checker for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Perl-OSType for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Parse-CPAN-Meta for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Params-Check for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Object-Accessor for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Pluggable for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Metadata for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Loaded for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Load-Conditional for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Load for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-CoreList for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Module-Build for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Log-Message-Simple for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Log-Message for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Locale-Maketext-Simple for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Locale-Maketext for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Locale-Codes for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-JSON-PP for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-IPC-Cmd for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-File-Fetch for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-File-CheckTree for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-ExtUtils-Embed for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-ExtUtils-CBuilder for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Env for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPANPLUS-Dist-Build for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPANPLUS for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPAN-Meta-YAML for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPAN-Meta-Requirements for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPAN-Meta for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CPAN for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-CGI for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-B-Lint for package: perl-core-5.16.3-292.el7.x86_64
--> Processing Dependency: perl-Archive-Extract for package: perl-core-5.16.3-292.el7.x86_64
--> Running transaction check
---> Package perl-Archive-Extract.noarch 1:0.68-3.el7 will be installed
---> Package perl-B-Lint.noarch 0:1.17-3.el7 will be installed
---> Package perl-CGI.noarch 0:3.63-4.el7 will be installed
--> Processing Dependency: perl(FCGI) >= 0.67 for package: perl-CGI-3.63-4.el7.noarch
---> Package perl-CPAN.noarch 0:1.9800-292.el7 will be installed
--> Processing Dependency: perl(local::lib) for package: perl-CPAN-1.9800-292.el7.noarch
---> Package perl-CPAN-Meta.noarch 0:2.120921-5.el7 will be installed
---> Package perl-CPAN-Meta-Requirements.noarch 0:2.122-7.el7 will be installed
---> Package perl-CPAN-Meta-YAML.noarch 0:0.008-14.el7 will be installed
---> Package perl-CPANPLUS.noarch 0:0.91.38-4.el7 will be installed
--> Processing Dependency: perl(DBIx::Simple) for package: perl-CPANPLUS-0.91.38-4.el7.noarch
--> Processing Dependency: perl(DBD::SQLite) for package: perl-CPANPLUS-0.91.38-4.el7.noarch
---> Package perl-CPANPLUS-Dist-Build.noarch 0:0.70-3.el7 will be installed
---> Package perl-Env.noarch 0:1.04-2.el7 will be installed
---> Package perl-ExtUtils-CBuilder.noarch 1:0.28.2.6-292.el7 will be installed
---> Package perl-ExtUtils-Embed.noarch 0:1.30-292.el7 will be installed
---> Package perl-File-CheckTree.noarch 0:4.42-3.el7 will be installed
---> Package perl-File-Fetch.noarch 0:0.42-2.el7 will be installed
---> Package perl-IPC-Cmd.noarch 1:0.80-4.el7 will be installed
---> Package perl-JSON-PP.noarch 0:2.27202-2.el7 will be installed
---> Package perl-Locale-Codes.noarch 0:3.26-2.el7 will be installed
---> Package perl-Locale-Maketext.noarch 0:1.23-3.el7 will be installed
---> Package perl-Locale-Maketext-Simple.noarch 1:0.21-292.el7 will be installed
---> Package perl-Log-Message.noarch 1:0.08-3.el7 will be installed
---> Package perl-Log-Message-Simple.noarch 0:0.10-2.el7 will be installed
---> Package perl-Module-Build.noarch 2:0.40.05-2.el7 will be installed
---> Package perl-Module-CoreList.noarch 1:2.76.02-292.el7 will be installed
---> Package perl-Module-Load.noarch 1:0.24-3.el7 will be installed
---> Package perl-Module-Load-Conditional.noarch 0:0.54-3.el7 will be installed
---> Package perl-Module-Loaded.noarch 1:0.08-292.el7 will be installed
---> Package perl-Module-Metadata.noarch 0:1.000018-2.el7 will be installed
---> Package perl-Module-Pluggable.noarch 1:4.8-3.el7 will be installed
---> Package perl-Object-Accessor.noarch 1:0.42-292.el7 will be installed
---> Package perl-Params-Check.noarch 1:0.38-2.el7 will be installed
---> Package perl-Parse-CPAN-Meta.noarch 1:1.4404-5.el7 will be installed
---> Package perl-Perl-OSType.noarch 0:1.003-3.el7 will be installed
---> Package perl-Pod-Checker.noarch 0:1.60-2.el7 will be installed
---> Package perl-Pod-LaTeX.noarch 0:0.61-2.el7 will be installed
---> Package perl-Pod-Parser.noarch 0:1.61-2.el7 will be installed
---> Package perl-Term-UI.noarch 0:0.36-2.el7 will be installed
---> Package perl-Test-Simple.noarch 0:0.98-243.el7 will be installed
---> Package perl-Text-Soundex.x86_64 0:3.04-4.el7 will be installed
--> Processing Dependency: perl(Text::Unidecode) for package: perl-Text-Soundex-3.04-4.el7.x86_64
---> Package perl-Time-Piece.x86_64 0:1.20.1-292.el7 will be installed
---> Package perl-Version-Requirements.noarch 0:0.101022-244.el7 will be installed
---> Package perl-autodie.noarch 0:2.16-2.el7 will be installed
--> Running transaction check
---> Package perl-DBD-SQLite.x86_64 0:1.39-3.el7 will be installed
---> Package perl-DBIx-Simple.noarch 0:1.35-7.el7 will be installed
---> Package perl-FCGI.x86_64 1:0.74-8.el7 will be installed
---> Package perl-Text-Unidecode.noarch 0:0.04-20.el7 will be installed
---> Package perl-local-lib.noarch 0:1.008010-4.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch   Version            Repository          Size
================================================================================
Installing:
 perl-core                   x86_64 5.16.3-292.el7     rhel-7-server-rpms  42 k
Installing for dependencies:
 perl-Archive-Extract        noarch 1:0.68-3.el7       rhel-7-server-rpms  28 k
 perl-B-Lint                 noarch 1.17-3.el7         rhel-7-server-rpms  20 k
 perl-CGI                    noarch 3.63-4.el7         rhel-7-server-rpms 250 k
 perl-CPAN                   noarch 1.9800-292.el7     rhel-7-server-rpms 293 k
 perl-CPAN-Meta              noarch 2.120921-5.el7     rhel-7-server-rpms 113 k
 perl-CPAN-Meta-Requirements noarch 2.122-7.el7        rhel-7-server-rpms  24 k
 perl-CPAN-Meta-YAML         noarch 0.008-14.el7       rhel-7-server-rpms  24 k
 perl-CPANPLUS               noarch 0.91.38-4.el7      rhel-7-server-rpms 307 k
 perl-CPANPLUS-Dist-Build    noarch 0.70-3.el7         rhel-7-server-rpms  29 k
 perl-DBD-SQLite             x86_64 1.39-3.el7         rhel-7-server-rpms 1.3 M
 perl-DBIx-Simple            noarch 1.35-7.el7         rhel-7-server-rpms  43 k
 perl-Env                    noarch 1.04-2.el7         rhel-7-server-rpms  16 k
 perl-ExtUtils-CBuilder      noarch 1:0.28.2.6-292.el7 rhel-7-server-rpms  67 k
 perl-ExtUtils-Embed         noarch 1.30-292.el7       rhel-7-server-rpms  50 k
 perl-FCGI                   x86_64 1:0.74-8.el7       rhel-7-server-rpms  42 k
 perl-File-CheckTree         noarch 4.42-3.el7         rhel-7-server-rpms  18 k
 perl-File-Fetch             noarch 0.42-2.el7         rhel-7-server-rpms  27 k
 perl-IPC-Cmd                noarch 1:0.80-4.el7       rhel-7-server-rpms  34 k
 perl-JSON-PP                noarch 2.27202-2.el7      rhel-7-server-rpms  55 k
 perl-Locale-Codes           noarch 3.26-2.el7         rhel-7-server-rpms 314 k
 perl-Locale-Maketext        noarch 1.23-3.el7         rhel-7-server-rpms  93 k
 perl-Locale-Maketext-Simple noarch 1:0.21-292.el7     rhel-7-server-rpms  50 k
 perl-Log-Message            noarch 1:0.08-3.el7       rhel-7-server-rpms  29 k
 perl-Log-Message-Simple     noarch 0.10-2.el7         rhel-7-server-rpms  11 k
 perl-Module-Build           noarch 2:0.40.05-2.el7    rhel-7-server-rpms 282 k
 perl-Module-CoreList        noarch 1:2.76.02-292.el7  rhel-7-server-rpms  85 k
 perl-Module-Load            noarch 1:0.24-3.el7       rhel-7-server-rpms  11 k
 perl-Module-Load-Conditional
                             noarch 0.54-3.el7         rhel-7-server-rpms  18 k
 perl-Module-Loaded          noarch 1:0.08-292.el7     rhel-7-server-rpms  46 k
 perl-Module-Metadata        noarch 1.000018-2.el7     rhel-7-server-rpms  26 k
 perl-Module-Pluggable       noarch 1:4.8-3.el7        rhel-7-server-rpms  29 k
 perl-Object-Accessor        noarch 1:0.42-292.el7     rhel-7-server-rpms  55 k
 perl-Params-Check           noarch 1:0.38-2.el7       rhel-7-server-rpms  18 k
 perl-Parse-CPAN-Meta        noarch 1:1.4404-5.el7     rhel-7-server-rpms  14 k
 perl-Perl-OSType            noarch 1.003-3.el7        rhel-7-server-rpms  20 k
 perl-Pod-Checker            noarch 1.60-2.el7         rhel-7-server-rpms  28 k
 perl-Pod-LaTeX              noarch 0.61-2.el7         rhel-7-server-rpms  35 k
 perl-Pod-Parser             noarch 1.61-2.el7         rhel-7-server-rpms 107 k
 perl-Term-UI                noarch 0.36-2.el7         rhel-7-server-rpms  22 k
 perl-Test-Simple            noarch 0.98-243.el7       rhel-7-server-rpms 170 k
 perl-Text-Soundex           x86_64 3.04-4.el7         rhel-7-server-rpms  19 k
 perl-Text-Unidecode         noarch 0.04-20.el7        rhel-7-server-rpms 114 k
 perl-Time-Piece             x86_64 1.20.1-292.el7     rhel-7-server-rpms  69 k
 perl-Version-Requirements   noarch 0.101022-244.el7   rhel-7-server-rpms  21 k
 perl-autodie                noarch 2.16-2.el7         rhel-7-server-rpms  77 k
 perl-local-lib              noarch 1.008010-4.el7     rhel-7-server-rpms  64 k

Transaction Summary
================================================================================
Install  1 Package (+46 Dependent packages)

Total download size: 4.5 M
Installed size: 14 M
Is this ok [y/d/N]: y
Downloading packages:
(1/47): perl-Archive-Extract-0.68-3.el7.noarch.rpm         |  28 kB   00:00    
(2/47): perl-B-Lint-1.17-3.el7.noarch.rpm                  |  20 kB   00:00    
(3/47): perl-CPAN-1.9800-292.el7.noarch.rpm                | 293 kB   00:00    
(4/47): perl-CGI-3.63-4.el7.noarch.rpm                     | 250 kB   00:00    
(5/47): perl-CPAN-Meta-2.120921-5.el7.noarch.rpm           | 113 kB   00:00    
(6/47): perl-CPAN-Meta-Requirements-2.122-7.el7.noarch.rpm |  24 kB   00:00    
(7/47): perl-CPAN-Meta-YAML-0.008-14.el7.noarch.rpm        |  24 kB   00:00    
(8/47): perl-CPANPLUS-0.91.38-4.el7.noarch.rpm             | 307 kB   00:00    
(9/47): perl-CPANPLUS-Dist-Build-0.70-3.el7.noarch.rpm     |  29 kB   00:00    
(10/47): perl-DBIx-Simple-1.35-7.el7.noarch.rpm            |  43 kB   00:00    
(11/47): perl-DBD-SQLite-1.39-3.el7.x86_64.rpm             | 1.3 MB   00:00    
(12/47): perl-Env-1.04-2.el7.noarch.rpm                    |  16 kB   00:00    
(13/47): perl-ExtUtils-CBuilder-0.28.2.6-292.el7.noarch.rp |  67 kB   00:00    
(14/47): perl-ExtUtils-Embed-1.30-292.el7.noarch.rpm       |  50 kB   00:00    
(15/47): perl-FCGI-0.74-8.el7.x86_64.rpm                   |  42 kB   00:00    
(16/47): perl-File-CheckTree-4.42-3.el7.noarch.rpm         |  18 kB   00:00    
(17/47): perl-File-Fetch-0.42-2.el7.noarch.rpm             |  27 kB   00:00    
(18/47): perl-IPC-Cmd-0.80-4.el7.noarch.rpm                |  34 kB   00:00    
(19/47): perl-JSON-PP-2.27202-2.el7.noarch.rpm             |  55 kB   00:00    
(20/47): perl-Locale-Codes-3.26-2.el7.noarch.rpm           | 314 kB   00:00    
(21/47): perl-Locale-Maketext-1.23-3.el7.noarch.rpm        |  93 kB   00:00    
(22/47): perl-Log-Message-0.08-3.el7.noarch.rpm            |  29 kB   00:00    
(23/47): perl-Locale-Maketext-Simple-0.21-292.el7.noarch.r |  50 kB   00:00    
(24/47): perl-Log-Message-Simple-0.10-2.el7.noarch.rpm     |  11 kB   00:00    
(25/47): perl-Module-Build-0.40.05-2.el7.noarch.rpm        | 282 kB   00:00    
(26/47): perl-Module-CoreList-2.76.02-292.el7.noarch.rpm   |  85 kB   00:00    
(27/47): perl-Module-Load-0.24-3.el7.noarch.rpm            |  11 kB   00:00    
(28/47): perl-Module-Load-Conditional-0.54-3.el7.noarch.rp |  18 kB   00:00    
(29/47): perl-Module-Loaded-0.08-292.el7.noarch.rpm        |  46 kB   00:00    
(30/47): perl-Module-Metadata-1.000018-2.el7.noarch.rpm    |  26 kB   00:00    
(31/47): perl-Module-Pluggable-4.8-3.el7.noarch.rpm        |  29 kB   00:00    
(32/47): perl-Object-Accessor-0.42-292.el7.noarch.rpm      |  55 kB   00:00    
(33/47): perl-Params-Check-0.38-2.el7.noarch.rpm           |  18 kB   00:00    
(34/47): perl-Parse-CPAN-Meta-1.4404-5.el7.noarch.rpm      |  14 kB   00:00    
(35/47): perl-Perl-OSType-1.003-3.el7.noarch.rpm           |  20 kB   00:00    
(36/47): perl-Pod-Checker-1.60-2.el7.noarch.rpm            |  28 kB   00:00    
(37/47): perl-Pod-LaTeX-0.61-2.el7.noarch.rpm              |  35 kB   00:00    
(38/47): perl-Pod-Parser-1.61-2.el7.noarch.rpm             | 107 kB   00:00    
(39/47): perl-Term-UI-0.36-2.el7.noarch.rpm                |  22 kB   00:00    
(40/47): perl-Text-Soundex-3.04-4.el7.x86_64.rpm           |  19 kB   00:00    
(41/47): perl-Test-Simple-0.98-243.el7.noarch.rpm          | 170 kB   00:00    
(42/47): perl-Time-Piece-1.20.1-292.el7.x86_64.rpm         |  69 kB   00:00    
(43/47): perl-Text-Unidecode-0.04-20.el7.noarch.rpm        | 114 kB   00:00    
(44/47): perl-Version-Requirements-0.101022-244.el7.noarch |  21 kB   00:00    
(45/47): perl-autodie-2.16-2.el7.noarch.rpm                |  77 kB   00:00    
(46/47): perl-core-5.16.3-292.el7.x86_64.rpm               |  42 kB   00:00    
(47/47): perl-local-lib-1.008010-4.el7.noarch.rpm          |  64 kB   00:00    
--------------------------------------------------------------------------------
Total                                              2.2 MB/s | 4.5 MB  00:02    
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : 1:perl-Module-Load-0.24-3.el7.noarch                        1/47
  Installing : perl-Module-Metadata-1.000018-2.el7.noarch                  2/47
  Installing : 1:perl-Module-CoreList-2.76.02-292.el7.noarch               3/47
  Installing : perl-Perl-OSType-1.003-3.el7.noarch                         4/47
  Installing : perl-CPAN-Meta-YAML-0.008-14.el7.noarch                     5/47
  Installing : perl-Pod-Parser-1.61-2.el7.noarch                           6/47
  Installing : 1:perl-Module-Pluggable-4.8-3.el7.noarch                    7/47
  Installing : 1:perl-Module-Loaded-0.08-292.el7.noarch                    8/47
  Installing : perl-CPAN-Meta-Requirements-2.122-7.el7.noarch              9/47
  Installing : perl-JSON-PP-2.27202-2.el7.noarch                          10/47
  Installing : 1:perl-Parse-CPAN-Meta-1.4404-5.el7.noarch                 11/47
  Installing : perl-CPAN-Meta-2.120921-5.el7.noarch                       12/47
  Installing : perl-Locale-Maketext-1.23-3.el7.noarch                     13/47
  Installing : 1:perl-Locale-Maketext-Simple-0.21-292.el7.noarch          14/47
  Installing : 1:perl-Params-Check-0.38-2.el7.noarch                      15/47
  Installing : perl-Module-Load-Conditional-0.54-3.el7.noarch             16/47
  Installing : 1:perl-IPC-Cmd-0.80-4.el7.noarch                           17/47
  Installing : 1:perl-Log-Message-0.08-3.el7.noarch                       18/47
  Installing : 1:perl-Object-Accessor-0.42-292.el7.noarch                 19/47
  Installing : perl-Log-Message-Simple-0.10-2.el7.noarch                  20/47
  Installing : perl-Term-UI-0.36-2.el7.noarch                             21/47
  Installing : 1:perl-ExtUtils-CBuilder-0.28.2.6-292.el7.noarch           22/47
  Installing : 2:perl-Module-Build-0.40.05-2.el7.noarch                   23/47
  Installing : 1:perl-Archive-Extract-0.68-3.el7.noarch                   24/47
  Installing : perl-File-Fetch-0.42-2.el7.noarch                          25/47
  Installing : perl-DBIx-Simple-1.35-7.el7.noarch                         26/47
  Installing : perl-B-Lint-1.17-3.el7.noarch                              27/47
  Installing : perl-Pod-LaTeX-0.61-2.el7.noarch                           28/47
  Installing : perl-Pod-Checker-1.60-2.el7.noarch                         29/47
  Installing : perl-Text-Unidecode-0.04-20.el7.noarch                     30/47
  Installing : perl-Text-Soundex-3.04-4.el7.x86_64                        31/47
  Installing : perl-File-CheckTree-4.42-3.el7.noarch                      32/47
  Installing : 1:perl-FCGI-0.74-8.el7.x86_64                              33/47
  Installing : perl-CGI-3.63-4.el7.noarch                                 34/47
  Installing : perl-autodie-2.16-2.el7.noarch                             35/47
  Installing : perl-Time-Piece-1.20.1-292.el7.x86_64                      36/47
  Installing : perl-Locale-Codes-3.26-2.el7.noarch                        37/47
  Installing : perl-ExtUtils-Embed-1.30-292.el7.noarch                    38/47
  Installing : perl-Test-Simple-0.98-243.el7.noarch                       39/47
  Installing : perl-Env-1.04-2.el7.noarch                                 40/47
  Installing : perl-DBD-SQLite-1.39-3.el7.x86_64                          41/47
  Installing : perl-CPANPLUS-0.91.38-4.el7.noarch                         42/47
  Installing : perl-CPANPLUS-Dist-Build-0.70-3.el7.noarch                 43/47
  Installing : perl-Version-Requirements-0.101022-244.el7.noarch          44/47
  Installing : perl-local-lib-1.008010-4.el7.noarch                       45/47
  Installing : perl-CPAN-1.9800-292.el7.noarch                            46/47
  Installing : perl-core-5.16.3-292.el7.x86_64                            47/47
  Verifying  : perl-local-lib-1.008010-4.el7.noarch                        1/47
  Verifying  : 1:perl-Params-Check-0.38-2.el7.noarch                       2/47
  Verifying  : 1:perl-Module-Pluggable-4.8-3.el7.noarch                    3/47
  Verifying  : perl-B-Lint-1.17-3.el7.noarch                               4/47
  Verifying  : perl-Version-Requirements-0.101022-244.el7.noarch           5/47
  Verifying  : perl-Pod-Parser-1.61-2.el7.noarch                           6/47
  Verifying  : 1:perl-Parse-CPAN-Meta-1.4404-5.el7.noarch                  7/47
  Verifying  : perl-CPAN-Meta-2.120921-5.el7.noarch                        8/47
  Verifying  : 1:perl-ExtUtils-CBuilder-0.28.2.6-292.el7.noarch            9/47
  Verifying  : perl-DBD-SQLite-1.39-3.el7.x86_64                          10/47
  Verifying  : perl-CPANPLUS-Dist-Build-0.70-3.el7.noarch                 11/47
  Verifying  : perl-Locale-Maketext-1.23-3.el7.noarch                     12/47
  Verifying  : 2:perl-Module-Build-0.40.05-2.el7.noarch                   13/47
  Verifying  : perl-CPAN-Meta-YAML-0.008-14.el7.noarch                    14/47
  Verifying  : perl-Env-1.04-2.el7.noarch                                 15/47
  Verifying  : perl-core-5.16.3-292.el7.x86_64                            16/47
  Verifying  : perl-Test-Simple-0.98-243.el7.noarch                       17/47
  Verifying  : perl-Perl-OSType-1.003-3.el7.noarch                        18/47
  Verifying  : perl-Module-Load-Conditional-0.54-3.el7.noarch             19/47
  Verifying  : perl-ExtUtils-Embed-1.30-292.el7.noarch                    20/47
  Verifying  : perl-Locale-Codes-3.26-2.el7.noarch                        21/47
  Verifying  : perl-Pod-LaTeX-0.61-2.el7.noarch                           22/47
  Verifying  : 1:perl-Locale-Maketext-Simple-0.21-292.el7.noarch          23/47
  Verifying  : perl-Time-Piece-1.20.1-292.el7.x86_64                      24/47
  Verifying  : 1:perl-Module-CoreList-2.76.02-292.el7.noarch              25/47
  Verifying  : perl-Log-Message-Simple-0.10-2.el7.noarch                  26/47
  Verifying  : perl-Pod-Checker-1.60-2.el7.noarch                         27/47
  Verifying  : perl-autodie-2.16-2.el7.noarch                             28/47
  Verifying  : perl-CPAN-1.9800-292.el7.noarch                            29/47
  Verifying  : perl-Term-UI-0.36-2.el7.noarch                             30/47
  Verifying  : 1:perl-Log-Message-0.08-3.el7.noarch                       31/47
  Verifying  : perl-CGI-3.63-4.el7.noarch                                 32/47
  Verifying  : 1:perl-Archive-Extract-0.68-3.el7.noarch                   33/47
  Verifying  : 1:perl-FCGI-0.74-8.el7.x86_64                              34/47
  Verifying  : perl-DBIx-Simple-1.35-7.el7.noarch                         35/47
  Verifying  : perl-JSON-PP-2.27202-2.el7.noarch                          36/47
  Verifying  : 1:perl-IPC-Cmd-0.80-4.el7.noarch                           37/47
  Verifying  : perl-File-CheckTree-4.42-3.el7.noarch                      38/47
  Verifying  : perl-CPANPLUS-0.91.38-4.el7.noarch                         39/47
  Verifying  : perl-Text-Unidecode-0.04-20.el7.noarch                     40/47
  Verifying  : 1:perl-Object-Accessor-0.42-292.el7.noarch                 41/47
  Verifying  : perl-File-Fetch-0.42-2.el7.noarch                          42/47
  Verifying  : perl-CPAN-Meta-Requirements-2.122-7.el7.noarch             43/47
  Verifying  : perl-Text-Soundex-3.04-4.el7.x86_64                        44/47
  Verifying  : 1:perl-Module-Loaded-0.08-292.el7.noarch                   45/47
  Verifying  : 1:perl-Module-Load-0.24-3.el7.noarch                       46/47
  Verifying  : perl-Module-Metadata-1.000018-2.el7.noarch                 47/47

Installed:
  perl-core.x86_64 0:5.16.3-292.el7                                            

Dependency Installed:
  perl-Archive-Extract.noarch 1:0.68-3.el7                                      
  perl-B-Lint.noarch 0:1.17-3.el7                                              
  perl-CGI.noarch 0:3.63-4.el7                                                  
  perl-CPAN.noarch 0:1.9800-292.el7                                            
  perl-CPAN-Meta.noarch 0:2.120921-5.el7                                        
  perl-CPAN-Meta-Requirements.noarch 0:2.122-7.el7                              
  perl-CPAN-Meta-YAML.noarch 0:0.008-14.el7                                    
  perl-CPANPLUS.noarch 0:0.91.38-4.el7                                          
  perl-CPANPLUS-Dist-Build.noarch 0:0.70-3.el7                                  
  perl-DBD-SQLite.x86_64 0:1.39-3.el7                                          
  perl-DBIx-Simple.noarch 0:1.35-7.el7                                          
  perl-Env.noarch 0:1.04-2.el7                                                  
  perl-ExtUtils-CBuilder.noarch 1:0.28.2.6-292.el7                              
  perl-ExtUtils-Embed.noarch 0:1.30-292.el7                                    
  perl-FCGI.x86_64 1:0.74-8.el7                                                
  perl-File-CheckTree.noarch 0:4.42-3.el7                                      
  perl-File-Fetch.noarch 0:0.42-2.el7                                          
  perl-IPC-Cmd.noarch 1:0.80-4.el7                                              
  perl-JSON-PP.noarch 0:2.27202-2.el7                                          
  perl-Locale-Codes.noarch 0:3.26-2.el7                                        
  perl-Locale-Maketext.noarch 0:1.23-3.el7                                      
  perl-Locale-Maketext-Simple.noarch 1:0.21-292.el7                            
  perl-Log-Message.noarch 1:0.08-3.el7                                          
  perl-Log-Message-Simple.noarch 0:0.10-2.el7                                  
  perl-Module-Build.noarch 2:0.40.05-2.el7                                      
  perl-Module-CoreList.noarch 1:2.76.02-292.el7                                
  perl-Module-Load.noarch 1:0.24-3.el7                                          
  perl-Module-Load-Conditional.noarch 0:0.54-3.el7                              
  perl-Module-Loaded.noarch 1:0.08-292.el7                                      
  perl-Module-Metadata.noarch 0:1.000018-2.el7                                  
  perl-Module-Pluggable.noarch 1:4.8-3.el7                                      
  perl-Object-Accessor.noarch 1:0.42-292.el7                                    
  perl-Params-Check.noarch 1:0.38-2.el7                                        
  perl-Parse-CPAN-Meta.noarch 1:1.4404-5.el7                                    
  perl-Perl-OSType.noarch 0:1.003-3.el7                                        
  perl-Pod-Checker.noarch 0:1.60-2.el7                                          
  perl-Pod-LaTeX.noarch 0:0.61-2.el7                                            
  perl-Pod-Parser.noarch 0:1.61-2.el7                                          
  perl-Term-UI.noarch 0:0.36-2.el7                                              
  perl-Test-Simple.noarch 0:0.98-243.el7                                        
  perl-Text-Soundex.x86_64 0:3.04-4.el7                                        
  perl-Text-Unidecode.noarch 0:0.04-20.el7                                      
  perl-Time-Piece.x86_64 0:1.20.1-292.el7                                      
  perl-Version-Requirements.noarch 0:0.101022-244.el7                          
  perl-autodie.noarch 0:2.16-2.el7                                              
  perl-local-lib.noarch 0:1.008010-4.el7                                        

Complete!
[root@web ~]# yum list perl
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
perl.x86_64                 4:5.16.3-292.el7                 @rhel-7-server-rpms
[root@web ~]# perl -v

This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi
(with 33 registered patches, see perl -V for more detail)

Copyright 1987-2012, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

[root@web ~]# perl -V
Summary of my perl5 (revision 5 version 16 subversion 3) configuration:
   
  Platform:
    osname=linux, osvers=2.6.32-642.13.1.el6.x86_64, archname=x86_64-linux-thread-multi
    uname='linux x86-017.build.eng.bos.redhat.com 2.6.32-642.13.1.el6.x86_64 #1 smp wed nov 23 16:03:01 est 2016 x86_64 x86_64 x86_64 gnulinux '
    config_args='-des -Doptimize=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -Dccdlflags=-Wl,--enable-new-dtags -Dlddlflags=-shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -Wl,-z,relro  -DDEBUGGING=-g -Dversion=5.16.3 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc. -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr/local -Dsitelib=/usr/local/share/perl5 -Dsitearch=/usr/local/lib64/perl5 -Dprivlib=/usr/share/perl5 -Dvendorlib=/usr/share/perl5/vendor_perl -Darchlib=/usr/lib64/perl5 -Dvendorarch=/usr/lib64/perl5/vendor_perl -Darchname=x86_64-linux-thread-multi -Dlibpth=/usr/local/lib64 /lib64 /usr/lib64 -Duseshrplib -Dusethreads -Duseithreads -Dusedtrace=/usr/bin/dtrace -Duselargefiles -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl=n -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr -Dd_gethostent_r_proto -Ud_endhostent_r_proto -Ud_sethostent_r_proto -Ud_endprotoent_r_proto -Ud_setprotoent_r_proto -Ud_endservent_r_proto -Ud_setservent_r_proto -Dscriptdir=/usr/bin -Dusesitecustomize'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.8.5 20150623 (Red Hat 4.8.5-11)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='gcc', ldflags =' -fstack-protector'
    libpth=/usr/local/lib64 /lib64 /usr/lib64
    libs=-lresolv -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc -lgdbm_compat
    perllibs=-lresolv -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version='2.17'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,--enable-new-dtags -Wl,-rpath,/usr/lib64/perl5/CORE'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -Wl,-z,relro '


Characteristics of this binary (from libperl):
  Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS
                        PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT
                        PERL_MALLOC_WRAP PERL_PRESERVE_IVUV USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF
                        USE_REENTRANT_API USE_SITECUSTOMIZE
  Locally applied patches:
      Fedora Patch1: Removes date check, Fedora/RHEL specific
      Fedora Patch3: support for libdir64
      Fedora Patch4: use libresolv instead of libbind
      Fedora Patch5: USE_MM_LD_RUN_PATH
      Fedora Patch6: Skip hostname tests, due to builders not being network capable
      Fedora Patch7: Dont run one io test due to random builder failures
      Fedora Patch9: Fix find2perl to translate ? glob properly (RT#113054)
      Fedora Patch10: Fix broken atof (RT#109318)
      Fedora Patch13: Clear $@ before "do" I/O error (RT#113730)
      Fedora Patch14: Do not truncate syscall() return value to 32 bits (RT#113980)
      Fedora Patch15: Override the Pod::Simple::parse_file (CPANRT#77530)
      Fedora Patch16: Do not leak with attribute on my variable (RT#114764)
      Fedora Patch17: Allow operator after numeric keyword argument (RT#105924)
      Fedora Patch18: Extend stack in File::Glob::glob, (RT#114984)
      Fedora Patch19: Do not crash when vivifying $|
      Fedora Patch20: Fix misparsing of maketext strings (CVE-2012-6329)
      Fedora Patch21: Add NAME headings to CPAN modules (CPANRT#73396)
      Fedora Patch22: Fix leaking tied hashes (RT#107000) [1]
      Fedora Patch23: Fix leaking tied hashes (RT#107000) [2]
      Fedora Patch24: Fix leaking tied hashes (RT#107000) [3]
      Fedora Patch25: Fix dead lock in PerlIO after fork from thread (RT#106212)
      Fedora Patch26: Make regexp safe in a signal handler (RT#114878)
      Fedora Patch27: Update h2ph(1) documentation (RT#117647)
      Fedora Patch28: Update pod2html(1) documentation (RT#117623)
      Fedora Patch29: Document Math::BigInt::CalcEmu requires Math::BigInt (CPAN RT#85015)
      RHEL Patch30: Use stronger algorithm needed for FIPS in t/op/crypt.t (RT#121591)
      RHEL Patch31: Make *DBM_File desctructors thread-safe (RT#61912)
      RHEL Patch32: Use stronger algorithm needed for FIPS in t/op/taint.t (RT#123338)
      RHEL Patch33: Remove CPU-speed-sensitive test in Benchmark test
      RHEL Patch34: Make File::Glob work with threads again
      RHEL Patch35: Fix CRLF conversion in ASCII FTP upload (CPAN RT#41642)
      RHEL Patch36: Do not leak the temp utf8 copy of namepv (CPAN RT#123786)
      RHEL Patch37: Fix duplicating PerlIO::encoding when spawning threads (RT#31923)
  Built under linux
  Compiled at Mar  2 2017 08:50:35
  @INC:
    /usr/local/lib64/perl5
    /usr/local/share/perl5
    /usr/lib64/perl5/vendor_perl
    /usr/share/perl5/vendor_perl
    /usr/lib64/perl5
    /usr/share/perl5
    .
[root@web ~]#
Jorge BatresAuthor Commented:
[root@web ~]#  yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id                                          repo name                                           status
PLESK_17_5_3-extras                              PLESK_17_5_3 extras                                     34
PLESK_17_NGINX                                   Nginx for Plesk 17.x                                     1
PLESK_17_PHP52                                   PHP 5.2 for Plesk 17                                    31
PLESK_17_PHP53                                   PHP 5.3 for Plesk 17                                    32
PLESK_17_PHP54                                   PHP 5.4 for Plesk 17                                    32
PLESK_17_PHP55                                   PHP 5.5 for Plesk 17                                    32
PLESK_17_PHP56                                   PHP 5.6 for Plesk 17                                    32
PLESK_17_PHP70                                   PHP 7.0 for Plesk 17                                    32
PLESK_17_PHP71                                   PHP 7.1 for Plesk 17                                    32
PLESK_17_PHP72                                   PHP 7.2 for Plesk 17                                    29
mariadb                                          MariaDB                                                 18
plesk-migrator                                   Plesk packages for migrator                              9
plesk-migrator-tp                                Plesk 3d-party packages for migrator                     0
!rhel-7-server-optional-rpms/7Server/x86_64      Red Hat Enterprise Linux 7 Server - Optional (RPMs) 21,155
!rhel-7-server-rpms/7Server/x86_64               Red Hat Enterprise Linux 7 Server (RPMs)            31,329
!rhel-7-server-supplementary-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Server - Supplementary (    351
repolist: 53,149
[root@web ~]#
FishMongerCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jorge BatresAuthor Commented:
Done!
Jorge BatresAuthor Commented:
What should I do next?
Jorge BatresAuthor Commented:
[root@web ~]# yum list | grep Text-Template
perl-Text-Template.noarch          1.45-12.el7       epel                      
php-phpunit-Text-Template.noarch   1.2.0-5.el7       epel                      
[root@web ~]#  yum list | grep Test-More
[root@web ~]#
FishMongerCommented:
That's odd.  Test::More is a core module.

What do you get from this command?
perl -MTest::More -e 1

or this one?
corelist Test::More
FishMongerCommented:
I don't have corelist on my CentOS box, but on my Windows box I get:

C:\>corelist Test::More

Data for 2015-02-21
Test::More was first released with perl v5.6.2
Jorge BatresAuthor Commented:
[root@web ~]# perl -MTest::More -e 1
[root@web ~]# corelist Test::More

Test::More was first released with perl v5.6.2
[root@web ~]#
FishMongerCommented:
Ok, so that shows it's already installed.

If it wasn't, that first command would have generated an error.
Jorge BatresAuthor Commented:
Thank you, so how do I install Text-Template ?
FishMongerCommented:
yum install perl-Text-Template
or
yum install perl-Text-Template.noarch
Jorge BatresAuthor Commented:
Thank you, before I install it, I wanted to show you the notes regarding perl on the installation package for OpenSSL-1.1.og
NOTES.PERL.txt
Jorge BatresAuthor Commented:
I ran the command:

[root@web ~]# yum install perl-Text-Template
Loaded plugins: product-id, search-disabled-repos, subscription-manager
rhel-7-server-optional-rpms                                                      | 2.3 kB  00:00:00    
rhel-7-server-rpms                                                               | 2.3 kB  00:00:00    
rhel-7-server-supplementary-rpms                                                 | 2.3 kB  00:00:00    
Resolving Dependencies
--> Running transaction check
---> Package perl-Text-Template.noarch 0:1.45-12.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================
 Package                         Arch                Version                    Repository         Size
========================================================================================================
Installing:
 perl-Text-Template              noarch              1.45-12.el7                epel               62 k

Transaction Summary
========================================================================================================
Install  1 Package

Total download size: 62 k
Installed size: 122 k
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7Server/epel/packages/perl-Text-Template-1.45-12.el7.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Public key for perl-Text-Template-1.45-12.el7.noarch.rpm is not installed
perl-Text-Template-1.45-12.el7.noarch.rpm                                        |  62 kB  00:00:00    
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Importing GPG key 0x352C64E5:
 Userid     : "Fedora EPEL (7) <epel@fedoraproject.org>"
 Fingerprint: 91e9 7d7c 4a5e 96f1 7f3e 888f 6a2f aea2 352c 64e5
 Package    : epel-release-7-11.noarch (installed)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : perl-Text-Template-1.45-12.el7.noarch                                                1/1
  Verifying  : perl-Text-Template-1.45-12.el7.noarch                                                1/1

Installed:
  perl-Text-Template.noarch 0:1.45-12.el7                                                              

Complete!
[root@web ~]#
FishMongerCommented:
Great.  It looks like you should be all set to install openssh
Jorge BatresAuthor Commented:
Thank you so much, hopefully this will work. Let me give it a try and I will come back to close the question.
Jorge BatresAuthor Commented:
I was wondering if you could please help me troubleshoot this error after Openssl install:

[root@web openssl-1.1.0g]# openssl version
openssl: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
[root@web openssl-1.1.0g]#

I google the error and found this but I'm not sure how to proceed.

https://github.com/openssl/openssl/issues/3993
Jorge BatresAuthor Commented:
Ok, I got OpenSSL-1.1.0g installed but OpenSSH cannot find the OpenSSL libraries so I will open a new Question.

Thanks a lot.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.