VTP domain mismatch

I currently have EIGRP routing between S1 and S2 and I'd like to add another EIGRP routing between S1 and S2. The new path will go through 2 L2 switches (see diagram).

vlan30 is the management vlan for S2 site.

vlan100 is the SVI that will carry EIGRP advertisement.

vlan10 is the users for S2 site.

vlan20 is the users for S1 site.

S1 site has vtp domain S1 & S2 site has VTP domain S2.

I only allow vlan100 between S1 & Switch2. This is just to allow only EIGRP to be advertised, The problem that I have is S1 reports a VTP domain mismatch because it cannot negotiate the trunk between S1 and Switch2. Any thoughts on how to deal with this?

 pic1
LVL 1
leblancAccountingAsked:
Who is Participating?
 
JustInCaseCommented:
Actually, DTP is sending message that VTP domain on the other end  does not match to VTP domain configuration of this end (and that, if interfaces are not hard coded as trunks, trunking will not be negotiated). To establish trunking on link, configure manually interfaces as trunks, and, to remove messages regarding VTP mismatch, just disable DTP on connected ports.

Switch22
interface fa0/1
 switchport mode trunk
 switchport nonegotiate

S1
 interface Fa0/2
  switchport mode trunk
  switchport nonegotiate
0
 
Don JohnstonInstructorCommented:
I don't see an S1 in your diagram.  I see R1, R2, Switch0 and Switch2.

That said, if you don't need VTP running between the two devices, the easiest way to not get the messages is to disable logging.

If you're running VTP v3, you can disable it per port.  But it's probably doubtful that you're running v3.
0
 
leblancAccountingAuthor Commented:
No I don't run vtp v3. an I disable VTP on S1 fa0/2?

 pic
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Don JohnstonInstructorCommented:
No.  If you're not running VTP v3, you can't disable VTP on a per-port basis.  It either running globally or not.

So if you're running VTP v2 and you have a mismatched domain and you don't want to see the messages, then you would have to disable logging.
0
 
leblancAccountingAuthor Commented:
The message is not bad. But what is the best practice to deal with trunk with different vtp domain?
0
 
Don JohnstonInstructorCommented:
But what is the best practice to deal with trunk with different vtp domain?

Don't have mismatched VTP domain names.   Different VTP domain names is not something you're ever supposed to do (which is why there's no good way to disable it).  

The ONLY way to deal with it is either ignore the messages or disable logging.  Whenever I've run into this situation, I just ignore the messages.
0
 
leblancAccountingAuthor Commented:
That's it Predrag. You got it. Thank you very much.
PS. Now I don;t see my eigrp going through the vlan100. But I will post the question through another thread.
0
 
JustInCaseCommented:
You're welcome.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.