One page is always my startup page

Hi One page is always my startup page. I want to remove it, but I cannot in Firefox and Chrome.

Here are steps I used:

How do I change my start page in Firefox?
Change Startup Page. On any open Mozilla Firefox window, press “Alt-T,” and then select “Options” on the drop-down menu. Under the General tab, insert the URL of a website or Web page into the field next to “Home Page,” and then click “Use Current Page” to make it your default startup page.

After I did above, it is still there when i start Firefox in Win8

Anyone has some suggestion? Thank you
eemoonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
>>Anyone has some suggestion? 

probably some program (or even spyware?) is running behind and changing your web browser's startup page constantly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Andrew LeniartSenior EditorCommented:
When you to into Options again (alt+t then Options) after you have set your home page, are your desired home page settings still correct, or have they reverted?

Try this..

  • Open Firefox
  • Press Alt+T
  • Options
  • Under "When Firefox starts", select "Show your home page"
  • In the Home Page box, type the full URL of your desired home page, including the http etc...
  • Close and re-open Firefox.

Did that cure it?
0
Andrew LeniartSenior EditorCommented:
If you can provide a link to the home page you want to always have open, I'll upload a graphic to show you exactly what your settings should look like.
0
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

eemoonAuthor Commented:
Thank you so much for your reply. What i did is exactly same with what you said above. but the page cannot be removed. I just want to open http://google.com always.
0
Andrew LeniartSenior EditorCommented:
In your Firefox address bar, type:

about:preferences  [Hit Enter Key]

Ensure your settings look as shown in the graphic below and then close and re-open Firefox.  
Go back to "about:preferences" in FireFox again and check to see if the settings were retained.  
If not, report back here and advise what the settings had changed to. Upload a screen capture if possible.

Firefox Home Page Settings
0
eemoonAuthor Commented:
it is same as before after i did as what you said. please attached. Thanks

Capture.PNG
0
Andrew LeniartSenior EditorCommented:
I think Ryan Chong was on the right track then.  You have either spyware or a browser hijacker on your system.

What Anti Virus are you using?  Make sure it is fully up to date and do a full scan of your machine with it.

Download and install Malwarebytes Free  Do a full scan with it and let it remove any garbage it identifies and finds.

SuperAntiSpyware is another good program to check for spyware.

Also, make sure FireFox is fully up to date on your system.

Report back with the results after doing the above.
0
Andrew LeniartSenior EditorCommented:
One other thing I neglected to mention.  Also, if you are still experiencing problems after performing the above steps, go to:

about:addons

in firefox and disable all of your add-ons.  If that cures the problem, re-enable add-ons one at a time until the problematic culprit is found.
0
eemoonAuthor Commented:
after using JRT, it work out. Thank you all
0
Andrew LeniartSenior EditorCommented:
Glad to have helped.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.