How to set CAS autodiscovery internal URL

I am trying to set the internal URL for the CAS autodiscovery service but I get the following error. What is the proper syntax


[PS] C:\Windows\system32>Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUrl mail-ii.dgdt.l
ocal/autodiscover/autodiscover.xml

A parameter cannot be found that matches parameter name 'AutodiscoverServiceInternalUrl'.
    + CategoryInfo          : InvalidArgument: (:) [Set-ClientAccessServer], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Set-ClientAccessServer
    + PSComputerName        : mail-ii.dgdt.local
Barry-f4Asked:
Who is Participating?
 
MaheshArchitectCommented:
it's Autodiscoverinternaluri and not Autodiscover internalurl
0
 
Seth SimmonsSr. Systems AdministratorCommented:
described here

Set-ClientAccessServer
https://technet.microsoft.com/en-us/library/bb125157(v=exchg.160).aspx

that said, your command should look more like this...

Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUrl "https://autodiscover.mail-ii.dgdt.local/autodiscover.xml"

Open in new window


...or something along those lines.  point is, the parameter is the full URL pointing to autodiscover.xml file
1
 
MaheshArchitectCommented:
it's Autodiscoverinternaluri and not
Autodiscoverinternalurl
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Sunil ChauhanExpertise in Exchange Server, Office 365 & Powershell ScriptingCommented:
a tip for you,

always hit tab to complete the parameters in any CMD, as stated above the error is because of the incorrect parameter name.
you can always type few character and then hit Tab for example below.

Set-ClientAccessServer -Identity "MBX-01" -Auto "hit TAB"

the repeated tab will show all the parameter start with "-auto"
0
 
Barry-f4Author Commented:
The command worked but when I check the status of the CAS via Get-AutodiscoverVirtualDirectory –server servername the internal URL is not displayed



Name                                                     Server                                  InternalUrl
----                                                            ------                                         -----------
Autodiscover (Default Web Site)         MAIL-II
0
 
Barry-f4Author Commented:
Found the right command and the url is displayed

Get-ClientAccessServer Mail-II | fl *InternalUri*
0
 
Barry-f4Author Commented:
Here is my issue, on several workstations (not all) whenever Outlook is opened I get the following errors in the attached file. The cert appears to be imported successfully and the workstation connects to the Exchange server. Needless to say may users are annoyed, any suggestions?
0
 
MaheshArchitectCommented:
attachment is missing
0
 
Barry-f4Author Commented:
HERE IS THE ATTACHMENTOutlook-error.pptx
0
 
MaheshArchitectCommented:
Your issue is:
the command is setting up .local address and certificate is for.com and hence you are getting error

your command should be:

Get-ClientAccessServer | Set-ClientAccessServer -AutodiscoverServiceInternalUri "https://autodiscover.mail-ii.dgdt.com/autodiscover.xml"

Open in new window


The above command should set client access uri on all CAS servers to .com and then check if it works
0
 
Barry-f4Author Commented:
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.