MS Access - Form - Autocorrect save failures

Hi,

I've got a Data table that I import an excel file into, it works great, all the information from the file goes into the table but another table has appeared called:

"Name Autocorrect save failures"

A new entry appears every time I Import giving the table name, object type, reasons for failure, and time. The reason for failure is "could not save the object" but all the info is in the Data table.

Can anyone help me in this?

Thanks in advance.
LVL 1
WSStudentAsked:
Who is Participating?
 
WSConnect With a Mentor StudentAuthor Commented:
Resolved:

File->Options->Current Database ->Name AutoCorrect Options

uncheck everything.

No problem will arise from disabling it.  Actually, this default option has been link to corruption in the past and most experienced developers disable it by default as a best practice.
0
 
Máté FarkasDatabase Developer and AdministratorCommented:
If the import works programmatically (from macro or VBA) then try to do that import manually to see the whole error message.
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
open the error table that Access created and inspect the records.  Oftentimes, the errors don't matter ... maybe there is text in a number field, or a date that isn't right ...
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Jeffrey CoachmanMIS LiasonCommented:
Please post the the explicit details on "how" you are importing this file...
0
 
WSStudentAuthor Commented:
@Mate, i try that but i am not able to understand why this table is getting error as everything is importing to DB.

@Crystal and Jeffrey, please have a look at sample DB i guess you can guide more after looking at the attach DB.

Thank you.
Sample-db--2-.accdb
0
 
WSStudentAuthor Commented:
@Crystal, Also i have check for Data Type , both of them have the same data type. All the data that is coming from excel sheet have the same data type as in Access.
0
 
WSStudentAuthor Commented:
Anyone who could help me out in this?
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
hi WS,

try :

1. change data type for Byte to Integer
2. Remove @ in the Format property
3. put AutoNumber field last (am assuming you are not importing into this one)
4. change fieldnames for Current, Timestamp, Values -- these are all reserved words

do #4 first, and that might fix it

Problem names and reserved words in Access by Allen Browne
http://allenbrowne.com/AppIssueBadWord.html

what process are you using to import?

have an awesome day,
crystal
0
 
Jeffrey CoachmanMIS LiasonCommented:
Why are you using the old Excel 2000 format for importing?
    DoCmd.TransferSpreadsheet acImport, 8, "tblImportTemp", selectFile(), True

When I use the newer 2010 format, (.xlsx), argument it works fine with no save errors
    DoCmd.TransferSpreadsheet acImport, acSpreadsheetTypeExcel12, "tblImportTemp", selectFile(), True
0
 
WSStudentAuthor Commented:
@Crystal , try that all but no luck.Also yes i am not importing Auto Number.For import i am using VBA code which is in the above attach DB.

@Jeffrey Coachman, you are right was using old, change to the one you mention but still the same error. I even check the excel file , both have the same data types also but i am not able to understand why this error is still there.
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
did you change the Byte data type?

the problem is with the data being imported so please post an Excel sheet that creates an issue, thanks
0
 
WSStudentAuthor Commented:
This is an excel sheet which is importing data. Data types are the same have a look at it. Thank you.
Book1.xlsx
0
 
WSStudentAuthor Commented:
Kindly if anyone could help me out in this? Thank you.
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
if no one has helped, I will look later on. Sorry I missed the Excel download.
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
keeping my eye on this, but it will be a few days before I can carve out enough time to do some testing ... meanwhile, someone else may jump in.
1
 
WSStudentAuthor Commented:
Any help?
0
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
glad you figured it out -- sorry I haven't been here. Lots happening.

On AutoCorrect: getting this to "stick" is a multi-step process.

Turn off AutoCorrect

Microsoft Access Flaws - Failures caused by Name Auto-Correct, by Allen Browne
http://allenbrowne.com/bug-03.html

if you haven't turned it off, then it is on

in 2007:

1. Click the Microsoft Office Button Button in the upper left corner
2. choose --> Access Options (lower right corner)

in 2010, 2013, +:

1. File ribbon menu
2. Options (near bottom)

~~~

then:

3. Current Database from left sidebar

in Access 2000 - 2003:
1,2,3. from the menu --> Tools >> Options >> General

-----------------------------------
THEN:
4. Under Name AutoCorrect Options:
uncheck --> Perform Name AutoCorrect
5. Compact/Repair
6. then go back and uncheck --> Track Name AutoCorrect info
7. Compact/Repair again

have an awesome day,
crystal
0
 
WSStudentAuthor Commented:
This solve my error.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.