After Office 365 migration, internal users can't see Public Folder hierarchy

Migrated Exchange 2010 to Office 365 and INTERNAL users only now cannot see and of the Migrated Public Folders.

Manually created the Public Folder mailbox, and Public Folder root directory.  Assigned all rights needed to a user group.
Copied up subfolders to be individual Public Folders under root.

Migrated user accounts using BitTitan MigrationWiz (didn't use their Public Folder migration option, just mailboxes).

Outlook 2010 users will see the Public Folder top level tree, but get a "Cannot display the folder.  Microsoft Outlook cannot access the specified folder location." when clicking on the ALL PUBLIC FOLDERS line.  Names of the real custom folders do not display.

Some Outlook users don't see the Public Folder tree at all in Folders view.

Also using Outlook 2016 and 2013 which don't work any better.

If I connect from outside the network using Outlook 2010 or Outlook 2016, everything works correctly.

I've changed the internal DNS autodiscover record to match the external DNS record and flushed the DNS.  Also tried setting DNS to 8.8.8.8 and recreating profile.  No luck.

It seems like it's still looking for the premises Public Folders and not the Office 365 folders.

Any help appreciated!

Thanks,

Nathan
NEMCAsked:
Who is Participating?
 
Vasil Michev (MVP)Connect With a Mentor Commented:
What do you mean by internal users, users accessing O365 mailbox form the corporate network or users with on-prem mailboxes? Are they all migrated to O365? What's the status of the on-premises Exchange server? And what kind of object remains on-prem?
0
 
NEMCConnect With a Mentor Author Commented:
Internal users mean users who are on the corporate network, who a week ago had an on-premises exchange account and are now Office 365 users.

All users have been migrated to Office 365.  The Exchange 2010 Server is still up and running, but it is completely unused.

After posting my original question, I figured out what the solution was.

The registry key:

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
"ExcludeScpLookup"=dword:00000001

prevents Outlook 2010 from connecting to a local exchange server, even if one is present.  This key was automatically added by BitTitan's MigrationWiz agent.  Makes perfect sense, I've added that key manually during past migrations.

The Agent ALSO added and enabled:

ExcludeHTTPRedirect
ExcludeHTTPSAutodiscoverDomain
ExcludeHTTPSRootDomain
ExcludeSRVLookup
ExcludeSRVRecord
PreferLocalXML

Deleting these registry keys fixed the problem.  Didn't need to create a new profile, didn't need to restart the workstation.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.