Outlook 2016 wont connect to exchange 2016 autodiscovery

Can't connect Outlook 2016 to Exchange 2016.
I verify my autodiscovery with Microsoft remote connectivity analyzer for both exchange and Outlook and both has the same results.
Fail for autodiscovery.domain.com but succeed for autodiscovery.mail.domain.com
The mail.domain.com is where the exchange is located. The domain.com is where the website is hosted.
The problem I see is that I have a Microsoft account at outlook.com with the same user name as me@domain.com that is the one that exist on the exchange server.
Before it was finding the one on outlook.com and was asking me the password but that's not the one I want. I want to one on the exchange server.
All DNS is correct for  A records and MX records. Everything was working fine the same way till one hour ago when I decide to reset my computer to factory defaults and reinstall Office. I had the same problem a year ago when I install it the first time and I figure out at that time with some local xml file for autodiscovery but I can't remember how.
I got an idea but still not working
LVL 2
infedonetworkAsked:
Who is Participating?
 
timgreen7077Exchange EngineerCommented:
I would suggest you confirm that your External Autodiscover CNAME or A record is pointing to your exchange server and not to office 365. tbst seems to be your issue. look on your domain name registrar, whether it's go daddy or whoever, and verify that the auotdiscover record is only pointing at your exchange and there isn't another auotdiscover record pointing at office 365. when you setup a domain in office 365 you can give Microsoft permission to modify DNS records and this may have happened.
0
 
Steven KutasovicSystems AdministratorCommented:
Is this a single computer? Have you tried flushing the dns cache / verifying the DNS sever can be reached?
0
 
timgreen7077Exchange EngineerCommented:
Are you attempting to connect outlook to internal Exchange 2016.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
infedonetworkAuthor Commented:
No the Exchange server is at a different location and the computer is not part of the Domain. If it was I would not have this problem.
I can't use the manual settings with Outlook 2016 so I have to rely on the autodiscovery. Like I said the autodiscovery work for autodiscovery.mail.domain.com but fail for autodiscovery.domain.com
I believe that when Outlook try to resolve user@domain.com it find the email at outlook.com but that's not the one I want. Since I can't specify the server anymore on Outlook I have to find another way to redirect outlook to mail.domain.com instead of domain.com
0
 
timgreen7077Exchange EngineerCommented:
I'm not clear on your autodiscover setup. Which auotdiscover DNS name points to the actual exchange server? You mentioned 2 but which is pointing at your internet facing exchange server?
0
 
infedonetworkAuthor Commented:
Take a look bellow.
ca
0
 
timgreen7077Exchange EngineerCommented:
this is a successful test. I'm assuming this is pointing to your on-prem exchange server. is that correct.
0
 
infedonetworkAuthor Commented:
Correct
0
 
timgreen7077Exchange EngineerCommented:
please confirm you are not in hybrid setup with exchange on-prem and office 365. does your company use office 365 also for mail or not?
0
 
infedonetworkAuthor Commented:
Well that's the problem I think. I have a domain that is set on Microsoft that is the same as the one on Exchange "me@domain.com"
When I go to outlook.com and I logon as me@domain.com it let me in and I can also send email as me@domain.com that is the same email that the one I have on Exchange
I did use the local xml and registry change listed here and I think it work but it must be an easy way. I think that if I cancel the domain.com with Microsoft I should be OK or I was thinking to upload the autodiscovery file that is located at mail.domain.com in to the webserver where the Domain.com is hosted so when Outlook first try to find the autodiscover.mydomain.com it will get it there.
Not sure if that will work

https://www.howto-outlook.com/howto/autodiscoverconfiguration.htm#cname
0
 
Jose Gabriel Ortega CCEO J0rt3g4 Consulting ServicesCommented:
If you have a hybrid environment, you should just set the internal (or on-prem) server's autodiscover.
if you don't have the hybrid, deploy it, and that would be the solution to your issue.

jose
0
 
infedonetworkAuthor Commented:
I think I know what happen but a little to late now to test it since the autodiscovery was set locally on the registry and with the xml file.
When I was setup the account on Outlook it keep asking the password and each time I enter it I get the wrong password error.
So I taught it is looking at my other  account that is set with Microsoft. Then I change the user name from me@domain.com to me only and still not work then I try domain\me and it work. what is strange is that I try this before on Outlook by entering the domain\user under the user name and if did not work.
Anyway it works fine now. Thank you for your help
0
 
infedonetworkAuthor Commented:
Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.