Autodiscover for Exchange 2010 to enable a 2016 Outlook to connect

I have a 2010 Exchange server that has an autodiscover A record in the local DNS settings which point to my internal Mail server's IP and a UCC SSL certificate that is correctly pointing external mobile and remote devices to my mail server which also references this autodiscover.
OWA works perfectly across all remote devices, iPad, Smartphones.
For some reason I can configure the Mail.app in Windows 10 in a non-domain joined computer but when I try to connect using Outlook 2016 I have no joy.
I don't want to remove my autodiscover from DNS settings and fritz any computers from being able to connect.
Any ideas would be appreciated.
CaCloAsked:
Who is Participating?
 
Jose Gabriel Ortega CConnect With a Mentor CEO J0rt3g4 Consulting ServicesCommented:
Yes the issue is that you usually have Service Connection Points or (SCP)
And they can be Internal and externalURL.

If you set the Virtual Directories using ECP/Server/Virtual Directories you will miss a couple of URLs that can't be fixed using GUI (internal autodiscover 'in your case this is the one missing,' and PowerShell).

I'd recommend you to use my script to set the internals URLs in this link:
https://gallery.technet.microsoft.com/office/Script-to-configure-the-5a58558b

You can set them all using, this steps:
1. Open a PowerShell console with elevated privileges
2. Set execution policy to unrestricted by running
 set-executionpolicy unrestricted

Open in new window

And accept the message ( r or y).

3. Download and save the script to your desktop.
4. Move to your desktop in the Powershell Console
 
cd  $env:userprofile\desktop

Open in new window

5. And run the script
.\setAll.ps1 -set -urlpath "https://mail.<domain.com>./"

Open in new window


Or just set internally:
.\setAll.ps1 -setInternal -urlpath "https://mail.<domain.com>./"

Open in new window

0
 
CaCloAuthor Commented:
Hi Jose

I didn't have any joy getting your so I went old school and the Internal URL is set.  Just want to check that I can use the following to set the external URL which currently has nothing set:

Get-ExchangeServer | Where {($_.AdminDisplayVersion -Like "Version 14*") -And ($_.ServerRole -Like "*ClientAccess*")} | Set-ClientAccessServer -AutoDiscoverServiceExternalUri https://$AutodiscoverHostName/Autodiscover/Autodiscover.xml

I'm hoping that by setting this the non-domain Outlook 2016 machine will be able to at least connect using OWA/EWS.  It was so much easier when a manual server could be selected to go to either OWA or EWS as required.


CaClo
0
 
Jose Gabriel Ortega CCEO J0rt3g4 Consulting ServicesCommented:
Well, it's another valid method.
Select the answer and close the question.
jose
0
 
CaCloAuthor Commented:
Thank you Jose.

Without your solution I would have had trouble finding the way forward to resolve this problem.  I only wish I'd been able to save time with the script file automating the typing.  I will try adding the External shortly and hope that this will work for the External URL.

kind regards and thanks again
0
 
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: Jose Gabriel Ortega C (https:#a42452438)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.