Error trying to install SharePoint 2016 in Offline mode unalbe to install the IIS ROle

Need to install SharePoint 2016 offline mode but when I try to install the IIS role before running the prereqs installer it fails no matter what java script I use to run it. I get 0x0800f0907. If I am unable to configure the role the prereq install fails to run.
Robert MaloneAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
onto which server product?
Walter CurtisSharePoint AEDCommented:
I had a similar problem and overcame it using the code from this reference:

https://www.techtask.com/sharepoint-2016-unable-to-install-application-server-role-web-server-iis-role/

Here is the code:

Add-WindowsFeature Application-Server,Web-Server,Windows-Identity-Foundation,NET-Framework-45-ASPNET,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,Web-Lgcy-Mgmt-Console,Web-Lgcy-Scripting,Web-Mgmt-Tools,Web-WMI,AS-Web-Support,Web-Common-HTTP,NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-HTTP-Activation45 -Source 'E:\sources\sxs'

Open in new window


I modified the location of the source files (the last part of the code), and copied the entire code with no line breaks in to a powershell console, running as admin of course.

It worked for me, hope it works for you...
Robert MaloneAuthor Commented:
I tried the script and I get the following error message 0x800f0907 ?
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Walter CurtisSharePoint AEDCommented:
What type of java script are you using on this. What do you mean by using a Java script?

Thanks
Shaun VermaakTechnical SpecialistCommented:
Can you try this prerequisite installer?

It does the following:
  • Application Server Role, Web Server (IIS) Role.
  • Microsoft SQL Server 2012 Native Client
  • Microsoft ODBC Driver 11 for SQL Server
  • Microsoft Sync Framework Runtime v1.0 SP1 (x64)
  • Windows Server AppFabric 1.1
  • Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763)
  • Microsoft Identity Extensions
  • Microsoft Information Protection and Control Client
  • Microsoft WCF Data Services 5.0
  • Microsoft WCF Data Services 5.6
  • Microsoft .NET Framework 4.5.2
  • Update for Microsoft .NET Framework to disable RC4 in Transport Layer Security (KB2898850)
  • Visual C++ Redistributable Package for Visual Studio 2013

https://gallery.technet.microsoft.com/office/SharePoint-2016-Prerequisit-17912ad2
Walter CurtisSharePoint AEDCommented:
The good link provided above by Shaun is a great link.

It does seem to have an error though, it makes it appear the the script is a javascript. It is Powershell. Make sure you use Powershell.

Good luck...
Robert MaloneAuthor Commented:
I am using powershell  script from the above website but I can't seem to add the IIS role without the error not matter how many scripts I run I find online. I am going to try to configure the role using the gui and add the IIS role not sure if that could work and point the source files to the place I copied them to on the vm. I don't know I am sure the online documentation seems to point me back to windows 2013 even if it starts out 2016.
Shaun VermaakTechnical SpecialistCommented:
Please let us know if you get error via GUI

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Robert MaloneAuthor Commented:
That worked for the IIS role but now for the installing the Prereqs from the script it fails is it possible just to manually install the files? without the script or does the following script do anything special?


$SharePoint2016SP1Path = “C:\Prereqs”
 
Start-Process “D:\PrerequisiteInstaller.exe” –ArgumentList“/SQLNCli:$SharePoint2016SP1Path\sqlncli.msi
/IDFX:$SharePoint2016SP1Path\Windows6.1-KB974405-x64.msu
/IDFX11:$SharePoint2016SP1Path\MicrosoftIdentityExtensions-64.msi
 
/Sync:$SharePoint2016P1Path\Synchronization.msi
 
/AppFabric:$SharePoint2016SP1Path\WindowsServerAppFabricSetup_x64.exe
 
/KB2671763:$SharePoint2016SP1Path\AppFabric1.1-RTM-KB2671763-x64-ENU.exe
 
/MSIPCClient:$SharePoint2016SP1Path\setup_msipc_x64.exe
 
/WCFDataServices56:$SharePoint2016SP1Path\WcfDataServices56.exe
 
/DotNet452:$SharePoint2016SP1Path\NDP452-KB2901907-x86-x64-AllOS-ENU.exe
 
/MSVCRT12:$SharePoint2016SP1Path\vcredist_x64.exe
 
/KB2898850:$SharePoint2016SP1Path\Windows8.1-KB2898850-x64.msu
Robert MaloneAuthor Commented:
The error I am seeing in the logs is unable to install ODBC driver ?
Robert MaloneAuthor Commented:
installing with the gui worked
Walter CurtisSharePoint AEDCommented:
Glad you got it working...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.