Incorrect serial showing via she run

I have a 2650xm router but when I do:

Show run - it shows the following:

Serial0/1
Serial0/2

The above is incorrect & it should be:

Serial0/0
Serial0/1

I have removed iOS & re-added the iOS still same problem.

I have also removed serial card & removed iOS & re-added same problem.

What is the issue & how to fix ?

I'm using an advanced iOS on 2 other 2650xm & they are ok.
mikey250Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Generally, device can't be wrong. I don't think that you can change it (but, who knows... I was surprised too many times so far...), compare hardware version with other devices by issuing show inventory, maybe hardware version is different.
0
mikey250Author Commented:
hi I think originally I may have taken the (wic 2t serial card) from a 3600 router.

When I looked on eBay I did find same serial cards on viewing stating that the card worked with the 2600 albeit I did not see (xm) & also 3600 & other routers.

One thing I did not try is taking another card from another 2600 as the wic 2t cards all visually look identical & show the expected serial numbers as expected as it states the serials 0 & 1 clearly on the cards except the iOS shows serial 0 & 2 as explained.

So I assumed maybe I need to re-partition & re-format & then upload iOS again but I cannot find this anywhere ???

I will however compare version on both good 2600 & other 2600 showing incorrect serial 0/2 instead of serial 0/1.

appreciated
0
mikey250Author Commented:
hi I've put the 2 working wic 2t serials into the supposed faulty 2650xm & both show as the same issue:

serial 0/1
serial 0/2 - incorrect should be 0/1

When I also remove supposed wic 2t serial from 2650xm & put in both good 2650 & 2650xm it shows as expected:

serial 0/0
serial 0/1

so it appears there is something wrong with my 2650xm & have deleted & copied another completely different iOS version then copied back the required iOS but same problem.

Any ideas other than maybe having to re-partition or reformat, just incase or at least as a last attempt ??

I have also ran the 'squeeze'
0
Prepare for an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program curriculum features two internationally recognized certifications from the EC-Council at no additional time or cost.

JustInCaseCommented:
If hardware version of these devices are the same and IOS versions in use are the same I don't expect that re-partitioning will help. The only thing that I can think of is that, maybe (I never saw it (even check if there is an option) on Cisco devices if there are jumpers on motherboard that could manipulate that S0/1 becomes 0/2.  If you can configure and test it as it is seen now (s0/2) to establish is it working would be great. If that's not the case, I am out of ideas how to deal with it (except check Cisco bugs for router and module, or to deal with Cisco TAC).
0
mikey250Author Commented:
hi I'm only a member/guest of cisco.

I will open it up & have a look & let you know today sometime.

on each router it's marked up on the outside as the following:

2650 - 1 router
2650xm - x 2 (1 of these shows the serial0/2)
all have identical ios
0
mikey250Author Commented:
I unplugged everything inside the router even though there was no jumpers inside to swap over & removed all external cards.

I then switch all memory etc over to another identical 2650 router & vice versa with the router with the issue showing: serial0/2 instead of serial0/1.

I then put back all serial cards & in the router with the issue showing incorrect serial & all appears as expected.

but when I put the eth controller card back in its original slot on right side of router power supply & on reboot serial 0/2 was showing again.

resolution
I removed the eth controller card & rebooted the router again & the serial 0/1 was showing again.

so when the eth controller card is plugged in nearest the power supply it shows the serial 0/2.

I then switched the serial card over with the eth controller card & all is still good.

weird didn't think that would be the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JustInCaseCommented:
In that case, I guess that serial connection could be functional even if it is marked as s0/2, but it is even better - you solved the mystery.
:)
0
mikey250Author Commented:
Yes it now shows as correct interface number serial0/1.

So all good.

I will allocate points either way so thanks.
0
JustInCaseCommented:
You're welcome.
0
mikey250Author Commented:
Even though I resolved it myself I appreciate good advice so allocating points anyway.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.