Need to add boot device in BIOS

I am using  a Biostar Motherboard A68N-2100 AMD APU E1-2100to build a new computer so I need to connect a DVD drive to load Windows 10. The computer is not recognizing the drive so I cannot boot from it. How do I add a boot device in the BIOS? I only see the Hard Drive.

Thank you.

Robert Ehinger
Robert EhingerIT specialistAsked:
Who is Participating?
 
nobusCommented:
how is the DVD drive connected?  to sata, or USB ?

it should see the drive from sata ok, unless you have a bad drive, or cable (you can test it on another pc too)
0
 
RaminTechnical AdvisorCommented:
Disable Safe Boot from BIOS and select legacy Boot,
0
 
Travis MartinezSmoke JumperCommented:
You're better off using Rufus to write your ISO file to a bootable USB device.  With Rufus the system should recognize the drive in BIOS and allow you to select it as the first boot location.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
RaminTechnical AdvisorCommented:
Disabled Secure boot and enabled Legacy Boot from BIOS.
0
 
Robert EhingerIT specialistAuthor Commented:
I will try disabling Safe Boot. I already tried writing to a uSB device but that was not recognized either.
0
 
Travis MartinezSmoke JumperCommented:
It wasn't recognized because it probably wasn't set for a GPT partion with UEFI boot.  What Ramin said about turning legacy boot on should do it.  That is if your motherboard accepts legacy boot.  I just built a system with an ASROCK that has no ability to boot legacy.
0
 
RaminTechnical AdvisorCommented:
As long as BIOS is set to Secure Boot it will not let you to use USB or DVD to Boot from any Operating System to keep your system secure.

Also you may need to Enable Legacy Boot or Disable Lock Legacy Resources.

1.png
0
 
Robert EhingerIT specialistAuthor Commented:
Secure Boot was already disabled.  The only place where I could find any Legacy options is in the CSM parameters. I changed all those options to Legacy and still cannot add a boot device.
0
 
Travis MartinezSmoke JumperCommented:
Please try and use "Rufus" to create a "GPT UEFI" USB boot device.  Be sure that once you select the ISO image with Rufus that it doesn't switch back to MBR.  It says UEFI with it but it will not work.  The board you have appears to be like my ASROCK and requires a UEFI boot device.
0
 
noxchoGlobal Support CoordinatorCommented:
Apparently the BIOS does not work with your USB DVD drive. Instead of using DVD use USB Stick. You can create Windows 10 installation USB stick using Media Creation Tool from Microsoft: https://www.microsoft.com/de-de/software-download/windows10
0
 
RaminTechnical AdvisorCommented:
Are you sure your first boot drive is set to USB legacy flash drive / DVD in BIOS  Hard Drive BBS Priorities?

You also need to Save and exit BIOS.
0
 
Robert EhingerIT specialistAuthor Commented:
Getting another drive to see if that is the problem.
0
 
nobusCommented:
can you answer my question , Robert?
0
 
Robert EhingerIT specialistAuthor Commented:
Drive is connected to SATA.
0
 
nobusCommented:
can you see the cd drive in the bios?  if not, i suggest to swap cables, sata port, and cd drive  (you can test it on another system)
0
 
nobusCommented:
so it seems to be a bad drive - or what ?
0
 
Robert EhingerIT specialistAuthor Commented:
Bad drive and bad cable. Both had to be replaced.
0
 
nobusCommented:
tx for feedback Robert, Always useful
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.