set define off;

I have a master script that creates about 30 tables. If I do not put this command in the very first line
set define off;
, I will get popup boxes when I run the script asking for a value "v1";

Why is that?
LVL 2
brgdotnetcontractorAsked:
Who is Participating?
 
sdstuberCommented:
because you have & characters in your scripts which SQL*PLUS treats as replacement variables.
So it's prompting for the values to replace in those variables.

By turning define off, you disable that feature
0
 
brgdotnetcontractorAuthor Commented:
Awesome, thanks !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.