Tomcat 8.0.35 running, web application WAR successfully deployed from IntelliJ IDEA 2017.3.3 but the browser is showing HTTP Status 404

Binyamin Regev
Binyamin Regev used Ask the Experts™
on
I have Tomcat 8.0.35 running, web application running from IntelliJ IDEA 2017.3.3 (build successful and WAR deployed) but the browser (I tried with Chrome, Firefox, and IE) is showing HTTP Status 404 when I try to access http://localhost:8080/ or http://127.0.0.1:8080/.

I built my web application with Maven as WAR. The WAR file was successfully deployed in Tomcat's "/webapps/ROOT" directory and "index.html" and "index.jsp" are there and at the end of the deployment the browser page is open.

Tomat is configured to default ports: 8080, 8081, 8009.
localhost-8080---WAR-artifact-is-dep.PNG
localhost-8080---http-status-404.PNG
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
mccarlIT Business Systems Analyst / Software Developer
Top Expert 2015

Commented:
Possibly the "welcome page" settings aren't set correctly. Have you tried navigating to http://localhost:8080/index.html or http://localhost:8080/index.jsp?

Otherwise, I think we would need further info, log files, config files, directory tree listings of /webapp folder, etc
Binyamin RegevJava Back End Developer

Author

Commented:
I resolved it myself.
mccarlIT Business Systems Analyst / Software Developer
Top Expert 2015

Commented:
Can you please give us some info on what the problem was and what you did to resolve it. Then you can select that comment as the solution. Otherwise, request to delete the question. There is no point keeping this question around in the current state.
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Java Back End Developer
Commented:
>>Possibly the "welcome page" settings aren't set correctly. Have you tried navigating to http://localhost:8080/index.html or http://localhost:8080/index.jsp?
Of course, I tried that. it's elementary.
I resolved it by creating a simple and basic Java web application with Spring-mvc and Java-Based configuration. This application was deployed successfully and I just compared the configuration of my application with the problem to the basic application that deployed.

C:\JavaProjects\IdeaProjects\SpringJavaConfiguration\ -- project base directory
      +  src
      |   +  main
      |   |   +  java
      |   |   +  com
      |   |   |   +  chef_ben
      |   |   |   |   -  config
      |   |   |   |              RootConfig.java
      |   |   |   |              WebConfig.java
      |   |   |   |              WebInit.java
      |   |   |   |   -  controller
      |   |   |   |              HomeController.java
      |   |   |   +  resources
      |   |   |   +  webapp
      |   |   |              home.jsp
      |   +  test
      |   |   +  java
RootConfig.java
WebConfig.java
WebInit.java
HomeController.java
Binyamin RegevJava Back End Developer

Author

Commented:
Almost forgot the configuration of IntelliJ --> Tomcat Server --> Local
IntelliJ---Maven---Tomcat-Server-loc.PNG
IntelliJ---Maven---Tomcat-Server-loc.PNG
Binyamin RegevJava Back End Developer

Author

Commented:
I took the method of K.I.S.S. - meaning, when having a basic problem, start over, make something simple that works and you will have a reference to check the problem. Nothing more to add to a simple and basic application

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial