Remote Desktop Connection can't connect....

I have been using Remote Desktop Connection (RDC) from my Windows 7 Professional SP1 desktop for several years to connect to my servers.  Suddenly, perhaps after a recent Windows update, I can no longer do this.  Instead, I get this message: "Your computer can't connect to the remote computer because a security package error occurred in the transport layer." (screen shot attached).

My online research mentions something about adding a key to the registry, but I'm hesitant to do so and thought I'd check here to see if others have seen this problem and get their solutions.
makingitbigAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hello ThereSystem AdministratorCommented:
Run this command elevated mode ob client computer.
reg.exe Add "HKCU\Software\Microsoft\Terminal Server Client" /V "RDGClientTransport" /T REG_DWORD /D "1"

or manually
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client
Name: RDGClientTransport
Type: Dword
Data: 1

If this will not work ,you can always delete this entry. So do not hesitate.

Also a missing DLL file might cause this.
makingitbigAuthor Commented:
This wasn't the direct solution, but it lead me to the solution which was to edit a couple of registry keys.  I had edited them last week in advance of the PCI credit card requirement to use TLS 1.2.  As it turns out, my edits effected the ability to remote desktop as I had only enabled TLS 1.1 & 1.2  (apparently, 1.0 needs to be enabled, as well for RDC).  So, the registry key that I entered, 0x00000a00, had to be modified to be 0x00000a80 (per the table below).  Now RDC works, again, as before.

The DefaultSecureProtocols registry entry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
On x64-based computers, DefaultSecureProtocols must also be added to the Wow6432Node path:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
The registry value is a DWORD bitmap. The value to use is determined by adding the values corresponding to the protocols desired.

DefaultSecureProtocols Value      Protocol enabled
0x00000008      Enable SSL 2.0 by default
0x00000020      Enable SSL 3.0 by default
0x00000080      Enable TLS 1.0 by default
0x00000200      Enable TLS 1.1 by default
0x00000800      Enable TLS 1.2 by default

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-a-default-secure-protocols-in
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
RDC

From novice to tech pro — start learning today.