Using SOAP1.1 version on Sprint Boot

I am using Spring Boot and want to create a client that uses SOAP1.1 as the SOAP VERSION.

I am not sure how to check my current SOAP version and how to switch it to SOAP1.1 for the client.

Does anyone have idea as I cannot find this online anywhere.........
Shantnu ChaturvediAsked:
Who is Participating?
 
mccarlIT Business Systems Analyst / Software DeveloperCommented:
SOAP 1.1 should be used by default, as long as Spring Boot is NOT changing the plain Spring defaults. See this javadoc...

https://docs.spring.io/spring-ws/docs/current/api/org/springframework/ws/soap/SoapMessageFactory.html

And it is this default MessageFactory that should be used in your web service client code.

If you want some code to find this stuff out, you will probably need to post some of your example client code just so that I can see at what level you are coding this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.