• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 668
  • Last Modified:

SQL Management Studio - 2014 - 'System.Windows.Media.Fonts' threw an exception

Using SQL 2014 management studio; not sure what happened, but every (or most of the time) time I try open a query or view records I get one of the following errors.

Cannot execute script.
Object reference not set to an instance of an object. (Microsoft.VisualStudio.Editor.Implementation)

The type initializer for 'System.Windows.Media.Fonts' threw an exception. (mscorlib)

I've tried running a repair, it complete fine but didn't resolve the issue.

Any ideas?

Thanks!
0
cuadmin
Asked:
cuadmin
  • 3
2 Solutions
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
You should apply the last Service Pack to solve any known issue.
But I'ld recommend you to install the latest version of SSMS that's compatible with SQL Server 2014.
1
 
Frank GrimesCommented:
Can I simply run Server Management Studio 17.4? I assume this will just upgrade the current application?
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
It won't upgrade the current SSMS version but will install a new one. You can then uninstall the old version as you won't used it for sure.
1
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Solution provided.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now