Error when attempting to create SQL Server ODBC connection

I am working on setting up a VMware Mirage test environment, and need to allow a second server to connect to the SQL Server 2012 Express instance on the first server. I am trying to set up an ODBC connection on the second server for the SQL Server on the first. I have already opened inbound TCP port 1433 on the first server. I need to log into the SQL Server using Windows authentication. I am logged into both servers using the same domain administrator account (they are on the same domain). Everytime I hit Next on the "How should SQL Server verify the authenticity of the login ID?" part of the System DSN wizard, I get the following error:

Connection failed:
SQLState: '01000'
SQL Server Error: 67
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Connection failed:
SQLState: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.

2018-02-06--1-.png
2018-02-06--2-.png
Can someone please help with this?
Dustin23IT DirectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeff MorlenNetwork EngineerCommented:
Have you tried to disable the firewall completely on the 1st system to see if is getting stopped by that?
If not, give that a try.  If you are able to connect, then check to see if TCP/IP is configured for connectivity... it may be only set to named pipes.

Hope that helps.
0
Travis MartinezSmoke JumperCommented:
Are you using the "SQL Native Client" for the connection?
Screenshot-2015-01-29-08.44.39.png
0
Dustin23IT DirectorAuthor Commented:
Ok Jeff, I will check TCP/IP configuration.

Travis, the only option was "SQL Server".
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Dustin23IT DirectorAuthor Commented:
Do I need to be running the SQL Server Browser?
0
Travis MartinezSmoke JumperCommented:
If the only option is "SQL Server" then it's not going to work.  You need to download and install the native client.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dustin23IT DirectorAuthor Commented:
Ok Travis, now this is for the machine that does not have SQL installed on it. I need the Native Client on THAT machine? If this is the case, why is it not on that machine by default?
0
Dustin23IT DirectorAuthor Commented:
Or am I supposed to be configuring the ODBC connection on the machine with SQL Server installed?
0
Travis MartinezSmoke JumperCommented:
That's correct.  It doesn't have SQL installed but it does have to have the native client to connect.  Try downloading and installing:

https://www.microsoft.com/en-us/download/details.aspx?id=50402

Then add the connection using the native client.

Why it's not there by default I can't answer.
0
Dustin23IT DirectorAuthor Commented:
Jeff, I took a look at the SQL Server Configuration Manager, and under SQL Server Network Configuration > Protocols for SQLEXPRESS only Shared Memory was enabled. I went ahead and enabled TCP/IP as well. The ODBC still did not work, but it looks like I need the Native Client as Travis suggested.

Is this what you were referring to Jeff?
0
Hypercat (Deb)Commented:
On the machine that has SQL Server installed, are you sure that the account has a login for SQL Server?  Normally during the installation of SQL IIRC, it defaults to add the administrator account automatically, but you have the choice to deselect that option too I think.
0
Jeff MorlenNetwork EngineerCommented:
Dustin23-
Yes, that's what I was referring to.
Did you try to turn off the firewall for a bit to see if connectivity worked?
Also, did you try by IP vs name?
0
Dustin23IT DirectorAuthor Commented:
Disabling the firewall on the SQL Server fixed the issue. ODBC connection is now created. I have Shared Memory, Named Pipes, and TCP/IP all enabled on the SQL Server. Besides port 1433, what else could I be missing that was keeping this from working with firewall enabled?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SQL

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.