Exchange services stopped and fails to start

Exchange Server 2016 CU7
Windows Server 2012 R2
All Exchange services suddenly stopped working except "Search host controller" and "Server Extension for Windows Server backup"
Topology gets error 1053 if I try starting it. Most other servicess get 1068 due to dependencies.
Interestingly some non-exchange services were disabled. "WWW Publishing Service" and "WMI" I was able to enable and start these and they remain enabled after a reboot.
Not sure what caused this.
Tried running updates but it fails to do a security update for CU7 (KB4045655).

I am in the process of downloading the Exchange ISO to see If I can do an installation repair.
If I restore whole VM from backup would there be any AD complications as there is separate Domain Controller?

Any suggestions would be appreciated.

Thanks.
scraftausAsked:
Who is Participating?
 
Muhammad AsifConnect With a Mentor Senior Solutions ArchitectCommented:
We had faced similar kind of issue and were able to resolve it. The solution is mentioned in given below link. Please go through it as it might help you.

https://solutionsorbit.com/2017/12/20/exchange-services-information-store-frontend-service-transport-are-not-starting-exchange-management-shell-and-virtual-directories-are-not-opening-exchange-version-exchange-2016-2013-windows/
0
 
Muhammad AsifSenior Solutions ArchitectCommented:
Hi,

Can you please try to open a powershell and let us know what error you are getting while opening it?
0
 
scraftausAuthor Commented:
Powershell opened fine without errors.
Exchange Management shell opens with Errors:

Shell.JPG
I Also tried to run the EXE from the Exchange 2016 ISO but got an APP crash:

ExSetup.JPG
0
 
scraftausAuthor Commented:
We ended up reverting to an image backup of the server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.