Outlook 2016 auto complete not keeping global addresses...

After setting up new remote access server, I opened outlook, started new message (from both contacts & global address book), hit control + k, then closed message.
When starting a new message, auto complete works fine, but if I close outlook & reopen, only names from contacts will auto complete, global addressbook names are no longer available, unless I do the whole process over again.
How can I fix this?
LVL 1
gromackAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
what mode of Outlook you are using? Is it Online Mode or Cached Mode?
0
gromackAuthor Commented:
Offline, I believe, since none of the cached boxes are checked.
0
systechadminConsultantCommented:
thats online mode. Online mode doesnt maintain chached entry of Email Address from GAL. you can test it on one system with chached mode and update us.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

gromackAuthor Commented:
Switched to cached, added addresses & it works, until I quit out of outlook.
After opening outlook again, it's lost its addresses from global address book.
0
timgreen7077Exchange EngineerCommented:
do you have exchange in your environment?
0
gromackAuthor Commented:
Yes
0
timgreen7077Exchange EngineerCommented:
make sure that the mailbox database is pointing to the default offline address book under client settings of each mailbox database.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gromackAuthor Commented:
Where?
Still learning my way around exchange 2013...
0
systechadminConsultantCommented:
Click on Database properties  and go to Client Settings, if its blank, you need to browse and select Default address book . See the attached screen shot.
ADbook.JPG
0
gromackAuthor Commented:
Thank you, that did it!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.