Routing between Vlans using L3 Switch

Routing between Vlans using L3 Switch
vlan


in this Lab I am using Vlan interfaces on L3 Switch instead of Subinterfaces
I have the configuration below:
Host1#sh run
Building configuration...

Current configuration : 1822 bytes
!
! Last configuration change at 21:53:36 CET Sun Feb 11 2018
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Host1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1
no ip routing
!
no ip cef
!
no ipv6 cef
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.10.1 255.255.255.0
 no ip route-cache
!
interface Ethernet0/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/3
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/3
 no ip address
 no ip route-cache
 shutdown
!
interface Serial2/0
 no ip address
 no ip route-cache
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 no ip route-cache
 shutdown 
 serial restart-delay 0
!
ip default-gateway 192.168.10.254
!
ip forward-protocol nd
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input all
!
end
          
Host1#

Open in new window


Host2#sh run 
Building configuration...

Current configuration : 1822 bytes
!
! Last configuration change at 21:34:20 CET Sun Feb 11 2018
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Host2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1
no ip routing
!
no ip cef
!
no ipv6 cef
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.20.2 255.255.255.0
 no ip route-cache
!
interface Ethernet0/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/3
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/3
 no ip address
 no ip route-cache
 shutdown
!
interface Serial2/0
 no ip address
 no ip route-cache
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 no ip route-cache
 shutdown 
 serial restart-delay 0
!
ip default-gateway 192.168.20.254
!
ip forward-protocol nd
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input all
!
end
          
Host2#

Open in new window


SW1#sh run 
Building configuration...

Current configuration : 1647 bytes
!
! Last configuration change at 21:59:22 CET Sun Feb 11 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef    
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport access vlan 10
 switchport mode access
 duplex auto
!
interface Ethernet0/1
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Serial2/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!         
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

SW1# 

Open in new window


SW3#sh run 
Building configuration...

Current configuration : 1685 bytes
!
! Last configuration change at 21:49:18 CET Sun Feb 11 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef    
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!
interface Ethernet0/0
 duplex auto
!
interface Ethernet0/1
 duplex auto
!
interface Ethernet0/2
 shutdown
 duplex auto
!
interface Ethernet0/3
 shutdown
 duplex auto
!
interface Ethernet1/0
 shutdown
 duplex auto
!
interface Ethernet1/1
 shutdown
 duplex auto
!
interface Ethernet1/2
 shutdown
 duplex auto
!
interface Ethernet1/3
 shutdown
 duplex auto
!
interface Serial2/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!         
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.254 255.255.255.0
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input all
!         
end

SW3#

Open in new window



Host2#ping 192.168.10.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Host2#ping 192.168.10.1  

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Host2#

Open in new window


Host1#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Host1#ping 192.168.20.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Host1#

Open in new window



As you can see I can ping from Host1 to Host2 DG( which is the interface Vlan20:192.168.20.254) but cannot ping Host2 IP address: 192.168.20.2   and I can ping from Host2 to Host1 DG( which is the interface Vlan10:192.168.10.254 ) but cannot ping Host1 IP address :192.168.10.1

Any Help ?
jskfanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Svet ChinkovCommented:
Hello,

It looks like you may have to enable sw3 for routing using the following global mode command - ip routing. Please give that a try and let me know the result. If that does not work, please post the output of the below commands:

Host 1 & 2: show ip int brief
Sw 1 & 3: show vlan brief & show int trunk
Sw3: show ip route

I hope that helps. Please let me know if you have any questions.
0
Fred MarshallPrincipalCommented:
This appears to cover the question assuming a Cisco or Cisco-like switch
https://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html
0
jskfanAuthor Commented:
Host1#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.10.1    YES NVRAM  up                    up    


Host2#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.20.2    YES NVRAM  up                    up  

W1#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/3, Et1/0, Et1/1, Et1/2
                                                Et1/3
10   VLAN0010                         active    Et0/0
20   VLAN0020                         active    Et0/1


SW1#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/2       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/2       1-4094

Port        Vlans allowed and active in management domain
Et0/2       1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Et0/2       1,10,20
SW1#

SW3#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/1, Et0/2, Et0/3, Et1/0
                                                Et1/1, Et1/2, Et1/3
10   VLAN0010                         active    
20   VLAN0020                         active    


SW3#sh interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/0       desirable        n-802.1q       trunking      1

Port        Vlans allowed on trunk
Et0/0       1-4094

Port        Vlans allowed and active in management domain
Et0/0       1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20


SW3#sh ip route

Gateway of last resort is not set

      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Vlan10
L        192.168.10.254/32 is directly connected, Vlan10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, Vlan20
L        192.168.20.254/32 is directly connected, Vlan20
SW3#
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jskfanAuthor Commented:
IP Routing is enabled on SW3
0
Fred MarshallPrincipalCommented:
In whatever notation is used on that Level 3 switch, you need to add routes:

A VLAN10: 192.168.20.0/24 to VLAN20
At VLAN20: 192.168.10.0/24 to VLAN10

And, knowing the model of the Level 3 switch wouldn't hurt a bit!
0
jskfanAuthor Commented:
Fred Marshall

That 's  IOU Web
Host to Host ping is not working .
Any Host ping to any interface Vlan works fine
0
jskfanAuthor Commented:
Also Ping  from SW3  to Host1 or Host2 works fine
0
Fred MarshallPrincipalCommented:
Do you mean that you can ping 192.168.10.254 from 192.168.10.xxx AND 192.168.20.254 from 192.168.20.xxx?

The Windows firewall will block incoming traffic unless you add subnet scope to the firewall incoming rules.
File and Printer Sharing Incoming rules need to include the Other subnet as well as the Local subnet in the Remote Address scope.
the last column is the Remote Address - needs the opposite subnet added
0
jskfanAuthor Commented:
No firewall , all the hosts ,switches and routers you see on the picture above,  they run in one vmware appliance,, it is called IOU Web.

I want just to make sure the configuration I posted makes sense. I know  that sometimes when you do not use real hardware you can see some weird stuff.
0
Mitul PrajapatiJunior IT EngineerCommented:
on Sw3, try to trunk using this command

SW3(Config)# interface e0/0
SW3(Config-if)# Switchport trunk encapsulation dot1q
SW3(config)# switchport mode trunk

This may sort out your issue.
0
JustInCaseCommented:
Since you can ping  can be ping from 192.168.10.1 -> 192.168.20.254 and from 192.168.20.2 -> 192.168.10.254 <- This means VLANs on SW2 and SW3 are created and functional also routing is working properly

Ping between hosts supposed to work.
If VLANs are not OK ping of default gateway IP address would fail.
If routing is not functional other VLAN SVI would not be pingable.

So, this sounds like some IOU bug. Try to save configurations  close lab and open it again, or recreate lab completely.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Natty GregIn Theory (IT)Commented:
If All the above fail save config and reboot the machine
0
jskfanAuthor Commented:
Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.