Set Strong Password

How force AD Users to Set Strong Password which must contain special characters by Changing ALT+CTRL+DEL.
Afiniti Exchange ADAsked:
Who is Participating?
 
McKnifeCommented:
Open the default domain policy, go to the computer config - windows settings - security settings - Password policy
and look at your options. The so-called complexity requirements will only be able to enforce 3 types of characters, but not explicitely the special characters, sorry.

For that, you would need a 3rd party addition, like for example https://anixis.com/products/ppe/
0
 
Hello ThereSystem AdministratorCommented:
Use GPO to do this:
Computer Configuration/Windows Settings/Security Settings/Account Policies/Password Policy
Passwords must meet complexity requirements - ENABLE
0
 
Andrew LeniartSenior EditorCommented:
Hi Afiniti,

Have you considered trying to set a complex password policy on both workstations and domain?
On workstations;

Start > Run > gpedit.msc
then
Computer Configuration > Windows Settings > Security Settings > Account Policies > Password Policy

Look at the settings
"Password must meet complexity requirements" and perhaps Enforce Password History

That any help?

Password Poilicy in GPO
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Hello ThereSystem AdministratorCommented:
0
 
Andrew LeniartSenior EditorCommented:
Damn you people must type fast! No one was viewing when I clicked on this question, I post my answer and two similar answers already given! lol :)
1
 
Afiniti Exchange ADAuthor Commented:
Password must meet complexity requirements already enabled.
0
 
Andrew LeniartSenior EditorCommented:
OP - Can you clarify and expand on what you mean by this?

which must contain special characters by Changing ALT+CTRL+DEL

Change ALT+CTRL+DEL doesn't make much sense to me?
0
 
Shaun VermaakTechnical Specialist/DeveloperCommented:
You cannot as per #a42465901 without 3rd party tools
0
 
Tom CieslikIT EngineerCommented:
If you did Enabled complexity requirements, make sure policy was refreshed, so force policy on one of workstation (account)

gpupdate /force

Then hit Ctrl-Alt-Del and select Change password.

Complexity requirements are enforced when passwords are changed or created.

Check if policy is working for this workstation.
0
 
Shaun VermaakTechnical Specialist/DeveloperCommented:
Won't make a difference, Password1 contains 3 types of characters and is a "complex" password
0
 
Hello ThereSystem AdministratorCommented:
We do not know whether the author required the solution involving GPO or 3rd party app, so I think points should be split.
Assisted comment #42465900 provided the only way what is possible via GPO. The best comment #42465901 confirmed that and showed what is really needed to make it possible using 3rd party app.
0
 
Shaun VermaakTechnical Specialist/DeveloperCommented:
I disagree

How force AD Users to Set Strong Password which must contain special characters by Changing ALT+CTRL+DEL.
It cannot be done without 3rd party tools
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.