• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 53
  • Last Modified:

Excessively large emails hung in Exchange 2010 queue.

I have an Exchange 2010 server environment (2 servers with all roles on each).  The other day, I found 2 1.7GB emails stuck in queue.  I have restrictions in place (100MB for internal emails <receive connector> and 35MB for external emails <send and receive connectors>) and they appeared to be working fine.  My question is "How did the 1.7GB emails (single PowerPoint attachment) make it to my queues?.  Is there something that I'm missing with the connectors?  These were internal email attempts, but well over 100MB.  Also, associated with this, is there a way to make Outlook prevent (or at least warn against) excessive attachments?  Obviously, nobody should be sending 1.7GB through email.

I appreciate any assistance provided.

Thank you,

Jeremy
0
Jer
Asked:
Jer
  • 2
1 Solution
 
timgreen7077Exchange EngineerCommented:
make sure you have those restrictions set in the global transport configuration settings. open EMC > org configuration > hub transport > global settings > transport settings and set the max send and receive to your limits. See if this fixes your issue.
0
 
timgreen7077Exchange EngineerCommented:
also make sure your hard drive capacity isn't fully consumed.
0
 
Ganesh Kumar ASr Infrastructure SpecialistCommented:
How do you say the queue got one 21.7 gb of data in it by seeing the queue folder and its size or by running get-queue command from EMS. If the mail.queue file size is 21 GB it grows if any additional transport agent or thirdparty or antimalware rule causes the transport queue file size to grow into big size. You sure if there is no mail struck in queue and you can stop the MS Exchange Transport service and delete the files under the Transport Queue folder and start the service. Which will create the fresh queue with 8MB as default size. Check all your transport service and internally do not allow more than 50 MB mailsize and external can be based on your bandwidth and policy. Most of the mail server wont take above 15-20 MB mail attachment size.

As recommended by Tim, you need to check the limits.
0
 
JerAuthor Commented:
Upon investigation, the global transport configuration settings for max sent and max receive were blank.  I've entered in our max allowed size and will monitor.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now