User suddenly cannot view shared calendars

Our sales reps share their Outlook calendars with our Customer Services manager.

They are using Outlook 2013 connecting to our 2010 Exchange server.

Up until a few days ago the CS manager could access all the sales guys calendars but all of a sudden she can't see several of them.

Now when she tries to view one of them she gets this error: You do not have permission to view this calendar.
Image1.jpg
tracyprierNetwork AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason CrawfordTransport NinjaCommented:
Try this in EMS:

Get-MailboxFolderPermission -Identity salesperson@emaildomain.com:\calendar -User csperson@emaildomain.com

Open in new window

if the appropriate permissions are missing for whatever reason just add them back with Add-MailboxFolderPermission.
timgreen7077Exchange EngineerCommented:
How are the calendars being shared. are they being shared via exchange by giving the users full manage access to the mailbox or is it being shared via delegate access in outlook? if via delegate access in outlook do the following to confirm they still have permissions:

open outlook of the user that share out his/her calendar, click file, account settings, delegate access, here you will see if what users have access to see the calendar.

If exchange is the method they are using do the following.
open the exchange console any go to the mailbox of the user sharing their calendar. right click and select Manage Full Access Permissions. Here you will be able to see what users have full access to their mailbox.

depending on which ever method is being used just add the user that needs to access to the share option, either via outlook delegate access or exchange full manage access.
tracyprierNetwork AdministratorAuthor Commented:
OK so that fixed the issue of accessing the calendars BUT by granting full manage permissions to all the sales guys mailboxes that has in turn added them to the CS managers Outlook which in turn has blown out her .ost file.

How do I get around that problem?
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

timgreen7077Exchange EngineerCommented:
Set the cache mode not to download shared folders or mailboxes. that way it will only cache the primary mailbox and not mailboxes or folders theu user is has full manage access to. in the cache setting just uncheck the box for shared folders
tracyprierNetwork AdministratorAuthor Commented:
cache setting in exchange or Outlook?
timgreen7077Exchange EngineerCommented:
Its in outlook. Do the following.

Open outlook > File > Account Settings > Account Settings > Change > More Settings > Advanced > Uncheck Download shared folder and uncheck Download Public Folder Favorites > Apply > Ok, and then close and restart outlook.
Jason CrawfordTransport NinjaCommented:
You have accidentally discovered profile auto-mapping in Outlook.  I have no idea why you're adding Full Access permission to these mailboxes just to manage calendar permissions, but if you're set on this course you need to remove/re-add Full Access permission to disable the auto-mapping feature.  This cannot be accomplished through any Outlook setting, it has to be performed on the server like this:

Remove-MailboxPermission -Identity salesguy@emaildomain.com -User csmanager@emaildomain.com -AccessRights fullaccess -Confirm:$false

Add-MailboxPermission -Identity salesguy@emaildomain.com -User csmanager@emaildomain.com -AccessRights fullaccess -AutoMapping $false

Open in new window

The -AutoMapping $false parameter is what you were missing the first time around.  Again though FullAccess is overkill if all you intended to add was calendar permissions.

I'm sorry upfront for upsetting the other folks in this thread, but it needs to be said.  You're getting some really bad advice and I would do a little more research before applying the "fixes" you receive before you encounter any more unintended consequences.
Jason CrawfordTransport NinjaCommented:
Here's a Technet article directly from Microsoft backing up everything I just said:

https://support.microsoft.com/en-us/help/2646504/how-to-remove-automapping-for-a-shared-mailbox-in-office-365
timgreen7077Exchange EngineerCommented:
Automapping is so that he mailboxes will map automatically or not map automatically but in regards to the mapped mailboxes being cached to the primary he needs to disable it in outlook as i mentioned.
Jason CrawfordTransport NinjaCommented:
Microsoft and I disagree.  Read the article.
Jason CrawfordTransport NinjaCommented:
You've given your opinion I've given mine.  Let's leave it at that and see what the OP says before this thread derails.
tracyprierNetwork AdministratorAuthor Commented:
Hello Jason.

The reason for the full access was that the method of getting the user themselves to share their calendar was flaky in that some shared calendars just become unavailable randomly.

What method would you suggest using ?

thanks
Veerappan SundaramSenior Technical ConsultantCommented:
If the purpose is to View the Free/Busy details of the team, No extra access is required.
By default, in Exchange 2007 and above, calendar's DEFAULT user permission is set to Free/Busy Time

Outlook 2010 and above has the feature to map team calendar based on Manager attribute with group calendar name as "TEAM: <Manager>"

You can create your own Calendar Group.
In outlook, click on Calendar. you will see the calendar options on the ribbon on top.
click on Calendar Groups --> Create New Calendar Group.
Add the users from GAL to view the free/busy information of the desired team members.
tracyprierNetwork AdministratorAuthor Commented:
They need more than just free-busy. they need full access to the sales reps calendars
Jason CrawfordTransport NinjaCommented:
There are multiple levels of permissions that can be applied to mailbox calendars:

https://technet.microsoft.com/en-us/library/dd298062(v=exchg.160).aspx

Capture.PNG
If "full access" is needed the equivalent folder permission would be Editor or Owner.  Here's an example of how to add:

Add-MailboxFolderPermission -Identity salesguy@emaildomain.com:\Calendar -User csmanager@emaildomain.com -AccessRights Editor

Open in new window

You can check what level of permission (if any) is currently applied by running the command I specified in my first response to  your post.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: Jason Crawford (https:#a42475774)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.