Excluding one particular Exchange CAS server to not participating in Autodiscover ?

Hi,

I have built and deploy Exchange 2013 CAS role only for basic authentication purpose back to the existing primary Mailbox/CAS role in the same AD site.

How can I exclude certain Exchange 2013 – CAS server so that it is not participating in the Autodiscover process?

AD Domain: MyCompany.com

AD Site: Site1DC1
PRDMAIL01-VM1 [MBX DAG1 member & CAS role]
PRDMAIL01-VM2 [MBX DAG1 member & CAS role]

AD Site: Site2DC2
PRDMAIL02-VM1 [MBX DAG1 member & CAS role]
PRDMAIL02-VM2 [MBX DAG1 member & CAS role]
PRDMAIL02-VM3 [CAS role only] --> the CNAME I created for this server is Auth.MyCompany.com

The objective of PRDMAIL02-VM3 server is just running for 3rd party application and NOT to actively participating in Autodiscover, Free Busy, EWS methods, etc… so all of my workstations picked it up as being active in the CAS array.

Thanks in advance.
LVL 9
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
 
IvanConnect With a Mentor System EngineerCommented:
Hi,

by default your domain computers are going to use Autodiscover SCP, and not DNS A record. You don't need to have DNS A record, and domain clients will still pick up Autodiscover from domain.

If you want to exclude one Exchange from Autodiscover, then set AutodiscoverServiceInternalUri to NULL for that server.

[PS] C:\> Set-ClientAccessServer -Identity “PRDMAIL02-VM3” -AutoDiscoverServiceInternalUri $NULL

Regards,
Ivan.
1
 
Justin EvansCommented:
first of all open a EMS and type the following:

Get-ClientAccessServer |ft identity, AutodiscoverServiceInternalUri,AutodiscoverSiteScope

This will show you who is in the CAS Array.

Then to remove type the following:

Set-ClientAccessServer –identity PRDMAIL02-VM3 –AutodiscoverServiceInternalUri: https://PRDMAIL02-VM3.Auth.MyCompany.com/autodiscover/autodiscover.xml

Kind Regards

Justin
0
 
Senior IT System EngineerIT ProfessionalAuthor Commented:
Hi Justin,

Does it mean it is just setting the AutodiscoverServiceInternalUri into another Exchange server or some random strings ?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
timgreen7077Connect With a Mentor Exchange EngineerCommented:
if you don't want the server to participate in Autodiscover just don't add it to the internal auotdiscover DNS record. add only DNS records for the servers you want to be found by auotdiscover.
0
 
Senior IT System EngineerIT ProfessionalAuthor Commented:
Hi Tim,

When I do NSlookup, the autodicover.domain.com resolves to all CAS server except PRDMAIL02-VM3.
0
 
timgreen7077Exchange EngineerCommented:
Good so that server will not be found by auotdiscover. I would just verify that th wre is no autodiscover DNS A record for that server, but most likely there isn't since nslookup didn't find it. you should be good to go.
1
 
Senior IT System EngineerIT ProfessionalAuthor Commented:
Thanks all !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.