OSPF Network Configuration

OSPF Network Configuration

ospf

I have configured OSPF on all 4 routers displayed in the topology above.
However from the Computer (Router, configured with No IP Routing), I can ping only the interfaces of R1: g0/0 , g1/0,g2/0. I can not ping from computer to any interface on R2 or R3 or R4.

Computer#sh run 
Building configuration...

Current configuration : 1389 bytes
!
! Last configuration change at 19:17:36 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Computer
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!         
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.15.5 255.255.255.0
 no ip route-cache
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
!
ip default-gateway 192.168.15.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Computer#  

Open in new window


R1#sh run 
Building configuration...

Current configuration : 1470 bytes
!
! Last configuration change at 19:07:02 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
 !
!
interface GigabitEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 !
!
interface GigabitEthernet1/0
 ip address 192.168.13.1 255.255.255.0
 negotiation auto
 !
!
interface GigabitEthernet2/0
 ip address 192.168.15.1 255.255.255.0
 negotiation auto
 !
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.13.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R1#

Open in new window



R2#sh run 
Building configuration...

Current configuration : 1456 bytes
!
! Last configuration change at 19:12:41 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
 !
!
interface GigabitEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 !
!
interface GigabitEthernet1/0
 ip address 192.168.24.2 255.255.255.0
 negotiation auto
 !
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
 !
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R2#

Open in new window



R3#sh run 
Building configuration...

Current configuration : 1456 bytes
!
! Last configuration change at 19:19:39 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
 !
!
interface GigabitEthernet0/0
 ip address 192.168.34.3 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 !
!
interface GigabitEthernet1/0
 ip address 192.168.13.3 255.255.255.0
 negotiation auto
 !
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
 !
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.13.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R3#

Open in new window




R4#sh run 
Building configuration...

Current configuration : 1549 bytes
!
! Last configuration change at 19:20:27 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 !
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
 !
!
interface GigabitEthernet0/0
 ip address 192.168.24.4 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 !        
!
interface GigabitEthernet1/0
 ip address 192.168.34.4 255.255.255.0
 negotiation auto
 !
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
 !
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.24.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!         
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R4#

Open in new window

jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atlas_shudderedSr. Network EngineerCommented:
configure your interfaces as ospf point to point

R1 is not configured to announce .25.0/24   all other hosts will be unaware of it  configure statement or redistribute static subnets
R2 is configured routing for .23.0/24, not .24.0/24 as noted - correct this

after these three changes, run:

show ip ospf neighbors and confirm you have neighbors showing and convergence
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
You are correct. I have not advertised the network 192.168.15.0 ..after I have advertised, the issue is resolved.

Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.