How to safeguard against IP configuration problems

The problem described below has been resolved.  What I am looking for is understanding as to why it happened, what was affected, and how might I safeguard against the problem happening again.

From one day to the next, my ipconfig went from this:
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : hsd1.ut.comcast.net
   IPv6 Address. . . . . . . . . . . : 2601:681:77f:c059:a1bf:653d:6494:f619
   Temporary IPv6 Address. . . . . . : 2601:681:77f:c059:5c7c:a1a4:1235:a8f0
   Link-local IPv6 Address . . . . . : fe80::a1bf:653d:6494:f619%5
   IPv4 Address. . . . . . . . . . . : 192.168.1.116
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::b675:eff:fe63:f4a4%5
                                       192.168.1.1

Open in new window


to this:
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::89f9:299b:1f80:bb7b%9
   Autoconfiguration IPv4 Address. . : 169.254.187.123
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

Open in new window


Notice a few things that are different:
-Connection-specific DNS suffix was wiped-out
-IPv4 address was assigned 169.254.x.x (which I laterlearned was a symptom of the DHCP server assigning a default IP????)
-Subnet mask changed from 255.255.255.0 to 255.255.0.0
Default Gateway was wiped-out / unassigned.  Which meant, of course, that I could not see or get to my router.

I tried googling and applying the solutions that made sense (and even some that didn't) including:

-ipconfig release / flush / renew
-netsh commands (various)
-unplugging power to my router(s), both cable and wireless, then powering-them back on (zero help)
-deleting letting Windows reinstall the wireless NIC adapter driver
-tried to hard-code DNS settings (IP and Gateway settings) instead of letting them be automatically assigned.  This never helped.
-sacrificed chickens
-vodoo dolls


-What finally worked was resetting Windows.  Fortunately I was able to keep my files.  But I am having to re-install all of my applications,including Microsoft Office, Visual Studio, Visual Studio Code, SQL Server,and Adobe Web CS4.  It's a pain.

I know next to nothing about networking, but after hours of research on this problem it seems to have to do with my DHCP Server failing to assign an IP address to my client (to my laptop)?

Does that sound right?

I am wondering what can be done to prevent this from happening again?  Is it the result of corruption that is fixable via RegEdit, or the reinstatement of some obscure file somewhere that I can backup and replace?

Would a deeper knowledge of networking under Windows 10 help me?  Recommendations?

It seems to me that if a re-install of Windows 10 fixed this, then it is an operating file issue, which means some sort of file corruption that the re-install FIXED.  So - what was corrupted?

Thank you so much.  No problems the past few days since I re-installed.
LVL 5
Tom KnowltonWeb developerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
About the only reason I see this results from:

1. Manual intervention in the DHCP settings. (this is the main reason)
2. There was some damage to the TCP/IP settings (driver issue, user issue. I do not see this as often).

If TCP/IP Reset fixes the issue, then it was one of the two things above.

Viruses are a possibility on any user machine.
Tom KnowltonWeb developerAuthor Commented:
Hey John : )

Makes sense, and my research seemed to support those 2 potential problems.

If it was a virus, which one?

Would finding and isolating / cleaning the virus fix the corruption?

Is there software BESIDES anti-virus, that specifically guards against attacks that render your wireless NIC cards unusable?

Thanks!
Tom KnowltonWeb developerAuthor Commented:
John:

Note:  I updated my question details since you posted, possibly.
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

masnrockCommented:
What do you exactly mean by IP configuration problems?

Was there an IP address conflict? That tends to be someone manually provided a device an IP address that was in the DHCP range. Only real solution would be restricting who can configure things to the network. Or even having some sort of process to ensure things are done properly BEFORE allowance on the network. Another thing that you might look into is using GPO to prevent users from being able to change TCP/IP settings on their systems.

Other issues can be caused by a damaged TCP/IP stack (hence the resetting John cited), driver issue, hardware issue, and so on.
JohnBusiness Consultant (Owner)Commented:
I have seen the issues you talk about and no viruses involved. I only mention viruses because people do silly things and then say this, that or the next thing does not work.

To your last question, we use Intel cards for the most part and I do not see anything render them unusable, except if someone changes variables.
masnrockCommented:
-IPv4 address was assigned 169.254.x.x (which I laterlearned was a symptom of the DHCP server assigning a default IP????)
Basically, that IP gets assigned if there's no luck with DHCP.

Weird that so much stuff wasn't showing when I originally was posting. Having seen all of this, a root of your problem could be even corrupted sections of software. One thing I did notice was you never mentioned trying another wireless card or even trying to update firmware (I did notice you tried reinstalling the drivers)

One weird thing I have seen are routers and cards just not playing nicely together. However, that's the type of stuff you would notice after certain software updates, not just some random day.

BTW - The tastiest way to sacrifice chickens is to fry them.
arnoldCommented:
The short answer the information you provide does not clear issues up.
1) to go from an assigned IP to a 169.254.x.x IP is the consequence of this system not receiving an IP.
THe reason for that can be vast.
a) the simplest is that the IPs available for allocation on the DHCP server are well below the devices using them. THis can be impacted by the DHCP configuration for the lease time. I.e. once an IP is assigned/allocated the amount of time, the DHCP server will excluded from subsequent allocation.
b) if all devices connecting the wifi no longer have IPS, this means the DHCP server is no longer responding.
2) a change and your system sync UP to a wi-fi different than regular and that wifi requires authorization to allocate an IP i.e. 801.x

in all it leads to the same, the DHCP did not provide an IP when requested....
Tom KnowltonWeb developerAuthor Commented:
he tastiest way to sacrifice chickens is to fry them.

: P

in all it leads to the same, the DHCP did not provide an IP when requested....

What is a DHCP server and where does it reside?  Can it be monitored?  Can I have some sort of warning or indication about WHY it is failing?

To my knowledge, nothing had changed from one day to the next.  It just .... STOPPED WORKING ... and then when I ran ipconfig to see what was the matter ... the 169.254.x.x was there and the Default Gateway had disappeared.  BTW, there are 2 other computers connecting wirelessly, and they never had any problems during all of this.

I still don't feel like I have a good understanding of why a Windows OS reinstall would fix this?  What did the reinstall change?
JohnBusiness Consultant (Owner)Commented:
In addition to the things we listed (TCP/IP Reset and Drivers), Windows 10 applies all driver updates it can, so it may have been driver interference that the reinstall repaired.
Tom KnowltonWeb developerAuthor Commented:
DHCP wiki

The DHCP operates based on the client–server model. When a computer or other device connects to a network, the DHCP client software sends a DHCP broadcast query requesting the necessary information. Any DHCP server on the network may service the request.

It seems my wireless NIC may have been failing to SEND the request?  Or does the 169.245.x.x assignment signify that the wireless NIC requested an IP and the DHCP server did not respond or respond properly?

In addition to the things we listed (TCP/IP Reset and Drivers), Windows 10 applies all driver updates it can, so it may have been driver interference that the reinstall repaired.

No problems were indicated with the device / driver for the wireless NIC card before or after I uninstalled and re-installed it.  So I wonder what Windows did differently?

I guess it is difficult to prevent this from happening?

I know ONE fix:  Reinstall Windows.

I am hoping for a less dramatic fix if this happens again.
arnoldCommented:
ipconfig /all
look for the DHCP server reference.
It will tell you the IP of the DHCP server that provided an IP, when the IP is 169.254 there is no DHCP server reference to be used.

you have to identify in your environment where the DHCP server/s is/are
router based, server base, wifi router, switch (level 3)

topology and information on the environment is needed/.
Jeff GloverSr. Systems AdministratorCommented:
All this is well and good but the basic thing you showed is this. You were getting a DHCP address from a Wireless router. (Probably a home router since they tend to use 192.168.0.0/24 or 192.168.1.0/24 as their DHCP range) The next day, your wireless could not connect to the router, hence, since your Wireless NIC was enabled for DHCP but found no DHCP server and could not ping its previously assigned Gateway, it assigned itself what is called an APIPA address. Automatic Private IP Addressing. This would lead me to believe that your Wireless card/NIC could not connect wirelessly to the router. If you rebooted and it came up and got an address, i would tend to believe you have either an intermittent Wireless Network adapter (I had one with a HP laptop that drove me nuts for weeks) or something in the OS that is causing it. Since you said you needed to reinstall windows, I would say it was a driver issue. Drivers are funny things.  A windows update can sometimes cause issues. You did not indicate whether or not any updates were installed the night before it died but I would think that could be a likely culprit.
  To answer your later questions, in your case, the DHCP service resides on your Router. you can view some details by logging into your router via the web interface (see your routers instructions for this), The reason you lost your address is not that DHCP stopped on your router but that your Wireless could not connect. If DHCP stalled but Wireless still worked, your computer would have kept its address until the end of its lease since it could still ping its default gateway.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.