How to allow local device like printer to send mails using smtp and basic authentification (clear password) via exchange 2007 server?

How to allow local device like printer to send mails using smtp and basic authentification (clear password) via exchange 2007 server?

I would like to allow devices like printers to send mails (notifications) using smtp and basic authentification (clear password) via exchange 2007 server?
The devices is on the same network as the Exchange server. And I would like create a specific windows account for each devices, to be used for authentification.
The current Exchange server have two send connectors one for the * address space (internet), a second one for the domain address space (*.domain.com):

get-sendconnector :

Identity               AddressSpaces                      Enabled
--------                      -------------                                 -------
domain.com         {SMTP:*.domain.com;1}      True
Internet                 {SMTP:*;1}                              True


I've to create an other sender connector?

And what about the receive connector for the device allowed to send smtp mails?
I must have basic authentification checked, in the authentification tab. Other paramaters?
And in the "permission groups" tab:
Which options must be selected among:
Anonymous users
Exchange users
Exchange servers
Legacy Exchange Servers
Partners

And what about the permissions (Add-adpermission commands)?
Wich permissions:
ms-Exch-SMTP-Accept-Any-Recipient
ms-Exch-SMTP-Submit
ms-Exch-SMT-Accept-Any-Sender
Others?

Thank you.

Jm
j75Asked:
Who is Participating?
 
Gaurav SinghConnect With a Mentor Solution ArchitectCommented:
you will need to create a new recieve connector to allow emails from Applications and other devices on Exhange. Once you create Receive connector, you will need to add the IP addresses of those devices to relay emails from the Exchange recieve connector and you will need to configure the SMTP settings on the printer device mentioning the Exchange IP or Servername and password.

Refer
https://confluence.atlassian.com/jira/how-to-set-up-smtp-relay-in-exchange-2007-188514374.html
https://technet.microsoft.com/en-us/library/ee428173(v=exchg.80).aspx
0
 
j75Author Commented:
Thanks Gaurav,

I've done a lot of tests, and I can now send email (i'm using "blat" utility to test).

In the receive connector  (with the ip device), the parameters are:
Authentification: basic authentification (I want an authentification, not like the conflucence.atlassian.com site's article)
(TLS is also checked but it's not necessary)

Permission groups: none

And, i've to create an accound an give him 3 permissions:
Add-AdPermission -Identity "receive_connector" -User "domain.com\user_smtp" -ExtendedRights ms-Exch-SMTP-Submit
Add-AdPermission -Identity "receive_connector" -User "domain.com\user_smtp" -ExtendedRights ms-Exch-SMTP-Accept-Any-Recipient
Add-AdPermission -Identity "receive_connector" -User "domain.com\user_smtp" -ExtendedRights ms-Exch-SMTP-Accept-Headers-Routing

(Now, I would like something more secured with TLS)

Best regards.

JM
0
 
Gaurav SinghSolution ArchitectCommented:
Can you check the Email headers of the Relayed emails and paste it here.  Also try to do SMTP test on mxtoolbox.com and share the result with us.
0
 
Delphineous SilverwingGood Ol' GeekCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: Gaurav Singh (https:#a42469848)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Delphineous
Experts-Exchange Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.