ESXI 6.0 HP switch Trunk problem

esxi1 -dhcp and 3xNICs   vmnic0,vmnic1,vmnic2

on HP 3400cl Switch configured:

Vlan 1 -   DEFAULT                
vlan 10-   ISCSI                        
vlan20-    MS DHCP Server  

created:
TRK1 port 22-24   all are member  VLAN 1,10,20


at the Moment only vmnic0 connected to TRK1 port 24 and work all.
if i Connect  second Network Card( vmnic1) to TRK1 port 23 ,then i loose all Connections , i cant Connect nothing till i plug out vmnic1 .

any help?
needs needsAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
LACP not supported on ESXi.
0
 
65tdCommented:
VMWare best practice for iSCSI networking is a dedicated nic on it's own network.

See info from vmware page 14:
https://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/support/landing-pages/virtual-support-day-best-practices-virtual-networking-june-2012.pdf
0
 
needs needsAuthor Commented:
Hi 65td
Thank you so much for info. But my Problem is Trunk ,if i Connect to vmnic physical TRK1 port then loose all Connection till i plug out it.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
needs needsAuthor Commented:
i did one test. I plugged only one VMNIC0 to HP Switch Trunk port 24. and plugged out ISCSI NAS machine from ESXI host and created Test Linux vm on the LOCAL DATA STORE.

ist the same Problem ,if i plug the second NIC to HP SW port 23 ,then NO Connection again.
0
 
JustInCaseCommented:
On switch side LAG is configured, what about other side (vmnic0,vmnic1,vmnic2)?
Generally, it is recommended to configure LACP LAG on both sides.
0
 
needs needsAuthor Commented:
i did not know ,if i Connect to esxi over TRUNK port NEEDS LACP enabled?
0
 
JustInCaseCommented:
If one side is bundled in LAG other side must be too. LACP is industry standard to create LAG.
0
 
needs needsAuthor Commented:
ok Thank you ,i will test today
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.