emelFM2 question

I have a Windows PCs that won't boot anymore. I'm trying to use the emelFM2 utility from my (Linux) System Rescue CD to copy files and folders onto another media. But emelFM2 is displaying all the folders in Linux-speak (bin, dev, etc). Can I get emelFM2 to display the usual Windows folders ("Desktop," "Documents," "Downloads", etc.).
john8217Asked:
Who is Participating?
 
Scott SilvaNetwork AdministratorCommented:
OK. This should get you going

mount -t ntfs /dev/sda1 /mnt/windows -o ro

ntfs-3g /dev/sdb1 /mnt/backup

Open in new window


Then you can copy whatever you want to save from /mnt/windows to /mnt/backup as /mnt/backup will be your passport drive

/mnt/windows/users  will show all the user profiles that were on the windows computer.
Inside one of them will be your documents, pictures, etc.
0
 
Scott SilvaNetwork AdministratorCommented:
Not in the way that windows shows them... Most linux rescue disks mount the found drives under a mount folder since linux only has one file system... I can't remember if System rescue CD automatically mounts any found partitions or not... Let me get a copy and I can be more specific.
0
 
john8217Author Commented:
I took two pictures with my camera, but they look like crap (I don't know how to take a screenshot while booted from Linux). I then pasted them into a Word doc and attached it. I would have preferred to embed the pictures but I can't: I tried embedding them twice but both times it crashed my PC and I had to do a cold shutdown.
     The first picture is the emelFM2 console.
     The second picture, I clicked on "Menu" (bottom-left corner of the GUI desktop), then "System" and then "Show Filesystems."
emelFM2.docx
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Scott SilvaNetwork AdministratorCommented:
System rescues CD does not auto mount your windows partitions...

Run the following in a shell (The yellow box called "Command Prompt"

mount -t ntfs /dev/sda2 /mnt/windows -o ro

Now the /mnt/windows folder should no longer be empty.

Browse to Users/username and your folders should be there...
You will need to also add something to copy them to like a USB stick...

After adding a USB stick use the Show filesystems tool to find out where the USB stick is and mount it
Should be mount -t vfat /dev/xxx  /mnt/backup  with xxx replaced with the device that the USB stick is under

If you need more help I'm here for a couple hours more
0
 
john8217Author Commented:
Thank you for the info. I won't be able to try it for another hour (I'm  somewhere else). But I was wondering;
1) I looked up the man page for mount but I'm still not sure what the -o switch does. Could you briefly explain?
2) The man page says ro is to mount it as read-only. Is that necessary? (just trying to learn from this).
0
 
Scott SilvaNetwork AdministratorCommented:
-o is for mount options and yes RO is read only... The safest way to mount a NTFS system you are just recovering files from...

Obviously you won't mount the recovery target as read only

The mount options on the recovery drive will depend on what file system is on it...
0
 
john8217Author Commented:
Wait, hold the phone.
That Filesystem screenshot I sent you was the wrong one, it was from another PC that I'm working on. My mistake, sorry. This image here is the correct one:
Correct screenshot(I'm doing this from another PC from another place, now I'm able to embed files. I don't need to send the correct image of emelFM2 because it is already identical. I also have this embedded file attached, just in case you can't see the embedded file).

     I didn't get a chance to manually mount the Windows partition. I got home way later than I thought and had to do something else. I'll have to do it tomorrow after work. But I have a few more questions, if that's OK:
     1) I currently have an external hard drive plugged into that PC (that's the destination I plan on copying the files over to). Notice how that external hard drive shows up in Filesystem (as "My Passport") with a label. So I would think that it's already mounted, but I looked inside every major directory and I still couldn't find "My Passport." How come? Is it possible for Linux to give something a label and still not mount it?
     2) When I'm done using the GUI in System Rescue CD, how do I properly shut down? I've been doing a cold shut-down because I don't know how else to end it.
     Once again, sorry for the mix-up.
0
 
john8217Author Commented:
That worked! Great! Thank you very, very much.
0
 
john8217Author Commented:
Thank you for all your help.
0
 
Scott SilvaNetwork AdministratorCommented:
You are very welcome!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.