Symantec Backup Exec 2010 services keep stopping.

We've had Symantec Backup Exec 2010 running just fine on this server but all of a sudden its services keep on stopping all by themselves and we have to keep on restarting them, but, it's unusable at the moment.

The admin password hasn't changed, I re-entered it for all the services, but they keep on failing all by themselves.

I've restarted the server as well, tried a repair, but nothing has helped.


Any thoughts?

The OS is Windows Server 2012, Backup Exec is up-to-date.


Thanks.
LVL 2
Tiva-ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Hi

What errors criticals or warnings are in the windows event logs? system and application logs?
What are the symantec backup exec logs saying?
Have you ensured the product is up to date by using the live update option usually under the help menu?
Try looking for help and test utilities within backup exec
Try looking at the account being used to start or stop the services in services.msc , perhaps if it is the default account give it a privileged account of its own? a service account.
0
Tiva-ITAuthor Commented:
Hi there.

Yes, I've already said that Backup Exec is up-to-date.

The only warning about Backup Exec in the event viewer is the following: "The application (Backup Exec, from vendor Symantec) has the following problem: Backup Exec is incompatible with this version of Windows. For more information, contact Symantec."

But it's been working fine for years until this week.

It's had the domain admin account credentials up until now and they've worked just fine, as I said, the password hasn't changed, put the details back in to ensure, problem still occurs.

Can't do test utilities now as have done a second repair and will have to restart the server monday again...

Any other thoughts?
0
Hello ThereSystem AdministratorCommented:
Do you have enough disk space?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Any windows updates installed in the last week? that might cause the issue perhaps?

Try disabling or uninstalling your anti virus.
0
Hello ThereSystem AdministratorCommented:
Run it in compatibility mode.
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Give the services a local administrator or different account as a test?
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
0
Tiva-ITAuthor Commented:
Hi there.

Yes, we have enough disk space.

No Windows Updates have been installed since middle of December last year.

Won't be able to start it in compatibility mode or start services as a different user for now as I tried repairing it again and I won't be able to restart the server until Monday.

We have Sophos AV, has had that until now and has been fine, will try with on-access scanning disabled, but again, what puzzles me is that nothing changed yet it stopped working out of nowhere.
0
Tiva-ITAuthor Commented:
No abnormally-sized log files either...
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Obviously something has changed either with the application or something around it, just have to figure out what it is.

Have you looked at the symantec logs? advanced logging for symantec?
0
JohnBusiness Consultant (Owner)Commented:
You have an older version of Backup Exec on a decently new server. Have Windows Updates perhaps have changed something in there area of security that has cause an issue for Backup Exec 2010?

We are using Backup Exec 2015 on all our Server 2012 R2 machines.
0
Tiva-ITAuthor Commented:
Hi.

Yes, I know it's old, it's all we have.

Already said that no Windows Updates have been installed since mid-December.
0
Brent FugettIT SpecialistCommented:
I started experiencing a very similar issue two days ago.    I'm using Symantec Backup Exec 2010 R3 and it's worked well for years up until this past Wednesday, 2/14/2018 around noon the Backup Exec Server service stopped, and it won't stay running for more than 30-40 minutes, usually no more than 10.    The application Event log shows the error as follows....

Faulting application name: beserver.exe, version: 13.0.5204.1279, time stamp: 0x53321a8c
Faulting module name: MSVCR80.dll, version: 8.0.50727.8428, time stamp: 0x520b0ac2
Exception code: 0xc0000005

And it is always preceded by this event within a few minutes...

Source: ApplicationExperienceInfrastructure
The application (Backup Exec, from vendor Symantec) has the following problem: Backup Exec is incompatible with this version of Windows. For more information, contact Symantec.

I'd really like to at least temporarily disable ApplicationExperienceInfrastructure if possible to at least troubleshoot.   It looks like Backup Exec is the only application it complains about.    

We've ran BE diagnostice with no issues detected.   Also we've exected beserver.exe with the -console switch to see what's going on during the halt...   Nothing shows at all, the application simply dies and leaves no error log entry.    Memory/disk are all nominal, and we install updates manually (they download only then wait for our install).    I can see nothing that was installed in the 6 hours between when it last worked and when it started failing.
0
Hello ThereSystem AdministratorCommented:
I suggest you to contact official support.
0
Tiva-ITAuthor Commented:
I tried contacting official support, but obviously they wouldn't help at all...

I wonder whether the application experience message had always been there but I've just not noticed it.

Will try a couple of things tomorrow and post back, I can only restart the server tonight.


Thanks.
0
Hello ThereSystem AdministratorCommented:
FYI Backup Exec 2010 R3 SP3 is not supported in Windows Server 2012 R2.
The only solution seems to be to upgrade to Backup Exec 2014.

What do you have? Windows Server 2012 or Windows Server 2012 R2?
0
Tiva-ITAuthor Commented:
I know, but, it worked absolutely fine until last week...
0
Hello ThereSystem AdministratorCommented:
From Veritas employee:
There were significant background differences between Windows 2012 and Windows 2012 R2, as such you will need Backup Exec 2014. Although you should be aware that for some of the more advanced options on Windows 2012 R2 that you may want to backup, your Backup Exec 2014 media server may also need to be running Windows 2012 R2 - although this does depend on your environment.

BTW 2010 Rx variants all officially go end of Engineering / Patch level support in a couple of months as such enhancements (things that aren't hi-criticality defects) to the 2010 Rx series are unlikely to take place
0
Hello ThereSystem AdministratorCommented:
I am afraid you cannot revert it. Accept the fact and upgrade BE to 2014 version.
0
Tiva-ITAuthor Commented:
Still, I'm really curios as to what exactly happened, why it is that it isn't working anymore since it worked just fine for years.
0
Hello ThereSystem AdministratorCommented:
Just check the log file:
https://vox.veritas.com/t5/Articles/LOG-Locations-in-Backup-Exec/ta-p/813034

As has been said, it could be any BE update.
It's hard to believe but they could just end the support without warning...
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
I asked for backup exec log too earlier. needs to be seen given we dont have vendor support.
0
Brent FugettIT SpecialistCommented:
Tiva-IT I may have information on this behavior for you but I don't want to put out the specifics unless I know my situation mirrors yours. Can you check the server's application event log and see if events similar to the ones I referenced above are there coinciding with your failures?   We have applied some workarounds that have our backups functional again while we look for a replacement.
0
Tiva-ITAuthor Commented:
Hello Brent.

All we have in the logs is the error about it not being supported on Server 2012...

We didn't get the other error that you were mentioning though.

Still, I don't get it, no Windows updates have been installed, no Symantec updates installed, nothing changed, yet, all of a sudden, it doesn't work anymore...

Does anything make the services remain running? Were you able to find a fix?
0
JohnBusiness Consultant (Owner)Commented:
That version is not supported on Server 2012 (never was). That doesn't mean it won't work, but when it breaks, there is not much way to fix.  I see the same thing with out-of-support cards and drivers.

You need to upgrade Backup Exec and get support with the new version.
0
Tiva-ITAuthor Commented:
Yes we know it wasn't supported, but it's worked for years, hence the posting of the question.

Interesting that it's happened to someone else as well, not just us.
0
Brent FugettIT SpecialistCommented:
What I found was it was the execution of the BE GUI that was triggering the compatibility warning and I suspect Windows is applying a compatibility shim that's actually crashing the Backup Exec Server service. No way I can tell for sure as the buexec.exe logs just simply stop at the crash, no indication beyond what's in the application logs.   to work around I set up a scheduled task that runs just before my nightly job to make sure the services are all running (there's an exe in the Backup Exec folder that you run with a switch, don't have that handy but you can Google for it).  I only need to briefly launch the GUI to check the prior night's backup so it shouldn't really disrupt me too badly.   Still as others have pointed out I'm considering this the writing on the wall and pursuing an upgrade or a different product,  but at least I have some breathing room.
0
Gavin LewisCommented:
Hi guys - exactly the same symptoms as you have described but we are running Server 2008 R2 (so no compatibility issues).  Was working perfectly until last Wednesday (14 feb 2018)  and now the server service crashes anywhere between one and five minutes once the gui has been opened.

Have tried everything that I have found elsewhere on the web (net framework updates, application repair, service accounts...) all to no avail.

Also spoke to a very friendly Veritas person who told me that we just need to update to a later version.  Nice.

Will try your suggestion Brent but if anyone has any ideas on a fix would be very grateful!!
0
Brent FugettIT SpecialistCommented:
Hey Gavin, that's good to know. Same/similar app events as what I posted??
0
Tiva-ITAuthor Commented:
Oh wow, how nice of them... Thank God for Windows Server Backup, it's what we're using now...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gavin LewisCommented:
Yes exactly the same error (French OS but it means the same thing!):

Nom de l’application défaillante beserver.exe, version : 13.0.5204.1279, horodatage : 0x53321a8c
Nom du module défaillant : MSVCR80.dll, version : 8.0.50727.4940, horodatage : 0x4ca2b4dd
Code d’exception : 0xc0000005

+ didn't mention, but no recent updates were made and same symptoms after anti-virus uninstalled.

Did Symantec/Veritas add a self destruct to their code?!
0
Tiva-ITAuthor Commented:
Only God knows guys, only God knows.

I have no idea how they could disable a piece of software without any updates being installed...
0
Brent FugettIT SpecialistCommented:
Without evidence it's all just conjecture.  

One thing I haven't tried yet, run the Backup Exec console remotely on a workstation to see if it still fails?
0
Gavin LewisCommented:
Just tried the console from another Server 2008 R2 machine and same problem unfortunately.  Didn't update to latest SP yet but not holding my breath...

My usual jobs are planned for this evening so fingers crossed that the 'Brent method' works for us to!
0
Brent FugettIT SpecialistCommented:
FYI here's the cmd for the task to start the services.  Find it in Backup Exec program folder. I like this be method because it insures all services are running, not just the one.  Obviously you'll want to test it well...

bemcmd -o502

https://www.interworks.com/blog/jkim/2010/01/28/backup-exec-schedule-restart-be-services-command-line-using-bemcmdexe
0
Frazer DixonCommented:
We have exactly the same product issue, that started on the same time and date. Ours started failing on Feb 14 at 12:08pm EST.
This is strange as nothing changed on our system either and it has been running successfully until this time.
0
Frazer DixonCommented:
Would it be possible to leave this open for a little longer. I would like to see if other users are experiencing the same issue. If there is some sort of kill in the Symantec it would be good to get an idea of the impact.
0
Brent FugettIT SpecialistCommented:
Agree
0
JohnBusiness Consultant (Owner)Commented:
Backup Exec 2010 is not compatible with Server 2012, so I would be surprised if you can fix the breakage.
0
Brent FugettIT SpecialistCommented:
I completely agree but I take issue with the notion that there isn't something to be uncovered here.  A 2008 server is reported as having this issue which should NOT have a compatibility issue.  Until we figure out why it happened who knows when it will crop up again and where.   Not encouraging.
0
Merwan ITICommented:
Hey,
We have the same problem on a dozen of our customers, mostly on 2008R2, and some on 2012R2 since last week.
No windows update we're installed before those service crashes.
We updated BE  with LiveUpdate. tryed to repair BE too, but service keeps crashing.
We are still looking for resolution.
0
Corentin LEGALLCommented:
Same here wait and see
0
Hello ThereSystem AdministratorCommented:
As I said before you need to contact Symantec BE Support and be insistent. Escalate it to the higher level of their support. Ask for explanation. They might give you some hints...
0
Hello ThereSystem AdministratorCommented:
I've seen crashing apps due to licence issues. Check this too. Maybe re-adding the licence might be what you need.

Try to set the region and language to US.

Also try to update or downgrade .NET Framework.

Are you running 32-bit BE on 64-bit WS2012?
0
Hello ThereSystem AdministratorCommented:
As per you description this happens when you try to use GUI...
Locate the Backup Exec .exe file -> Properties and try to run it in lower resolution, disable visual themes and so on and then run the program from the C:Program Files... -> Right-click -> Run as Administrator -> type Domain Admin credentials and if this won't help, type Local Admin credentials.
Consider updating video drivers.
0
Hello ThereSystem AdministratorCommented:
Do you use SEP? There is might be a compatibility issue between BE and SEP.
0
RSI RSICommented:
Hello,
same problem dated 14 February. with a 2008 r2
And Sophos antivirus installed
0
Hello ThereSystem AdministratorCommented:
Use this to collect more data: https://www.veritas.com/support/en_US/vqa
0
RSI RSICommented:
Hello,
same problem dated 14 February. with a 2008 r2
And Sophos antivirus installed
and graphic card Matrox G200e installed
0
哲瑋 許Commented:
i have the same problem,
2008 R2 (64bit) with Backup Exec 2010 (64bit) ,
the last date success backup  is 2018/2/13
0
Tiva-ITAuthor Commented:
I was kind of trying to unsubscribe from this because we already switched to Server Backup, but I guess this is useful for other people experiencing the same thing...

How does one unsubscribe to emails from one question only? By closing the question?
0
Soleil CelebTechCommented:
I have the same problem with 9 servers,
Win 2008 R2 with Backup Exec 2010 R3
Win 2003 with backup exec 12.5
0
Maximus KittysonCommented:
Same exact issue here.  I've actually been running it on Windows Server 2016 for over a year without any issues.  No Windows updates have been installed during that time.  Suddenly on 2/14 the service crashes every 5 minutes.   At first I thought it was only happening when the BU GUI was running/active, but seems to be happening whether it's open or not.

Agree that product is outdated and probably time to upgrade, but very curious what happened all of a sudden to cause this.
0
Frazer DixonCommented:
I just got off the phone with Veritas, I spoke with a supervisor and he is going to escalate the issue.
I explained that this goes beyond support, as an owner of the software they do not have the right to have code in it that stops it form working.
I will keep you updated once Veritas gets back to me.
0
Brent FugettIT SpecialistCommented:
Thank you Frazer!   Tell them the many people following this thread are anxiously awaiting their response.   lol
0
Joe YiuCommented:
Same problem

Small Business Server 2011 Standard,  Backup Exec 2010 R3, the “Backup Exec Server” service will stop by itself when the backup up job is launched or when backup job is run.
I got the Application error in the system log  ( beserver.exe  13.0.5204.1270, MSVCR80.dll 8.0.50727.6195)
I have tried to
-      Create new backup device (new backup to disk folder to different drive) and media set
-      Repair the software through software and features
-      Run live update in the application
-      Clear files in C:\Program Files\Symantec\Backup Exec\BEDBG
-      Installed hotfix be5204R195395_x64bit and batch BE5204.1225RSP3_x64bit
-      Run “Repairing Database” with BEUtility
-      Change the credential of the service

all didn't help, waiting for the solution
0
Hello ThereSystem AdministratorCommented:
Finally someone was able to start this thread...
https://vox.veritas.com/t5/Backup-Exec/Service-Backup-Exec-Server-crash-with-Backup-exec-2010-R3/m-p/847267

Check the last comment that provides a few suggestions by Veritas employee.
3
哲瑋 許Commented:
https://vox.veritas.com/t5/Backup-Exec/Service-Backup-Exec-Server-crash-with-Backup-exec-2010-R3/td-p/847267

Create the DisableThreatconStatusPolling registry key in the Technote below and set it to 1  or disabled.
https://www.veritas.com/support/en_US/article.100005403.html

I have tried to do it, now seems good
3
Hello ThereSystem AdministratorCommented:
In case the link becomes blind...

1. Go to Tools - Options - Network And Security - Uncheck or disable "Run Backup Imediately when and Elevated ThradCon Level is reached" if it is enabled/checked.
2. Stop the Backup Exec services
3. Browse to HKLM\Software\Symantec\Backup Exec For Windows\Backup Exec\Server
4. Click Edit | New | DWORD Value = DisableThreatconStatusPolling
4. Set the Value data to 1 decimal to disable the status polling.
4
Joe YiuCommented:
https://www.veritas.com/support/en_US/article.100005403.html

seems it works for my case, thanks a lot!
0
Didier HossayCommented:
Thanks.

Working for me too
0
Hello ThereSystem AdministratorCommented:
That's really nice to hear that the link I provided was that helpful. Awesome!
1
anthony andrieuxIT managerCommented:
Hello,

not lucky for me, it does not work.
The option was not activated in Backup Exec so I just added the registry key after stopping all BE services. I restarted them and after a few  minutes it crashes again (even if BE console does not run).
I use BE 2010 R3 on a 2008 R2 SP1 server.

Anthony ANDRIEUX
0
Gavin LewisCommented:
Thanks Frazer and Hello There, beer all round!

My gui has been up for over 20 minutes without crashing the service so I'd say that the fix has done the job.

Would love to know what happened though - more than strange that this happened on numerous installations at the same time/date...
0
anthony andrieuxIT managerCommented:
The problem seems to be solved for me too. It was a stupid error from myself.
I copied the name of the registry key in the web page and pasted it in the registry but there was a blank at the beginning.
I corrected that and for the moment all is OK.
0
Brent FugettIT SpecialistCommented:
I've applied the fix as well and disabled my contingency.   It's been up for about 20 min but it stayed up for about an hour once after I tried switching service credentials (I think), so I'm not calling it until I see it uninterrupted all day and through a successful backup job, but your reports are very encouraging.  

I too would like to know what triggered this.  If it really is an intentional upgrade fuse I don't think we'll ever know that.
0
Julien DAL GOBBOCommented:
Thank you for the workaround...  (https://www.veritas.com/support/en_US/article.100005403.html)

It was the same thing for me ! 2008R2 + BE 2010 R3 SP4 ..

Beremote.exe crashed every 5 min... since 2/14/18 ... Symantec... what are you doing with your code !
0
Maximus KittysonCommented:
This appears to have fixed it for me as well, no more crashes.  Thank you!
0
Brent FugettIT SpecialistCommented:
Up now for 3 hours.   I think it's good.   Thanks all for the good work!
0
Tiva-ITAuthor Commented:
Sorry guys, I wanted to close the thread as I didn't want to receive the notifications about the comments anymore.


Thanks.

(just use Server Backup, there aren't any features it doesn't have...)
0
pm ngCommented:
Hi all,

I have the same problem, almost at the same day as most of you.
Mine problem started on 16 Feb 2018, that is very strange

System:
windows 2008
Backup exec 2010 R3
0
Frazer DixonCommented:
Guys I wanted to provide an update that I received from Veritas that looks like it resolves the issue.
I have pasted a couple of email bodies below that discuss the reason and the resolution.

180220-002033 | Backup Exec 2010 - Services keep stopping.

I have engaged further with our Support team and Engineering team around the issue you are facing.

Currently, we believe the issue is linked to a dependency that Backup Exec 2010 has with Symantec Threatcon. Symantec made changes to their Threatcon level on the 13th February which is around the same time your issue began occurring


Following on from my last email please find attached our new technote describing the issue seen:

https://www.veritas.com/support/en_US/article.100041911


https://www.symantec.com/security_response/threatcon/

If your issue is related to the Threatcon process, this can be disabled by completing the following steps.

1.            Go to Tools > Options > Network and Security – Uncheck or Disable “Run Backup Immediately when an Elevated Threatcon Level is reached.”
2.            Stop the Backup Exec Services
3.            Create the DisableThreatconStatusPolling registry key in the following technote - https://www.veritas.com/support/en_US/article.100005403.html

The Support team are also in the process of creating an updated technote around the above findings.

Please also be aware that Backup Exec 2010 reached full End of Support Life “EOSL” on Feb 1st 2017. This means that after this date no support of any kind is available for this product:

https://www.veritas.com/support/en_US/article.000116356

If the above steps do not resolve your issue we would strongly recommend that you upgrade to a supported version of Backup Exec.
1
Frazer DixonCommented:
See I am a little late to the party. Some of you have already got the fix.
I hope this works for everyone.
I guess this can be closed.
Cheers guys.
0
Tiva-ITAuthor Commented:
Hi guys.

I tried the fix on a Server 2012, seems to have helped, but, we already switched to Server Backup as we had other issues with Backup Exec 2010, namely, that it wouldn't detect plugged in drives and we had to have a user always click on the online button for the drive which was annoying...
0
Leif SCommented:
Worked for me, Server 2012R2 BE 12.5 Rev 2213 SP4.  Thanks, my issued started at the same time as everyone else's.
0
Bertrand MERICCommented:
Bonjour,
J'avais le même probléme (2008 R2 + Backup2010), et depuis la découverte de ce post je vous béni chaque jour lors de l'insertion de ma cartouche.
Encore un grand merci à tous pour cette solution que je n'aurais pu trouver seul.
Cordialement,

Hello,
I had the same problem (2008 R2 + Backup2010), and since the discovery of this post I bless you every day when inserting my cartridge.
Another big thank you to all for this solution that I could not find alone.
Cordially
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
symantec backup exec

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.