• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

Windows 10 (Home Edition) keeps dropping mapped drive connection

We have two Windows 7 and two Windows 10 (home version) PCs in our office. Each is connected to the same LAN HDD, as a mapped drive. The Windows 10 machines disconnect the mapped drive 10 or more times a day (the network connection stays intact). However, the connection can immediately be restored by clicking on the mapped drive (when disconnected, it displays a red "X"). This never happens with the Windows 7 machines, so it seems to be an issue with Windows 10 settings.
Every time a Windows 10 machine disconnects the mapped drive, it crashes a database we have on the LAN HDD, so I would really like to find a solution to prevent this from happening.
I found a few articles regarding this problem:
https://community.spiceworks.com/topic/1139165-windows-10-losing-mapped-drives?page=1
https://www.qdoscc.com/blog/following-windows-10-upgrade-mapped-drives-disconnect-briefly
https://www.mcbsys.com/blog/2016/08/windows-10-repeatedly-disconnects-network-drives/
However: (i) much of the discussion in these threads seems to be about servers (not PCs), (ii) suggested solutions involve changing the Group Policy from “Replace” to “Refresh”. We don’t seem to have “Group Policy” settings on our machines (maybe because they are W10 Home Edition ?), (iii) the threads seem a bit inconclusive as to whether this is a permanent solution, and whether or not it causes other issues.
I am reasonably “handy” with computers, but not an IT expert. Any suggested solutions would be much appreciated !
0
Paul McCabe
Asked:
Paul McCabe
  • 6
  • 3
  • 2
3 Solutions
 
JohnBusiness Consultant (Owner)Commented:
Go to Control Panel, Advanced Network Sharing on all machines. Look down the page and make sure Home Group is OFF on all machines. Mapped Drives work but outside of Home Group.

Make sure the Network cards are set to Private (or Work), not Public.
0
 
Andrew LeniartSenior EditorCommented:
Hi Paul,

I think you may have already hit the nail on the head with your own research. (Well done!)

seems to be about servers (not PCs)
While not always the case, in the first research link you provided, editing Group Policy would apply equally to Windows 10 as to a server.

We don’t seem to have “Group Policy” settings on our machines (maybe because they are W10 Home Edition ?)
Bingo. Well done on your research.

Your solution would be to either upgrade your workstations to Windows 10 Pro (or higher)
or
Try to enable Group Policy on your Windows 10 Home installs. This ITECHTICS article explains a means of doing that, but I've never personally had cause to try it, so I don't know if it will work or how helpful it might be.

Note that I've also not looked into the legality of the above process. Following that article could see you in breach of Microsoft licensing, so I would advise caution.
0
 
Paul McCabeAuthor Commented:
Dear All,

Many thanks for your comments and suggestions.

I tried switching off the home group, but unfortunately that did not resolve the issue. I also tried to enable Group Policy on our W10 Home Edition machines per the link suggested by Andrew. The Group Policy editor was installed, but no group policy settings seem to exist (and if it is possible to set these on a home edition machine, unfortunately I don't have the level of expertise to do so).
So at the moment it looks as if the only way to potentially resolve the issue would be to upgrade to W10 Pro. However, I find it difficult to believe that an OS (even Home Edition) would have this behavior as default. If it did, there would be tens of millions of people with this problem, many of them complaining to Microsoft, who presumably would have done something about it by now.
I will try digging a bit more and update this post asap, one way or the other.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Andrew LeniartSenior EditorCommented:
So at the moment it looks as if the only way to potentially resolve the issue would be to upgrade to W10 Pro.

I suspect that will be the end result.  It may be possible to edit the registry manually to resolve this, but I've not seen anything like that before. It's been some time since I've used a Home edition of Windows but from what I can recall, many required registry entries will likely just be missing, or have no effect if manually added.

I will try digging a bit more and update this post asap, one way or the other.

Thanks Paul, please do.

And thank you for taking the time to update the thread with your progress.

A courtesy all too often lacking at times.

Regards,
Andrew
0
 
Paul McCabeAuthor Commented:
I talked with Microsoft support for Windows 10 Home Edition. The best they could do was point me towards the following link:
https://support.microsoft.com/en-us/help/297684/mapped-drive-connection-to-network-share-may-be-lost
…..and warn me that since it does not cover Windows 10 they couldn’t guarantee that it would work, and wouldn’t take any responsibility if it wrecked my PC. Well, thanks a lot Microsoft.

It seems reasonably clear at this stage that there is no reliable solution for this issue for Windows 10 home edition. Not great news, but hopefully this information will save someone else the bother of looking for a solution that does not exist.

So I bit the bullet and upgraded to Windows 10 Pro. Unfortunately, the issue still persists, although on the plus side the frequency of disconnection seems quite reduced.
After upgrading to Pro I tried the “net config server /autodisconnect:-1” procedure described in the Microsoft link, but it had no effect.
There is a group policy editor, but it does not contain any group policy for mapped drives, so it looks as if I would have to create a policy myself, and this is going beyond my level of skill (and not sure even then if this would solve the problem).
So right now it looks as if the options are:
1)      dole out ~500 USD on Microsoft Pro support and hope they can fix it
2)      wait a bit more to see if anyone else in the EE community has any more ideas
…or of course just put up with it. It is still irritating though, even with the reduced disconnection rate.
So for the time being I'll opt for 2) and  keep this thread open for a little longer in the hope of more ideas…
0
 
JohnBusiness Consultant (Owner)Commented:
Try two things:

1. Make a new, test Windows User Profile (Account).  Log into the new Windows Account and test drive mapping stability.

2. If that does not work, do a Windows 10 Repair Install and Keep Everything.

Go to the Media Creation Link

https://www.microsoft.com/en-us/software-download/windows10

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.

Please let us know if this helps.
0
 
Andrew LeniartSenior EditorCommented:
Agree it's time to try a new user profile to rule out a corruption. If you're going to go down that path, you may find my following articles of some help.

Creating a Local Administrator User Profile in Windows 10

Create a new Microsoft Account User Profile in Windows 10

Hope that's helpful.

Regards, Andrew
0
 
Paul McCabeAuthor Commented:
Thank you for your comments and nice instructions for creating a user profile !

My initial thought was that a new profile / repair install was unlikely to solve the issue because: i) the problem has been around since the PCs were brand new and ii) the 2 Windows 10 PCs have the same issue (unlikely that both simultaneously developed a corrupt user profile etc.) In any case I went ahead and created a new profile, but the drive gets disconnected there too. With Repair Install, it will take me half a day to re-install the 20+ installed programs, so I need to find time for this, especially as this PC is actively being used for work.

In the meantime though, I have a few more ideas to try. I will update  when I have had carried these out and know the results. Incidentally, sorry for the delays in responding, the nature of this disconnect issue is such that it takes a while to  check if there has been any effect after making changes.
0
 
Paul McCabeAuthor Commented:
I managed to solve the issue described above on both the Home and Pro versions of Windows 10. The solution is described below, but let me first mention that there seem to be two separate mapped drive “red X” issues with W10:
1)      Red “X” on startup
2)      Intermittent red “X” while the PC is in operation

1)      Red “X” on startup
Although this is a well documented issue, as far as I can see, no one (including MS) has ever come up with a robust solution. Some people claim it arises from the fast speed of modern SSDs, which are up and running well before the network adaptor is. This sounds plausible and might explain why some people never experience a red “X” on bootup. The mapped drives on our Windows 10 PCs get a red “X” on startup 8 out of 10 times, and indeed, they are pretty fast machines with SSD drives.

2)      Intermittent red “X” while the PC is in operation
The solution that worked for us was to adjust the power saving setting of the network adaptor.
Device Manager >> Network card >> Power management options >> “Allow the computer to turn off this device to save power” option >> Disable
Apparently this setting was making the network card cut power to mapped drives after a period of inactivity. Although this tweak made the problem disappear, I also did the following to doubly ensure power to the mapped drives would not be cut:
i)      Control panel >> Power options >> Advanced settings >> PCI express >> Link state power management >> Setting: >> Off
Add new REG_DWORD to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\
Value name: KeepConn
Value data: 65535 (the maximum possible)
Base: Decimal
ii)      Change autodisconnect value
In command window, execute: net config server /autodisconnect:-1

Lastly, I'll mention that the earlier discussions about a "Group Policy" approach turned out to be irrelevant, as our PCs are not part of a domain and have local administer privileges.

Hopefully the above information will be of use to someone.

Thank you for your suggestions and encouragement throughout this. I’ll mark this as the solution and award you the points for your help.

All the best, Paul.
0
 
Paul McCabeAuthor Commented:
It was the only solution that solved the problem.
0
 
Paul McCabeAuthor Commented:
Update:
I discovered a fix for the “mapped drive red X on startup” we previously wrestled with. Disabling Windows 10 fast startup solved the problem, and the mapped drive is now always connected on startup. Instructions for disabling fast startup are on the following page: https://www.windowscentral.com/how-disable-windows-10-fast-startup
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 6
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now