OSPF/RIP Redistribution

OSPF/RIP Redistribution

I have this topology :
I have advertised networks 1.1.1.1/24 and 192.168.12.0/24 into OSPF
 then Redistributed   OSPF to RIP with metric 10. Now : 1.1.1.1/24  shows with metric of 10 in R3 RIP Routing table, but 192.168.12.0/24  still shows with metric of 1.





ospf
R1(config-router)#do sh run 
Building configuration...

Current configuration : 1412 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown 
 duplex auto
 speed auto
 !
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!         
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R1(config-router)# 

Open in new window


R2(config-router)#do sh run 
Building configuration...

Current configuration : 1515 bytes
!
! Last configuration change at 06:23:44 UTC Sat Feb 17 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex half
 !
!
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !        
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 192.168.12.0 0.0.0.255 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 10
 network 192.168.23.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R2(config-router)#

Open in new window


R3(config)#do sh run 
Building configuration...

Current configuration : 1382 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
 duplex half
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown 
 duplex auto
 speed auto
 !
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router rip
 version 2
 network 3.0.0.0
 network 192.168.23.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!         
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R3(config)# 

Open in new window



Now if I look at R3 routing table, the network 192.168.12.0/24 which is in OSPF , still shows with metric of 1 instead of 10

R3(config)#do sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/10] via 192.168.23.2, 00:00:25, FastEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:25, FastEthernet0/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.23.0/24 is directly connected, FastEthernet0/0
L        192.168.23.3/32 is directly connected, FastEthernet0/0
R3(config)#
jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Something is very wrong, resulting route table does not make any sense. Double check your running configurations again.
Since it did not make any sense I pasted your configurations and resulting routing table is:

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1/32 [120/10] via 192.168.23.2, 00:00:14, GigabitEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3/32 is directly connected, Loopback0
R    192.168.12.0/24 [120/10] via 192.168.23.2, 00:00:14, GigabitEthernet0/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, GigabitEthernet0/0
L       192.168.23.3/32 is directly connected, GigabitEthernet0/0

Network 192.168.12.0/24 is as expected 10 hops away.
I guess in you case on R2 network 192.168.12.0/24 is advertised into RIP (not present on R2 configuration above).
0
jskfanAuthor Commented:
if you check R2 configuration, I have :
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 192.168.12.0 0.0.0.255 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 10
 network 192.168.23.0
 no auto-summary

Open in new window

0
JustInCaseCommented:
I checked configuration, but end result does not match that configuration. The only way to have network 192.168.12.0/24  1 hop away is that RIP advertises 192.168.12.0/24 on R2. There is no other way (except some bug).
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

jskfanAuthor Commented:
R1#sh run | sec router 
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
R1#

Open in new window


R2#sh run | sec router 
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 192.168.12.0 0.0.0.255 area 0
router rip
 version 2
 redistribute ospf 1 metric 10
 network 192.168.23.0
 no auto-summary
R2#

Open in new window


R3#sh run | sec router 
router rip
 version 2
 network 3.0.0.0
 network 192.168.23.0
 no auto-summary
R3#

Open in new window


I could not see where 192.168.12.0/24  is advertised  by RIP
0
jskfanAuthor Commented:
that's weird though... it shows here that's known via RIP:

R3#sh ip route 192.168.12.0
Routing entry for 192.168.12.0/24
 Known via "rip", distance 120, metric 1
 Redistributing via rip
  Last update from 192.168.23.2 on FastEthernet0/0, 00:00:20 ago
  Routing Descriptor Blocks:
  * 192.168.23.2, from 192.168.23.2, 00:00:20 ago, via FastEthernet0/0
      Route metric is 1, traffic share count is 1
R3#
0
JustInCaseCommented:
Sure it is known by RIP. But does not looks like redistributed into RIP on R2 since, if it was redistributed into RIP from OSPF, in that case, it suppose to have hop count of 10.

Go to R2 and issue:

sh ip rip database

What is the output?
0
jskfanAuthor Commented:
R2#sh ip rip database 
1.0.0.0/8    auto-summary
1.1.1.1/32    redistributed
    [10] via 192.168.12.1, from 1.1.1.1, 
3.0.0.0/8    auto-summary
3.3.3.3/32
    [1] via 192.168.23.3, 00:00:14, FastEthernet1/0
192.168.12.0/24    auto-summary
192.168.12.0/24    redistributed
    [1] via 0.0.0.0, 
192.168.23.0/24    auto-summary
192.168.23.0/24    directly connected, FastEthernet1/0
R2#

Open in new window

0
JustInCaseCommented:
I uploaded your configs. It should look like this:

R2(config-router)#do sh ip rip database
1.0.0.0/8    auto-summary
1.1.1.1/32    redistributed
    [10] via 192.168.12.1, from 1.1.1.1,
3.0.0.0/8    auto-summary
3.3.3.3/32
    [1] via 192.168.23.3, 00:00:08, FastEthernet0/1
192.168.12.0/24    auto-summary
192.168.12.0/24    redistributed
    [10] via 0.0.0.0,
192.168.23.0/24    auto-summary
192.168.23.0/24    directly connected, FastEthernet0/1
R2(config-router)#

via 0.0.0.0 means this router (localy injected into RIP).
R2 advertises 192.168.12.0 with hop count 1. Try to issue on R2:
no router rip
and recreate rip process again
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
I have redone it :
R2#sh run | sec router 
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 192.168.12.0 0.0.0.255 area 0
router rip
 version 2
 redistribute ospf 1 metric 10
 network 192.168.23.0
 no auto-summary
R2#

Open in new window


R3 still shows the same thin:
R3#sh ip rout rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/10] via 192.168.23.2, 00:00:15, FastEthernet0/0
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:15, FastEthernet0/0
R3#
0
jskfanAuthor Commented:
R2#sh ip rip database
1.0.0.0/8    auto-summary
1.1.1.1/32    redistributed
    [10] via 192.168.12.1, from 1.1.1.1,
3.0.0.0/8    auto-summary
3.3.3.3/32
    [1] via 192.168.23.3, 00:00:10, FastEthernet1/0
192.168.12.0/24    auto-summary
192.168.12.0/24    redistributed
    [1] via 0.0.0.0,
192.168.23.0/24    auto-summary
192.168.23.0/24    directly connected, FastEthernet1/0
R2#
0
JustInCaseCommented:
I don't know how you get those results with the above configuration.
0
jskfanAuthor Commented:
I wonder if it was a Bug in GNS 3, or I have configured something different that what I have just done on IOU Web.

I have used IOU Web, and got the correct results:

Router#sh run  | sec router 
router ospf 1
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
Router#

Open in new window



Router#sh run | sec router 
router ospf 1
 redistribute rip subnets
 network 192.168.12.0 0.0.0.255 area 0
router rip
 version 2
 redistribute ospf 1 metric 10
 network 192.168.23.0
 no auto-summary
Router#

Open in new window



Router#sh run | sec router 
router rip
 version 2
 network 3.0.0.0
 network 192.168.23.0
 no auto-summary
Router#

Open in new window



Router#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/10] via 192.168.23.2, 00:00:16, Ethernet0/0
R     192.168.12.0/24 [120/10] via 192.168.23.2, 00:00:16, Ethernet0/0
Router#

Open in new window


We can see the metric now is 10 on RIP
0
JustInCaseCommented:
I tested configurations in GNS3 and packet tracer. Resulting RIB on R3 was OK each time.
0
jskfanAuthor Commented:
Ok.. at least it worked now.
Thank you for your Help
0
JustInCaseCommented:
You're welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.