Why is the Attribute tab missing?

I am trying to view attributes of an AD User Object. I have enabled advanced view and I can see additional tabs compared to when advanced view is not enabled but the Attribute tab does not show. What is causing this? is there some kind of security feature enabled?
missing-atribute-tab.JPG
r_gibsonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zvitamConsultantCommented:
In order to display the attribute editor tab you have to enable the Advance Features in AD User and computers for further information see here
0
r_gibsonAuthor Commented:
The advanced Features is enabled but the attribute tab is not showing. Other Tabs like Dial-in display in advanced mode but not Attribute. See the screenshot.
0
Seth SimmonsSr. Systems AdministratorCommented:
if the object you are looking at is the result of a search, the tab does not appear
not sure why, but i have never seen that tab on an object in the find window; only through navigating directly to the OU
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

r_gibsonAuthor Commented:
I have directly navigated to the object, right clicked and selected Properties and I get the tabs as shown in the screenshot but not the attribute tab. I have tried on both DC and get the same - no attribute tab. I have turned off advanced features and tried to turn it back on but it makes no difference - still no attribute tab.
0
Kevin StanushApplication DeveloperCommented:
What is the AD functional level/version?  And what sort of client o/s do you have?  You may need to just reinstall RSAT in case something removed the property sheet extension that this tab relies on.
0
r_gibsonAuthor Commented:
the DC are running server 2012R2 and the domain functional level is 2012R2. I use the ADUC on the DC themselves. I have also tried from out exchange server that has the ADUC tool installed and get the same results.
0
Kevin StanushApplication DeveloperCommented:
The only thing that can cause this is that you are missing the registration information in the schema for the attribute editor.  You can check this by following this discussion:

https://social.technet.microsoft.com/Forums/sharepoint/en-US/6e6ef6bd-b5c9-4f16-b346-097832e3b93c/rsat-and-the-missing-attribute-editor-tab-solution?forum=winserverManagement

Before attempting this fix, I would make a backup, as modification of this container can hose thing up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
r_gibsonAuthor Commented:
That has fixed the issue. Thanks very much for your help.
0
Kevin StanushApplication DeveloperCommented:
Good fix.  Wierd that this happens though.  For an easier way to get AD attributes exported (in a GUI), consider taking Hyena for a test drive:

https://www.systemtools.com/hyena

You can customize any AD query to get just the attributes you want, export it, and even manage the accounts without needing to use ADUC.
0
Shaun VermaakTechnical Specialist/DeveloperCommented:
PS: A way to get past the missing tab in a search is to
  1. Search for object
  2. In Member of tab open a group that object belongs in
  3. Close original dialog box
  4. In group dialog box, under "Members" double-click original object you searched for
You will then have Attributes tab
0
r_gibsonAuthor Commented:
Worked like a treat. Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.