Cisco 1841 interfaces down

Hi

I connected to the console port of an operational Cisco Router 1841 in order to reset the admin password

I followed the first section of this step by step guide

All went well until after the final reboot - as you can see below the FastEthernet0/0.1 and FastEthernet0/0.2 vlans are both down :

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
FastEthernet0/0.1          XXX.XXX.XXX.XXX   YES NVRAM  administratively down down
FastEthernet0/0.2          XXX.XXX.XXX.XXX     YES NVRAM  administratively down down
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
ATM0/0/0                   unassigned      YES NVRAM  administratively down down
ATM0/0/0.1                 unassigned      YES unset  administratively down down
ATM0/1/0                   unassigned      YES NVRAM  administratively down down
ATM0/1/0.1                 unassigned      YES unset  administratively down down
Virtual-Access1            unassigned      YES unset  up                    up
Dialer1                    unassigned      YES NVRAM  up                    up
Dialer2                    unassigned      YES NVRAM  up                    up

Even though the FastEthernet0/0 was previously down (as required by the running config) the FastEthernet0/0.1 and FastEthernet0/0.2 vlan interfaces were previously both up

I tried a 'no shut' on both of them but to no avail :
en
conf t
int FastEthernet0/0.1
no shut 
exit
exit

Open in new window


I then tried to enable FastEthernet0/0 which then brought both 0/0.1 and 0/0.2 interfaces up
but the Internet access isn't up so that doesn't seem to be the solution

There is a Catalyst 2960 connected to F0/0

As you can tell I'm no Cisco expert

Any ideas ?

Thanks
yann


Here is the running config :

Current configuration : 6617 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec localtime year
service timestamps log datetime msec localtime year
service password-encryption
!
hostname J206099_rt1841
!
boot-start-marker
boot-end-marker
!
logging buffered 32000
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
!
aaa new-model
!
!
aaa group server radius ssg-proxy
 server xxx.xxx.xxx.xxx auth-port 1812 acct-port 1813
!
aaa accounting suppress null-username
aaa accounting network DHCP start-stop group ssg-proxy
aaa accounting system default start-stop group ssg-proxy
!
!
aaa session-id common
clock timezone MET 1
clock summer-time MET recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp binding cleanup interval 10
ip dhcp bootp ignore
no ip dhcp conflict logging
ip dhcp excluded-address 10.62.161.1
!
ip dhcp pool hotspot_vlan2
   network 10.62.161.0 255.255.255.128
   default-router 10.62.161.1
   dns-server 8.8.8.8
   domain-name xxxxxxxxxxx-hotspot.com
   lease 0 0 30
   update arp
   accounting DHCP
!
!
no ip bootp server
no ip domain lookup
ip domain name xxxxxxxxxxxxxxxx.wifi
multilink bundle-name authenticated
!
!
!
!
username AdMinWlan password 7 xxxxxxxxxxxxxxxx
archive
 log config
  hidekeys
!
!
ip ssh version 2
ip rcmd rcp-enable
ip rcmd rsh-enable
ip rcmd remote-host admWifi xxx.xxx.xxx.xxx admWifi enable
ip rcmd remote-host admWifi xxx.xxx.xxx.xxx admWifi enable
!
!
!
interface Loopback0
 no ip address
!
interface FastEthernet0/0
 description connexion vers Infra Interne Hotspot
 no ip address
 shutdown
 speed 100
 full-duplex
 no cdp enable
!
interface FastEthernet0/0.1
 description vlan admin
 encapsulation dot1Q 1 native
 ip address xxx.xxx.xxx.xxx 255.255.255.224
 no ip redirects
 no ip unreachables
 no cdp enable
!
interface FastEthernet0/0.2
 description vlan hotspot
 encapsulation dot1Q 2
 ip address xxx.xxx.xxx.xxx 255.255.255.128
 ip access-group 110 in
 no ip redirects
 no ip unreachables
 no cdp enable
 arp authorized
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
 snmp trap link-status
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/1/0.1 point-to-point
 snmp trap link-status
 pvc 8/35
  oam-pvc manage
  encapsulation aal5mux ppp dialer
  dialer pool-member 2
 !
!
interface Dialer1
 ip address negotiated
 no ip redirects
 no ip unreachables
 ip mtu 1492
 ip load-sharing per-packet
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxxxxxxxxxxxx
 ppp chap password 7 xxxxxxxxxxxxxxxxxxxxx
!
interface Dialer2
 ip address negotiated
 no ip redirects
 no ip unreachables
 ip mtu 1492
 ip load-sharing per-packet
 encapsulation ppp
 no ip mroute-cache
 dialer pool 2
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxxxxxxxxxxx
 ppp chap password 7 xxxxxxxxxxxxxxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
!
no ip http server
no ip http secure-server
!
ip radius source-interface FastEthernet0/0.1

no cdp run
!
radius-server host xxx.xxx.xxx.xxx auth-port 1812 acct-port 1813 key 7 xxxxxxxxxxxxxxxxx
radius-server timeout 1
radius-server deadtime 1
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
banner login 
!
line con 0
 exec-timeout 5 0
line aux 0
line vty 0 4
 exec-timeout 5 0
 transport input telnet ssh
 transport output none
 escape-character 5
!
scheduler allocate 20000 1000
ntp clock-period 17178405
ntp server xxx.xxx.xxx.xxx
ntp server xxx.xxx.xxx.xxx prefer
end

Open in new window

Yann ShukorOwnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
Hi,

You need the follwing:

interface FastEthernet0/0
no shu
ip nat ins
interface FastEthernet0/1
no shu
ip nat ins
interface Dialer1
ip nat out
interface Dialer2
ip nat out
access-list 100 permit ip any any
ip nat inside source list 100 interface Dialer1 overload
ip nat inside source list 100 interface Dialer2 overload

Open in new window

0
Yann ShukorOwnerAuthor Commented:
Istvan,

Unfortunately there is no improvement

I forgot to mention that all was working fine before my attempt to reset the admin password

Why would I now need to modify the configuration ?

regards
yann
0
Yann ShukorOwnerAuthor Commented:
Could the fact that I changed admin password on the 1800 block the Catalyst 2960 from reconnecting to the router ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Craig BeckCommented:
Your ATM interfaces are shutdown.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Yann ShukorOwnerAuthor Commented:
Thanks Craig

I forgot that when I executed the "sh ip int brief" I was in the config mode required to reset the password

I upped ATM0/0/0 and ATM0/1/0 so now I have the following status :

J206099_rt1841>sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
FastEthernet0/0.1          172.20.62.33    YES NVRAM  administratively down down
FastEthernet0/0.2          10.62.161.1     YES NVRAM  administratively down down
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
ATM0/0/0                   unassigned      YES NVRAM  up                    up
ATM0/0/0.1                 unassigned      YES unset  up                    up
ATM0/1/0                   unassigned      YES NVRAM  up                    up
ATM0/1/0.1                 unassigned      YES unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
Virtual-Access3            unassigned      YES unset  up                    up
Dialer1                    172.19.7.198    YES IPCP   up                    up
Dialer2                    172.19.48.155   YES IPCP   up                    up
Loopback0                  unassigned      YES NVRAM  up                    up

Open in new window


but still no Internet access

Should I write to memory and then reboot ?

regards
yann
0
Craig BeckCommented:
No probs.

Also, the NAT statements need to go on your subinterfaces, not the physical interface.

Check your default route too. You should use...

ip route 0.0.0.0 0.0.0.0 dhcp

...as you're using DHCP on the dialers.
0
Yann ShukorOwnerAuthor Commented:
When I followed the password reset guide it did in fact mention the need to "no shut" the required interfaces, but I wasn't sure which ones

I'm a little confused concerning the NAT statements and the default route
Like I mentioned this router was in operation before I began my password reset quest
If the config was right to begin with, how is it that it was working fine (as was) ?

On which sub-interfaces should I enable the NAT : FE, ATM or Dialer ?

Incidently the the link between the Catalyst and F0/0 on the 1800 still isn't active, any ideas ?

yann
0
Istvan KalmarHead of IT Security Division Commented:
FastEthernet0/0            unassigned      YES NVRAM  administratively down down

so you need to enable it:

int fa0/0
no shu

Open in new window

1
Yann ShukorOwnerAuthor Commented:
Bingo, thanks Istvan

So basically my issue was simply no having upped the required interfaces following the password reset procedure

Gosh, I feel really silly

Thanks Istvan and Craig for your precious help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.