DFSR failing on main domain controller

DFSR replication seems to be failing on my Domain Controller that holds all the domain roles.

Every 5 minutes i get errors 2104 / 2212 and 2106 on the domain controller.

The other domain controllers report

The DFS Replication service is stopping communication with partner domaincontrller for replication group Domain System Volume due to an error. The service will retry the connection periodically.
 
Additional Information:
Error: 9033 (The request was cancelled by a shutdown)
Connection ID: 8DAD90BA-150D-4DA4-9F30-5EED852B6CA4
Replication Group ID: 1996DD82-0403-4C8D-967F-99591BE03D71


and

The DFS Replication service encountered an error communicating with partner DomainController for replication group Domain System Volume.
 
Partner DNS address: DomainController.domain
 
Optional data if available:
Partner WINS Address: Domaincontroller
Partner IP Address: IP
 
The service will retry the connection periodically.
 
Additional Information:
Error: 1753 (There are no more endpoints available from the endpoint mapper.)
Connection ID: 8DAD90BA-150D-4DA4-9F30-5EED852B6CA4
Replication Group ID: 1996DD82-0403-4C8D-967F-99591BE03D71


I have checked the permissions for the System information folder and it all looks ok on the failing DC, i have also tried stopping the service, moving the DFSR folder and letting it rebuild it but still get the same error messages.

What can i do to fix this issue? I am worried that it will cause sync issues on my domain.
LVL 6
CaptainGibletsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
Have you tried rebooting the DCs?
0
CaptainGibletsAuthor Commented:
No joy, I just moved the roles to another DC and demoted it.
0
MaheshArchitectCommented:
can you check if other dcs are replicating with dfsr correctly ?
if yes, on faulting dc check if sysvol and net logon shares are shared
I believe you need to do sysvol non authoritative restore on this dc,
before u do that if server contains fsmo, move all fsmo to different server and force ad replication and check if output of below commands is same on all servers ?
follow steps in below article
https://www.experts-exchange.com/articles/17360/Active-Directory-DFSR-Sysvol-Authoritative-and-Non-Authoritative-Restore-Sequence.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MaheshArchitectCommented:
forgot to add command details
netdom query fsmo
the command should be run on all dcs
0
CaptainGibletsAuthor Commented:
thanks for help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.