Powershell Send-SmigServerData command as Admin

Hi Guys

Powershell Problem.

I'm using 'Server Migration Tools' to migrate 'User Personal' data from a Windows Server 2008 Standard to a Windows Server 2012 R2.

Installing the tools and the send and receive connectors on Source and destination servers is fine. But, when I run the 'ServerMigration.psc1' on the 2008 server so that I can run the Send-SmigServerData.... command I get told:

Send-SmigServerData : This cmdlet requires Administrator permissions. Open Windows Powershell with admin privileges.


I cannot right-click the .psc1 file and 'run as' admin so instead I have opened the 'Run' dialog box and run the following:

PowerShell -NoExit “C:\Windows\System32\ServerMigrationTools\DeploymentFolder\SMT_ws08_x86\ServerMigration.psc1”

This runs and opens the script just fine but when running the Send-SmigServerData command again I now get the following error:

The term 'Send-SmigServerData' is not recognised as the name of the cmdlet.

I need to run the ServerMigration.psc1 script as Admin and for the PS Window to stay open so that the Send-SmigServerData command can be run.

In advance thank you for your support.
LVL 2
CTCRMInfrastructure EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

oBdACommented:
From the Run menu, use
powershell.exe -PSConsoleFile "C:\Windows\System32\ServerMigrationTools\DeploymentFolder\SMT_ws08_x86\ServerMigration.psc1" -NoExit

Open in new window

Or open an administrative PowerShell console any which way you prefer, and in this console enter
& "C:\Windows\System32\ServerMigrationTools\DeploymentFolder\SMT_ws08_x86\ServerMigration.psc1"

Open in new window

Or open an administrative Command prompt (cmd.exe) any which way you prefer, and enter (including the empty pair of quotes!)
start "" "C:\Windows\System32\ServerMigrationTools\DeploymentFolder\SMT_ws08_x86\ServerMigration.psc1"

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CTCRMInfrastructure EngineerAuthor Commented:
Hi oBdA
The 3rd option worked for me so thank you for that.

However, I'm getting the 'Starting the connected transport failed', so I have ensured that the Local Users & Groups were Exported/Imported but still getting the same connected transport failed.

I may have to use GS Richcopy 360 or even a Robocopy...
0
oBdACommented:
Question answered.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.