Security Alert connecting to RDS Farm

I'm setting up a Windows Server 2016  Remote Desktop farm, consisting of 3 RDS hosts, a connection broker and a dedicated server with the web access and gateway role. I have created the server collection and the DNS round robin entries, with the name of my collection pointing to the RDS hosts.

However recently we have noticed when users are connecting to the name of the collection, they are receiving security alerts:
'the certificate is not from a trusted certfying authority;
This is all 3 RDS Hosts.

When the certificate is installed on one of the terminals, the error is then:
The name on the security certificate is invalid or does not match the name of the site

The strange thing is there is never been a certificate attached to:
RD connection broker : Enable single-sign on
RD connection broker: Publishing

Do I need to purchase an SSL certicate that includes:
The farm name, the rds hosts, the connection broker
certerror.jpg
plokij5006Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zaheer IqbalTechnical Assurance & ImplementationCommented:
Click on the certification path and post a screenshot.
0
Cliff GaliherCommented:
Don't set up DNS round Robin. The connection broker will handle forwarding to the hosts  and attempting to use round Robin breaks things. That method changed with 2012.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
plokij5006Author Commented:
The certification path is just the 'servername'
If this is installed on the one of the client machines, that message appears, but the message:
"the server name on the certificate is incorrect"

All I need is how to fix this:
Is it a wildcard certificate I need from an SSL supplier like godaddy
This will then be added to RD CONNECTION BROKER> ENABLE SINGLE + RD CONNECTION BROKER - PUBLISHING

Thanks again,
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Cliff GaliherCommented:
You're asking the wrong question. The certificate is wrong because round Robin DNS is interfering either how RDS is supposed to work on 2012 and is actually causing a name mismatch. The problem isn't the certificate... Or wasn't... Could bee now if many attempts were made to replace them.

In 2012, the connection broker does load balancing and redirection, which neither requires DNS changes nor special certificates on the session hosts because the connection broker will include the right name in its redirect and that certificate will be on the server by default.
0
plokij5006Author Commented:
Ignore the DNS round robin, This is not set up. This is confirmed
Clients connect to 'name.ts' which then routes them to the connection broker server (as per DNS record)> which then routes the client to 1 of the 3 rdshs as per the load balancing rules.

So the certificate issue error still exits. Just wondering why now our client is getting it, as the RDS deployment has never had a certificate attached to it.

to quote:
" connection broker will include the right name in its redirect and that certificate will be on the server by default."

What certificate?
0
Cliff GaliherCommented:
In a properly set up system (no special steps required), joining a member server to a domain generates a basic certificate as part of that process. And RDS in 2012 expects that systems are domain joined.

The names would normally match. The root may not be trusted but that is a different error than what you've described. The only way to get the error you describe is if steps were actively taken to subvert how the RDCB or member servers work by default.
0
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- Cliff Galiher (https:#a42479005)
-- Cliff Galiher (https:#a42481842)
-- Cliff Galiher (https:#a42482189)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.