DB2 Add User to SYSMON group

DB2 10.5 On Windows

I am trying to use CommVault to backup my DB2 databases and am having permission issues.  When I run the backup through CommVault I get the following.

ERROR CODE [59:41]: Browse operation on database [xxx] could not be completed. Error [ ---- error report ---- app. message = db2GetSnapshotSize line = 783 file = Db2Browse.cpp SQLCODE = -1092 SQL1092N The requested command or operation failed because the user ID does not have the authority to perform the requested command or operation. User ID: "CVADMIN". --- end error report --- db2GetSnapshotSize() failed: Exit.]. Please check the database configuration, user privileges and ensure that the product's services are running on client, server, MediaAgent and then resume.

From what I have read, this means that the user CVADMIN does not have SYSMON permissions.  So I did the following.

1. Check that the server has a group defined for SYSMON.  It does.   SYSMON group name     (SYSMON_GROUP) = NAGIOS
2. On windows, I created a group name NAGIOS and added CVADMIN to it.

From what I read, that should grant CVADMIN SYSMON permission but it is not working.  Still get the same error.   Is there a specific GRANT I have to issue?  IBM has a lot of information on this but none of it is clear to me.  

Thank you.

Jim
Jim YoumansSr Database AdministratorAsked:
Who is Participating?
 
Kent OlsenData Warehouse Architect / DBACommented:
Hi Jim,

This is another "clear as mud" IBM message and documentation.  (They've had a lot of time to make these as obfuscated as possible.  I'm pretty sure their plan is working....)

When was the SYSMON_GROUP value set in the database manager?  DB2 reads the value on instance startup, not on update, so if DB2 hasn't been cycled since the group name was set you'll need to do that.
0
 
Jim YoumansSr Database AdministratorAuthor Commented:
It was there when I checked it so I have to believe it was set up awhile ago and the server is rebooted once a month so that should not be an issue.
0
 
karllangstonSenior Technical ConsultantCommented:
Try running the check readiness report as that will highlight what is missing if anything
http://documentation.commvault.com/commvault/v11/article?p=39708.htm
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.