Scheduled task will not run in WIndows 10

I have a local task built on my Windows 10 machines.  It runs the command shutdown -s -t 30 every night.  It works fine on Windows 7 machines but is not working on my Windows 10 clients.  Can you tell me what could be causing the stoppage?
David ImbrognoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew LeniartFreelance JournalistCommented:
Hi,

Please try to use / to set the shutdown switches.

Ie:  Shutdown.exe /s /t 30

I'd also recommend using the /f switch, as in "Shutdown.exe /s /f /t 30"  (Forces closing of any open programs)

Hope that's helpful.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Farbood NajafiSystem AdministratorCommented:
Try to schedule with  administrator user
0
Hello ThereSystem AdministratorCommented:
It doesn't really matter which kind of switch you use.
Make sure the task in Enabled. Also you need to use elevated account as mentioned above.

You have to use -f switch since there are some processes running and Windows will not allow you to get over it.
Try it with -f switch and see the difference.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Andrew LeniartFreelance JournalistCommented:
@Hello There
The /f switch is implied if /t is greater than zero anyway.

I just prefer to include it - commands in my experience don't always perform as designed. It's also handy if you set /t to zero in the future. Including it does no harm and can prevent issues at a later date.
0
David ImbrognoAuthor Commented:
Thanks for all the help
0
McKnifeCommented:
Did it make a difference to add /f? It should not.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.