Limited access to micro-sd card on Samsung Tab.

Have inserted a 32GB microSD card in my Samsung Tablet GT-P5210 running Android 4.4.2
Card shows ok, and I'm able to create new folders on the sd card.
Files copied to the card when card is connected directly to my PC works well, and files are accessed without problems.

When trying to copy files from external sources (a Win PC), using a file manager on the Tab, I get an error message on the Tab, saying no access.
Have tried two different file managers, and both show the same. Error message also say something about rooting.
Copying from the tab's internal memory to the sd-card works well. Creating new folders on the sd-card also works well.
Any ideas how to fix this?
Olaf BerliAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brandon LyonSenior Frontend DeveloperCommented:
Can you be a little more specific about what you're trying to do? What devices and operating system versions, what applications, what data transfer mode, what are the steps to reproduce the problem, etc?

Here is an example of a more thorough request for assistance. The more data we have the easier it is to troubleshoot :

I'm trying to copy data...
FROM my Samsung Galaxy Tab S3 running Android N (7.0)
TO my Windows 10 laptop
via USB in MTP mode [or possibly MSC mode (sometimes phrased as "photos" or "files" or "media")]
Using the application "Solid Explorer" 2.3.7
I would like to copy the files in /storage/emulated/0/Downloads
into the folder C:/users/xxxxx/Documents/SDCard/
I tried the following steps
1. Plugged the USB C cable into a compatible port on the back of my desktop computer.
2. When prompted by my phone I selected "Media Storage" mode.
3. On my phone I opened the app "Solid Explorer".
3. I navigated to the SD Card folder.
3. Copied all the files with a long press
3. ???
But received the following error message verbatim:
"You need to grand SD card access to Solid Explorer in order to complete this operation..."
0
Olaf BerliAuthor Commented:
OK. Thanks for reminding me about being clear and provide the info needed to understand the problem.

Needed more memory in my Samsung Tablet GT-P5210 running Android 4.4.2.
Installed a micro-SD card, 32GB.
Card shows ok on the tab, and I'm able to access files on the sd-card (like music, pictures etc.)
Moving files between internal memory and SD-card also works well.
To move some music files (.mp3) to the SD-card, I removed it from the tab and inserted it into a usb-adapter, connected to my Win 7 PC. This also worked well. After moving the SD-card back to the tab, I could access the files just fine.

To avoid moving the SD-card (physically) between the tab and the USB-adapter on the PC, I tried the following steps.

1. Installed ES File Explorer on the tab
2. Connected via local wireless LAN to a shared directory E:\Music\Rock on the Win7 PC where the files I wanted to transfer were located
3. Made a new folder on the tab where the files should be stored (Music\Rock). Worked fine.
4. Selected the files I wanted to transfer in the shared directory. Selected "copy".
5. Selected destination directory on the tab and pressed "paste"
6 Got an error message saying:"Your system forbids ES from writing on external SD card (check https://code.google.com/p/android/issues/detail?id=67570) so ES can only write on it after it is rooted"

Also tried an app called File Commander, but got a similar error message.

Any ideas how to "root" the sd-card or solve this problem?
0
Brandon LyonSenior Frontend DeveloperCommented:
Thank you for the clarification. How is the memory card formatted? Is it NTFS, FAT32, or other? If it is something other than FAT32 then the Android system might have trouble writing to the SD card.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Olaf BerliAuthor Commented:
It is FAT32.
And - Android is able to access the card when it is an "internal" operation - like copying files from the system/internal memory to the sd-card.
It seems like the problem is when an Android app (ES File Explorer or File Commander) is trying to copy or move files from sources external to the tablet into the sd-card.
0
Brandon LyonSenior Frontend DeveloperCommented:
Unfortunately OS version 4.4.2 is an odd spot in Android history. Right around then Google started to restrict direct access to the SD cards when a device doesn't have root. Later versions of Android removed this restriction.

It looks like there might be a way around this but I don't have any devices to test with. You can try this link to see if it helps.
http://www.instructables.com/id/How-to-bypass-Android-44-KitKat-external-SD-write-/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Olaf BerliAuthor Commented:
Thanks for the info. Tried it, and - as stated at the end of the article - "Certainly it’s just a temporary and, probably, not the most elegant solution, however it works.".

The B1 file manager is able to create a sandbox directory on the sd card and to copy external files and folders into this sandbox. It can't, however, move them from the sandbox to the "real" directories. Fortunately the "My Files" app that is included in Android is able to move the files / folders into the place where I want to have them. Seems like apps, like music player, video player and the gallery app are not able to access the sanbox directly...

In my case, I find it easier, when there is a need to manage files on the sd card, to move the card to an USB-adapter, connect it to my PC and copy, delete or manage the files directly on the PC.
0
Olaf BerliAuthor Commented:
Thanks for your feedback and help :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Tablets

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.