Redistribution RIP/OSPF/EIGRP

Redistributing RIP /OSPF / EIGRP

red
in the displayed topolgy

R1 has loopback 0 with ip 1.1.1.1/24

RIP is configured on R1 and R2
OSPF is configured on R2 and R3
EIGRP is configured between R2 and R4 and between R4 and R3


in the configuration below the redistribution is just on R2, however I can reach end to end in optimal way.  Probably it could have been a problem if OSPF or EIGRP is only between R3 and R4 . I mean if I had between R2 and R3 and between R2 and R4 the same IP routing protocol and between R3 and R4 a different IP routing protocol, I might run into Sub-optimal routing issue.




R1#sh run 
!
hostname R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
router rip
 version 2
 network 1.0.0.0
 network 192.168.12.0
 no auto-summary
R1#

Open in new window


R2#sh run 
hostname R2
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
interface Ethernet0/2
 ip address 192.168.24.2 255.255.255.0
router eigrp 1
 network 192.168.24.0
 redistribute rip metric 5 1000 255 255 1500
!         
router ospf 1
 redistribute rip subnets
 network 192.168.23.0 0.0.0.255 area 0
!
router rip
 version 2
 redistribute eigrp 1 metric 5
 redistribute ospf 1 metric 5
 network 192.168.12.0
 no auto-summary

R2#

Open in new window



R3#sh run 
hostname R3
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.34.3 255.255.255.0
router eigrp 1
 network 192.168.34.0
!         
router ospf 1
 network 192.168.23.0 0.0.0.255 area 0

R3#

Open in new window



R4#sh run 
hostname R4
interface Ethernet0/0
 ip address 192.168.24.4 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.34.4 255.255.255.0

router eigrp 1
 network 192.168.24.0
 network 192.168.34.0
R4#

Open in new window


The redistribution is configured just on R2


R4#sh ip route | exclude L|C
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
D EX     1.1.1.0 [170/512281600] via 192.168.24.2, 02:13:30, Ethernet0/0
D EX  192.168.12.0/24 [170/512281600] via 192.168.24.2, 02:13:30, Ethernet0/0
      192.168.24.0/24 is variably subnetted, 2 subnets, 2 masks
      192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks

R4#

Open in new window


R3#sh ip route | exclude L|C
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
O E2     1.1.1.0 [110/20] via 192.168.23.2, 02:24:55, Ethernet0/0
O E2  192.168.12.0/24 [110/20] via 192.168.23.2, 02:25:07, Ethernet0/0
      192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
D     192.168.24.0/24 [90/307200] via 192.168.34.4, 03:01:30, Ethernet0/1
      192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks

R3#

Open in new window


R2#sh ip route | exclude L|C
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/1] via 192.168.12.1, 00:00:02, Ethernet0/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
      192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
      192.168.24.0/24 is variably subnetted, 2 subnets, 2 masks
D     192.168.34.0/24 [90/307200] via 192.168.24.4, 03:02:04, Ethernet0/2

R2#

Open in new window



R1#sh ip route | exclude L|C
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
R     192.168.23.0/24 [120/5] via 192.168.12.2, 00:00:02, Ethernet0/0
R     192.168.24.0/24 [120/5] via 192.168.12.2, 00:00:02, Ethernet0/0
R     192.168.34.0/24 [120/5] via 192.168.12.2, 00:00:02, Ethernet0/0

R1#

Open in new window

jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Not sure what is question here.

If there is a single point for redistribution, like here on R2, there will not be suboptimal routing issue.
Routing loops and suboptimal routing are typically present when there are multiple mutual redistribution points (more than one router on which redistribution between protocols happens).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
Actually it started as question, until I reviewed the configuration, and noticed the redistribution is only on R2,  then wanted to make it a comment
0
jskfanAuthor Commented:
Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.