• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8255
  • Last Modified:

TOR Browser: Secure Connection Failed

When i try to search using the Tor Browser opening screen, I receive a "Secure Connection Failed" error no matter what I try in the address bar
This is using the latest 7.5
Any solutions, ideas?
1
GNOVAK
Asked:
GNOVAK
  • 16
  • 10
  • 3
  • +2
1 Solution
 
btanExec ConsultantCommented:
May be the antivirus is causing the issue. See if you can whitelist TOR. Here is one instance for Kaspersky. But do make sure you do manual scan separately to make received data are safe enough to use.

https://www.google.com.sg/amp/s/amp.reddit.com/r/TOR/comments/7zpsm5/secure_connection_failed_no_matter_what_site/
0
 
GNOVAKAuthor Commented:
I tried that - TOR Browser is listed under Trusted applications.
I also run Acronis protection and it is also listed under that as well.
Anyone have another idea or two?
0
 
btanExec ConsultantCommented:
Adjust SSL setting on Firefox
Type about:config in the address bar and press Enter key on your keyboard.
The warning page would shows up. Click I accept the risk to go on.
Copy security.ssl.enable_ocsp_stapling from here to paste on the search bar of the open page.
Then double-click on it from the result to set its Value to be false.
Now try to connect the website again to see if the error has gone.
  1. Your computer’s system clock must be set correctly, or Tor will not be able to connect.
  2. Make sure another Tor Browser is not already running. If you’re not sure if Tor Browser is running, restart your computer.
  3. Make sure that any antivirus program you have installed is not preventing Tor from running. You may need to consult the documentation for your antivirus software if you do not know how to do this.
  4. Temporarily disable your firewall.
  5. Delete Tor Browser and install it again. If updating, do not just overwrite your previous Tor Browser files; ensure they are fully deleted beforehand.
If you still can’t connect, your Internet Service Provider might be censoring connections to the Tor network. Read the Circumvention section for possible solutions.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
GNOVAKAuthor Commented:
Thanks LVL66 - the setting is set to false. I rebooted, I disabled the firewall (Kaspersky only - dont use the windows one). I still cant get to even google. I have spectrum and life should be good there for TOR.
The only other two items that are "different" is Acronis Security (turned that off with no luck) and BoostSpeed (turned that off with no affect).

I think I'm going to remove TOR Browser and start all over. I'll report back.
In the meantime if anyone else thinks of something, let me know.
0
 
GNOVAKAuthor Commented:
I uninstalled TOR (deleted the directory & rebooted).
Got the latest, greatest 7.5
installed and rebooted.
Changed the setting indicated above to false

And... still cant search, cant even test for network settings - still getting the Secure Connection Failed.
The only addons are HTTPS Everywhere, NoScript, Torbutton, TorLauncher.


Anyone? ideas?
0
 
btanExec ConsultantCommented:
Need to try if normal browser can surf internet and if so, try seeing the proxy has other setting  and try removing it and go into internet directly thru broadband dongle. See
Tor can't establish a circuit, here are some hints:

Check your system clock. If it's more than a few hours off, Tor will refuse to build circuits. For Microsoft Windows users, synchronize your clock under the clock -> Internet time tab. In addition, correct the day and date under the 'Date & Time' Tab. Also make sure your time zone is correct.
Is your Internet connection firewalled by port, or do you normally need to use a proxy?
Are you running programs like Norton Internet Security or SELinux that block certain connections, even though you don't realize they do? They could be preventing Tor from making network connections.
Are you in China, or behind a restrictive corporate network firewall that blocks the public Tor relays? If so, you should learn about Tor bridges.
Check your Tor logs. Do they give you any hints about what's going wrong?
https://www.torproject.org/docs/faq.html.en#DoesntWork
And lastly if still no clue, may try configuring bridges
https://www.torproject.org/docs/bridges.html.en
0
 
GNOVAKAuthor Commented:
Well - I tried Safe mode with networks(windows 7 ultimate) and TOR worked. so the clock must be right
SInce it's been a while since I had to work this way, what is the best way to "peel this onion" and either add things one by one to the safe mode or take things off 1 by one?
0
 
btanExec ConsultantCommented:
It is likely still antivirus, trusteer rapport, or similar software since it is working after rebooting Windows into Safe Mode with Networking and starting Tor Browser.

Otherwise, maybe see if browser in safe mode. Select "Start in Safe Mode." Once the window entitled "Firefox Safe Mode" appears, select "Start in Safe Mode." This will temporarily turn off things like add-ons, extensions, themes, etc. in order to troubleshoot Firefox and when you restart Firefox in normal mode, these things will be returned.
0
 
GNOVAKAuthor Commented:
Where do I turn on safe mode only for the browser?
0
 
btanExec ConsultantCommented:
Holding down SHIFT button while starting Tor Browser starts it in non-Tor mode. Apparently it's a Firefox kind of a safe mode startup, in which all the extensions, addons and plugins are disabled. Obviously, this will also prevent Tor launcher / Tor button to do their job (starting the background Tor process, etc.). But at least try to check if connection to Internet still work.
0
 
GNOVAKAuthor Commented:
maybe you're onto something.  When I try that I get:
The proxy server is refusing connections

Firefox is configured to use a proxy server that is refusing connections.

    Check the proxy settings to make sure that they are correct.
    Contact your network administrator to make sure the proxy server is working.


What does that mean in plain terms--ie, where/what do I do to fix it?
0
 
btanExec ConsultantCommented:
If you disable AV and any security software like firewall, and does not work then it is likely some other thing. Tough to know what it is since Safe mode with Networking simply just load minimal drivers for you to get into internet. I guess the browser in safe mode does help since it is just disabling the Tor connection and proxy hence the error seen.

Does the machine has any other software or can we even try uninstall AV and firewall for test sake.. whitelisting in AV and FW doesnt seem to help for you in last testing too?

https://tor.stackexchange.com/questions/15053/tor-doesnt-open-after-initial-install-windows-10/15065
0
 
GNOVAKAuthor Commented:
I'm trying to keep this simple, so I'm using duckduckgo.com as the test. In TOR Browser (TB), It gives me the Secure Conncection Failed.
If I utilize my existing FireFox, it goes there with no problem.
Wouldnt that indicate the problem is related to the Browser somehow?

Do I have to set up something different for the TB?
0
 
btanExec ConsultantCommented:
You cannot reach duckduckgo.com via TB but can reach it via its .onion equivalent like TorDuckGo - see https://www.andrewparadi.com/torduckgo/. It would be some address like e.g.  3g2upl4pq6kufc4m.onion.
Likewise for FF which cannot go to the .onion but can go to the https for duckduckgo
0
 
GNOVAKAuthor Commented:
Still Stumped. I cant get to google.com. nor can I get to the link above about torduckgo. Same security error.
Anyone have ideas on how to narrow down what is causing this?
I've suspended my Kaspersky and Acronis to no avail...
0
 
btanExec ConsultantCommented:
Google cannot be reached using normal https in TB.

if you need to use a local proxy to access the Internet. The steps below assume that you do not. If you do, you need to check your regular browser settings and copy over your proxy configuration. (In Firefox you can find these settings in the Options > Advanced > Network tab of Connection Settings.). Section 3.1 for direct access and 3.2 for restricted access.

Also see 4.1 to check on TB
https://securityinabox.org/en/guide/torbrowser/windows/
0
 
GNOVAKAuthor Commented:
btan,
Appreciate the comment.  My Foxfire proxy is setup to use "system settings".  When I looked at that in my W7 internet options(|LAN Network settings), it says it is  set to "Automatically detect settings".
I tried setting TOR Browser to the same system settings to no avail.

so I'm back to the original question with a bit more knowledge.
If my foxFire can get to https://duckduckgo.com, why cant TB?  

That said, I think my next solution is to boot in a mode where I can add a few items one at a time to the boot sequence.
Does anyone know of a way to do this?
0
 
GNOVAKAuthor Commented:
so while I was playing with btan's comments, I just changed the settings to use system settings AND unchecked the use DNS when using SOCKS5 (dont understand this, but thought I would try at this point.
I get the following:
first duck duck go error
Then, I click get certificate and get this:
after "get certificate is checked
Meanwhile Kaspersky wants me to add the site to its exclusions with a title of "Error during encrypted connection scan".  And, if this was the problem all along (Kaspersky), why did it not work when I deactivated it?  Seems like it was some sort of check from with TB???

so now... I can get to duckduckgo.  Sure wish I knew why this occurred so I can avoid it in the future. However, any of the search results are still giving me the secure connection failed error.
ideas?
0
 
GNOVAKAuthor Commented:
Here's the solution for now, but I need TB help to set up some stuff permanently (unless this eliminates the anonymous browsing):
1) in Tor Browser (TB), go into Options | Advanced | Network  and set Proxies to: "Use system proxy settings"
     (FYI - system settings are set to automatically find proxy - is this bad?)
2) within the connection settings, UNCHECK the box "Proxy DNS when using SOCKS v5"
     (What is this?)
3) Turn off Kaspersky protection
  (ticket into them to see what other alternatives there are to this)

Any idea on how I can permanently have # 1 and #2 set this way in TB?

Note - if either of these three things are not done correctly, I will get an error in TB that doesnt allow me to get to sites.
0
 
Serene JohnsonCommented:
Am having the exact same issue. Had to screw around with Firefox as well as TOR, because updating only one would cause the other to revert back. So I am assuming one of them has had an update and screwed things over.

I dont use this PC very often so I have no idea.
0
 
Serene JohnsonCommented:
Addit: It works with kaspersky untouched, but I had to change the connection and proxy settings in both browsers (thank Jeebus for Chrome so I could still google!) to be able to access content. Any content. And my system clock was spot on.
0
 
GNOVAKAuthor Commented:
Serene -
did you get it to work then?
What did you finally do?
0
 
btanExec ConsultantCommented:
Tor provides a SOCKS proxy by default. And the Tor browser uses a different port (9150) than the standalone Tor program (9050). So I am thinking if we use the SOCK proxy setting instead -

From that menu, you will need to get to the “Networking” and/or “Proxy” section.
From this menu, you will need to enter the proxy settings for the connection.
The “Hostname” will need to be “127.0.0.1” or “localhost”. Either one will work.
The “Port” will need to be set to “9150”.
The “Type” will be set to “Socks5”.
And finally, “Use proxy for” will be need to be set to “All Connections”.
After all this is entered, just hit the “OK” button.
0
 
Serene JohnsonCommented:
I did what was listed above. Except for turning off KIS. But you have to do it to both browsers.
0
 
GNOVAKAuthor Commented:
Well, after all this time... here's my solution:
1)  deleted and reinstalled Kaspersky
2) tried Tor Browser with the settings mentioned above - manual, 170.0.0.1, Socks v5 and port 9150

Worked!!!
BUT
regular firefox did not!
it gave me security errors all over the place that it never used to.

My patience has worn thin. Firefox is no longer my browser of choice - too bad, I thought they had their act together.
So back to Chrome and TB.... works like a charm.
0
 
GNOVAKAuthor Commented:
thanks everyone - this was the best piece of advice from the lot.
appreciate the help/
0
 
GNOVAKAuthor Commented:
Well, if anyone is still around. That didnt help either.  i eliminated and re- added Kaspersky. TB worked for a while. then there was an upgrade for TB. I had to reboot my machine and voila! back to the same security issue even with the settings above.

Is there an alternative to TB?

This has been extremely frustrating!
0
 
btanExec ConsultantCommented:
Does even AV disable work if TB in its upgraded version? The local proxy is one of the means to work otherwise back to first post to check other setting. Also maybe also uninstall FF..
0
 
Jack KilbyCommented:
I have the same problem but i am using Kaspersky total security just change this one option and enjoying the TOR Browser

Image 1

and just select the do not scan the encrypted connection


Image 2
1
 
GNOVAKAuthor Commented:
Jack Kilby:
YES!!!!!

That is THE answer. If I had points left I would gladly give them to you!!
That works like a charm!
0
 
Geoff SmithIT Programme ManagerCommented:
GNOVAK you do need to be aware though, if you read the help in Kaspersky, disabling scanning secure connections impacts among other things the running of the Web Anti Virus protection.  So anywhere you go in TOR is not being scanned for virus's etc.  I would look for a safer option personally.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 16
  • 10
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now